aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-04-06 14:22:03 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-04-06 14:34:39 +0000
commitd95f49cb3b54aa5c685fb3ea73aaf1be76af6111 (patch)
tree982e36e2ac621469ddcc69359019c6937488b288
parent7f878397c39c6719f659192aba7e0e3eb888e072 (diff)
downloadports-d95f49cb3b54aa5c685fb3ea73aaf1be76af6111.tar.gz
ports-d95f49cb3b54aa5c685fb3ea73aaf1be76af6111.zip
databases/p5-DBD-mysql4: new port with verision 4.052
In new branch 5.x upstream removed support of the MariaDB and MySQL 5.7 and earlier: https://github.com/perl5-dbi/DBD-mysql/issues/405#issuecomment-1818501464 This break a lot of installations with MariaDB. Also DBD-MariaDB (databases/p5-DBD-MariaDB) isn't compatable with DBD-mysql and most of ports doesn't support it. PR: 277889 275100 Approved by: flo, arrowd (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D44524
-rw-r--r--databases/p5-DBD-mysql4/Makefile41
-rw-r--r--databases/p5-DBD-mysql4/distinfo3
-rw-r--r--databases/p5-DBD-mysql4/pkg-descr6
-rw-r--r--databases/p5-DBD-mysql4/pkg-plist8
4 files changed, 58 insertions, 0 deletions
diff --git a/databases/p5-DBD-mysql4/Makefile b/databases/p5-DBD-mysql4/Makefile
new file mode 100644
index 000000000000..8adf523032ff
--- /dev/null
+++ b/databases/p5-DBD-mysql4/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= DBD-mysql
+PORTVERSION= 4.052
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DVEEDEN
+PKGNAMEPREFIX= p5-
+PKGNAMESUFFIX= 4
+
+MAINTAINER= sirdice@gmail.com
+COMMENT= MySQL driver for the Perl5 Database Interface (DBI)
+WWW= https://metacpan.org/release/DBD-mysql
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Devel-CheckLib>=1.09:devel/p5-Devel-CheckLib
+RUN_DEPENDS= p5-DBI>=1.08:databases/p5-DBI
+TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep
+
+USES= compiler:c11 mysql perl5
+USE_PERL5= configure
+
+CONFIGURE_ARGS= ${_CONFIGURE_ARGS_${CHOSEN_COMPILER_TYPE}}
+_CONFIGURE_ARGS_gcc= --libs="-L${PREFIX}/lib/gcc${GCC_DEFAULT} `mysql_config --libs | ${SED} 's/-pthread //'`"
+
+CONFLICTS_INSTALL= p5-DBD-mysql
+
+OPTIONS_DEFINE= SSL
+OPTIONS_DEFAULT= SSL
+
+SSL_RUN_DEPENDS= p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay
+SSL_USES= ssl
+SSL_CONFIGURE_ON= --ssl
+SSL_CONFIGURE_OFF= --nossl
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DBD/mysql/mysql.so
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-mysql4/distinfo b/databases/p5-DBD-mysql4/distinfo
new file mode 100644
index 000000000000..f3ee23f99dbb
--- /dev/null
+++ b/databases/p5-DBD-mysql4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711540853
+SHA256 (DBD-mysql-4.052.tar.gz) = a83f57af7817787de0ef56fb15fdfaf4f1c952c8f32ff907153b66d2da78ff5b
+SIZE (DBD-mysql-4.052.tar.gz) = 162074
diff --git a/databases/p5-DBD-mysql4/pkg-descr b/databases/p5-DBD-mysql4/pkg-descr
new file mode 100644
index 000000000000..b07df5f5d210
--- /dev/null
+++ b/databases/p5-DBD-mysql4/pkg-descr
@@ -0,0 +1,6 @@
+DBD::mysql is the Perl5 Database Interface driver for the MySQL
+database. In other words: DBD::mysql is an interface between the Perl
+programming language and the MySQL programming API that comes with the
+MySQL relational database management system. Most functions provided by
+this programming API are supported. Some rarely used functions are
+missing, mainly because noone ever requested them.
diff --git a/databases/p5-DBD-mysql4/pkg-plist b/databases/p5-DBD-mysql4/pkg-plist
new file mode 100644
index 000000000000..bac17eb1028f
--- /dev/null
+++ b/databases/p5-DBD-mysql4/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_ARCH%%/Bundle/DBD/mysql.pm
+%%SITE_ARCH%%/DBD/mysql.pm
+%%SITE_ARCH%%/DBD/mysql/GetInfo.pm
+%%SITE_ARCH%%/DBD/mysql/INSTALL.pod
+%%SITE_ARCH%%/auto/DBD/mysql/mysql.so
+%%PERL5_MAN3%%/Bundle::DBD::mysql.3.gz
+%%PERL5_MAN3%%/DBD::mysql.3.gz
+%%PERL5_MAN3%%/DBD::mysql::INSTALL.3.gz