aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-12-17 00:51:44 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-17 01:06:23 +0000
commitda36e637247b8899cc81731b2c6172afae98dc06 (patch)
tree3a80e734f0cd269ff9c05d6e5dbeff1b3fa7be5d
parent09e810a8fba2bf78ae954325348b35ebd42c6ddc (diff)
downloadports-da36e637247b8899cc81731b2c6172afae98dc06.tar.gz
ports-da36e637247b8899cc81731b2c6172afae98dc06.zip
devel/kf5-kconfig: add dependency on qt5-declarative
In 5.89 a component was moved from kf5-kdeclarative to kf5-kconfig, but the activation is based on optionally installed qt5-declarative. This might get moved to a default-on option in the future. This also makes the optional qt5-declarative available transitively in devel/kf5-knotifications, which therefore was also updated to explicitely depend on that. Reported by: se, jkim
-rw-r--r--devel/kf5-kconfig/Makefile3
-rw-r--r--devel/kf5-kconfig/pkg-plist6
-rw-r--r--devel/kf5-knotifications/Makefile3
-rw-r--r--devel/kf5-knotifications/pkg-plist2
4 files changed, 12 insertions, 2 deletions
diff --git a/devel/kf5-kconfig/Makefile b/devel/kf5-kconfig/Makefile
index 76ab4a9cdd9a..e0efe3eb40a8 100644
--- a/devel/kf5-kconfig/Makefile
+++ b/devel/kf5-kconfig/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kconfig
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +12,7 @@ LICENSE= LGPL21+
USES= cmake compiler:c++11-lib cpe kde:5 qt:5 tar:xz
CPE_VENDOR= kde
USE_KDE= ecm_build
-USE_QT= core dbus gui linguisttools xml \
+USE_QT= core dbus declarative gui linguisttools xml \
buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/devel/kf5-kconfig/pkg-plist b/devel/kf5-kconfig/pkg-plist
index a6e2e0f608b9..8230d6dceab5 100644
--- a/devel/kf5-kconfig/pkg-plist
+++ b/devel/kf5-kconfig/pkg-plist
@@ -32,6 +32,9 @@ include/KF5/KConfigGui/kconfigloader.h
include/KF5/KConfigGui/kconfigskeleton.h
include/KF5/KConfigGui/kstandardshortcut.h
include/KF5/KConfigGui/kwindowconfig.h
+include/KF5/KConfigQml/KConfigPropertyMap
+include/KF5/KConfigQml/kconfigpropertymap.h
+include/KF5/KConfigQml/kconfigqml_export.h
include/KF5/kconfig_version.h
lib/cmake/KF5Config/KF5ConfigCompilerTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/KF5Config/KF5ConfigCompilerTargets.cmake
@@ -46,6 +49,9 @@ lib/libKF5ConfigCore.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libKF5ConfigGui.so
lib/libKF5ConfigGui.so.5
lib/libKF5ConfigGui.so.%%KDE_FRAMEWORKS_VERSION%%
+lib/libKF5ConfigQml.so
+lib/libKF5ConfigQml.so.5
+lib/libKF5ConfigQml.so.%%KDE_FRAMEWORKS_VERSION%%
lib/libexec/kf5/kconf_update
lib/libexec/kf5/kconfig_compiler_kf5
%%QT_MKSPECDIR%%/modules/qt_KConfigCore.pri
diff --git a/devel/kf5-knotifications/Makefile b/devel/kf5-knotifications/Makefile
index d69892316474..866fedf21c71 100644
--- a/devel/kf5-knotifications/Makefile
+++ b/devel/kf5-knotifications/Makefile
@@ -1,5 +1,6 @@
PORTNAME= knotifications
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +12,7 @@ LIB_DEPENDS= libdbusmenu-qt5.so:devel/libdbusmenu-qt \
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
USE_KDE= codecs config coreaddons windowsystem \
ecm_build
-USE_QT= core dbus gui linguisttools phonon4 widgets x11extras \
+USE_QT= core dbus declarative gui linguisttools network phonon4 widgets x11extras \
buildtools_build qmake_build
USE_XORG= x11 xtst
diff --git a/devel/kf5-knotifications/pkg-plist b/devel/kf5-knotifications/pkg-plist
index 5cf06a71c8aa..07b7e11d1e36 100644
--- a/devel/kf5-knotifications/pkg-plist
+++ b/devel/kf5-knotifications/pkg-plist
@@ -24,6 +24,8 @@ lib/libKF5Notifications.so
lib/libKF5Notifications.so.5
lib/libKF5Notifications.so.%%KDE_FRAMEWORKS_VERSION%%
%%QT_MKSPECDIR%%/modules/qt_KNotifications.pri
+%%QT_QMLDIR%%/org/kde/notification/libknotificationqmlplugin.so
+%%QT_QMLDIR%%/org/kde/notification/qmldir
share/dbus-1/interfaces/kf5_org.kde.StatusNotifierItem.xml
share/dbus-1/interfaces/kf5_org.kde.StatusNotifierWatcher.xml
share/kservicetypes5/knotificationplugin.desktop