aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-07-24 09:19:51 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-07-24 09:19:51 +0000
commitda6a0d2507cf21f0497f3f85a8c67a1cd5391450 (patch)
treed2a05938c0d8185b8ae3be7ca80d94a510b2c086
parent10fcc95dedb6b0f7bcf2313c29a89e7da830871a (diff)
downloadports-da6a0d2507cf21f0497f3f85a8c67a1cd5391450.tar.gz
ports-da6a0d2507cf21f0497f3f85a8c67a1cd5391450.zip
net/tinyldap: fix build on 32bit
-rw-r--r--net/tinyldap/Makefile1
-rw-r--r--net/tinyldap/files/patch-ldap_match_sre.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/tinyldap/Makefile b/net/tinyldap/Makefile
index b85444dca50e..21083f1bea39 100644
--- a/net/tinyldap/Makefile
+++ b/net/tinyldap/Makefile
@@ -1,5 +1,6 @@
PORTNAME= tinyldap
PORTVERSION= 0.0.${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.dinoex.de/pub/tinyldap/
DISTNAME= ${PORTNAME}-${SNAPSHOT}
diff --git a/net/tinyldap/files/patch-ldap_match_sre.c b/net/tinyldap/files/patch-ldap_match_sre.c
new file mode 100644
index 000000000000..f6074d4c545b
--- /dev/null
+++ b/net/tinyldap/files/patch-ldap_match_sre.c
@@ -0,0 +1,11 @@
+--- ldap_match_sre.c.orig 2007-06-28 22:17:33 UTC
++++ ldap_match_sre.c
+@@ -45,7 +45,7 @@ static int ldap_match_present_sre(struct SearchResultE
+ }
+
+ static int substrmatch(struct Substring* x,struct string* s,int ignorecase) {
+- int (*diff)(const void* a, unsigned long len, const void* b);
++ int (*diff)(const void* a, size_t len, const void* b);
+ if (ignorecase)
+ diff=case_diffb;
+ else