aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-07 05:15:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-07 06:50:02 +0000
commitda7bafd753417bb78754c5054eaff71deed21b97 (patch)
treeb5ef36909057981ab05bfe3ef69eb778a02d4f9b
parent600b48f2d263963f1d0b30849ae7eed6dd0ab8dc (diff)
downloadports-da7bafd753417bb78754c5054eaff71deed21b97.tar.gz
ports-da7bafd753417bb78754c5054eaff71deed21b97.zip
x11-toolkits/libdecor: add new port
libdecor is a library that can help Wayland clients draw window decorations for them. It aims to provide multiple backends that implements the decoration drawing. https://gitlab.gnome.org/jadahl/libdecor
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/libdecor/Makefile34
-rw-r--r--x11-toolkits/libdecor/distinfo7
-rw-r--r--x11-toolkits/libdecor/pkg-descr5
-rw-r--r--x11-toolkits/libdecor/pkg-plist6
5 files changed, 53 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index d13b3f24b09f..4c1274243d7b 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -69,6 +69,7 @@
SUBDIR += libXt
SUBDIR += libadwaita
SUBDIR += libdazzle
+ SUBDIR += libdecor
SUBDIR += libgdiplus
SUBDIR += libhandy
SUBDIR += libhandy0
diff --git a/x11-toolkits/libdecor/Makefile b/x11-toolkits/libdecor/Makefile
new file mode 100644
index 000000000000..99fd049190f6
--- /dev/null
+++ b/x11-toolkits/libdecor/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= libdecor
+DISTVERSION= 0.1.0
+CATEGORIES= x11-toolkits
+
+PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
+PATCHFILES+= ca1dd07bbdbd.patch:-p1 # https://gitlab.gnome.org/jadahl/libdecor/-/merge_requests/74
+PATCHFILES+= d5493ba96563.patch:-p1 # https://gitlab.gnome.org/jadahl/libdecor/-/merge_requests/75
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Client-side decorations library for Wayland client
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>=1.15:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= gnome meson pkgconfig
+USE_GITLAB= yes
+USE_GNOME= cairo pango
+USE_LDCONFIG= yes
+GL_SITE= https://gitlab.gnome.org
+GL_ACCOUNT= jadahl
+GL_COMMIT= 3ec3fadd59a21835079fbb3046d2bec6c649d6fa
+MESON_ARGS= -Ddemo=false
+
+OPTIONS_DEFINE= DBUS
+OPTIONS_DEFAULT=DBUS
+
+DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
+DBUS_MESON_ENABLED= dbus
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libdecor/distinfo b/x11-toolkits/libdecor/distinfo
new file mode 100644
index 000000000000..ddd6ca16f92b
--- /dev/null
+++ b/x11-toolkits/libdecor/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1626777309
+SHA256 (jadahl-libdecor-3ec3fadd59a21835079fbb3046d2bec6c649d6fa_GL0.tar.gz) = 14fdf799035ec523be2ff7f87aacf5d9d7b6db985fc3983338f489fc3f4681dd
+SIZE (jadahl-libdecor-3ec3fadd59a21835079fbb3046d2bec6c649d6fa_GL0.tar.gz) = 45097
+SHA256 (ca1dd07bbdbd.patch) = fd83b8339a2e721e57417a0c407dd4448bee564fc12b0c0accd6a05736b0203a
+SIZE (ca1dd07bbdbd.patch) = 1246
+SHA256 (d5493ba96563.patch) = 95b8ced998f4a9542ddddd78356fcd5f8a3440e5554fdc6c6c13db0edae9eff9
+SIZE (d5493ba96563.patch) = 4476
diff --git a/x11-toolkits/libdecor/pkg-descr b/x11-toolkits/libdecor/pkg-descr
new file mode 100644
index 000000000000..8685b68f05d4
--- /dev/null
+++ b/x11-toolkits/libdecor/pkg-descr
@@ -0,0 +1,5 @@
+libdecor is a library that can help Wayland clients draw window
+decorations for them. It aims to provide multiple backends that implements the
+decoration drawing.
+
+WWW: https://gitlab.gnome.org/jadahl/libdecor
diff --git a/x11-toolkits/libdecor/pkg-plist b/x11-toolkits/libdecor/pkg-plist
new file mode 100644
index 000000000000..6c20828f79cc
--- /dev/null
+++ b/x11-toolkits/libdecor/pkg-plist
@@ -0,0 +1,6 @@
+include/libdecor-0/libdecor.h
+lib/libdecor-0.so
+lib/libdecor-0.so.0
+lib/libdecor-0.so.0.100.0
+lib/libdecor/plugins-1/libdecor-cairo.so
+libdata/pkgconfig/libdecor-0.pc