aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-06-25 14:25:09 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-06-26 22:58:21 +0000
commitdaafa4e5eadf6c01394c255b8cbed4e36ea9e49f (patch)
tree6dfa30a622e50392b86b5f923357ea2e7ac693be
parent676a46525743f06d90d3d0bcecf7671db2911b45 (diff)
downloadports-daafa4e5eadf6c01394c255b8cbed4e36ea9e49f.tar.gz
ports-daafa4e5eadf6c01394c255b8cbed4e36ea9e49f.zip
graphics/sdl2_gpu: fix build with LLVM 16
Silence a warning about an incompatible function pointer type to fix the build on 14-CURRENT. This warning is harmless: the function pointer takes a const argument, but was assigned to where a pointer taking an unqualified argument was expected. Reported by: fallout
-rw-r--r--graphics/sdl2_gpu/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/sdl2_gpu/Makefile b/graphics/sdl2_gpu/Makefile
index cc22b8848c50..3158ab345d46 100644
--- a/graphics/sdl2_gpu/Makefile
+++ b/graphics/sdl2_gpu/Makefile
@@ -19,6 +19,7 @@ GH_ACCOUNT= grimfang4
GH_PROJECT= sdl-gpu
CMAKE_ON= USE_SYSTEM_GLEW DYNAMIC_GLES_3
+CFLAGS+= -Wno-incompatible-function-pointer-types
OPTIONS_DEFINE= DOCS
DOCS_CMAKE_BOOL= BUILD_DOCS