aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 17:51:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 18:00:42 +0000
commitdaf74492d86988c55eadec0ca6c581b7e4fd7d7c (patch)
treebb136d0abd5004fc3a48216d7d468a9f9db675bf
parent0c24df6fc770268737c8b64b4069637bc7c2af07 (diff)
downloadports-daf74492d86988c55eadec0ca6c581b7e4fd7d7c.tar.gz
ports-daf74492d86988c55eadec0ca6c581b7e4fd7d7c.zip
devel/py-pytest-cpp: Add py-pytest-cpp 2.3.0
pytest-cpp uses pytest runner to discover and execute C++ tests. It supports Google Test, Boost.Test, and Catch2. This brings several benefits: - Allows you to run all your tests in multi-language projects with a single command; - Execute C++ tests in parallel using pytest-xdist plugin; - Use --junitxml option to produce a single and uniform xml file with all your test suite results; - Filter which tests to run using standard test filtering capabilities, such as by file names, directories, keywords by using the -k option, etc.;
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-cpp/Makefile23
-rw-r--r--devel/py-pytest-cpp/distinfo3
-rw-r--r--devel/py-pytest-cpp/pkg-descr11
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7195de524fec..f44650bb2b4d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5249,6 +5249,7 @@
SUBDIR += py-pytest-checkdocs
SUBDIR += py-pytest-console-scripts
SUBDIR += py-pytest-cov
+ SUBDIR += py-pytest-cpp
SUBDIR += py-pytest-datadir
SUBDIR += py-pytest-django
SUBDIR += py-pytest-enabler
diff --git a/devel/py-pytest-cpp/Makefile b/devel/py-pytest-cpp/Makefile
new file mode 100644
index 000000000000..19a382d1a496
--- /dev/null
+++ b/devel/py-pytest-cpp/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pytest-cpp
+PORTVERSION= 2.3.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Use pytest runner to discover and execute C++ tests
+WWW= https://github.com/pytest-dev/pytest-cpp
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=7.0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-cpp/distinfo b/devel/py-pytest-cpp/distinfo
new file mode 100644
index 000000000000..8cdc1ce90f68
--- /dev/null
+++ b/devel/py-pytest-cpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681052892
+SHA256 (pytest-cpp-2.3.0.tar.gz) = 37abfa693697940aed2e7c034698188dee3616183ad9b3f764f3b06aeb75ed4a
+SIZE (pytest-cpp-2.3.0.tar.gz) = 298220
diff --git a/devel/py-pytest-cpp/pkg-descr b/devel/py-pytest-cpp/pkg-descr
new file mode 100644
index 000000000000..dc9719af52c7
--- /dev/null
+++ b/devel/py-pytest-cpp/pkg-descr
@@ -0,0 +1,11 @@
+pytest-cpp uses pytest runner to discover and execute C++ tests. It supports
+Google Test, Boost.Test, and Catch2.
+
+This brings several benefits:
+- Allows you to run all your tests in multi-language projects with a single
+ command;
+- Execute C++ tests in parallel using pytest-xdist plugin;
+- Use --junitxml option to produce a single and uniform xml file with all your
+ test suite results;
+- Filter which tests to run using standard test filtering capabilities, such as
+ by file names, directories, keywords by using the -k option, etc.;