aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-05-04 08:59:27 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-05-04 09:01:09 +0000
commitdafec451b64b0e980151da818b91be33dbc2b33f (patch)
treee3c1402c3a84d23b56b7ea6a8e4a5fa83523a45c
parente1d7d6fdeb6c69c437f75a25b61885044502b42d (diff)
downloadports-dafec451b64b0e980151da818b91be33dbc2b33f.tar.gz
ports-dafec451b64b0e980151da818b91be33dbc2b33f.zip
sysutils/dd_rescue: Update to 1.99.11
-rw-r--r--sysutils/dd_rescue/Makefile2
-rw-r--r--sysutils/dd_rescue/distinfo6
-rw-r--r--sysutils/dd_rescue/files/patch-Makefile15
-rw-r--r--sysutils/dd_rescue/files/patch-secmem.c10
4 files changed, 22 insertions, 11 deletions
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index be211b082741..f20a05338332 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -1,7 +1,7 @@
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
PORTNAME= dd_rescue
-PORTVERSION= 1.99.10
+PORTVERSION= 1.99.11
CATEGORIES= sysutils
MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/ \
http://fossies.org/unix/privat/
diff --git a/sysutils/dd_rescue/distinfo b/sysutils/dd_rescue/distinfo
index 29e181dc805f..f562eaeb3afe 100644
--- a/sysutils/dd_rescue/distinfo
+++ b/sysutils/dd_rescue/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1615785193
-SHA256 (dd_rescue-1.99.10.tar.bz2) = 100fceb65b073a2c6e4f1a6b6e2e58e5d51235a4e85162f098b03d9ff0e65c16
-SIZE (dd_rescue-1.99.10.tar.bz2) = 176603
+TIMESTAMP = 1620114532
+SHA256 (dd_rescue-1.99.11.tar.bz2) = 84c780919b971459e6fb18775ee097a41fc3dbdcb5aab8332e71e83a03ec645f
+SIZE (dd_rescue-1.99.11.tar.bz2) = 181927
diff --git a/sysutils/dd_rescue/files/patch-Makefile b/sysutils/dd_rescue/files/patch-Makefile
index 3f8d4816c636..e1773aaec5dd 100644
--- a/sysutils/dd_rescue/files/patch-Makefile
+++ b/sysutils/dd_rescue/files/patch-Makefile
@@ -1,10 +1,11 @@
---- Makefile.orig 2021-03-08 07:47:42 UTC
+--- Makefile.orig 2021-04-29 08:31:32 UTC
+++ Makefile
-@@ -7,10 +7,7 @@ VERSION = 1.99.10
+@@ -7,11 +7,7 @@ VERSION = 1.99.11
DESTDIR =
SRCDIR = .
--CC ?= gcc
+-CC = gcc
+-SHELL = /bin/bash
-RPM_OPT_FLAGS ?= -Os -Wall -g -D_FORTIFY_SOURCE=2
-CFLAGS = $(RPM_OPT_FLAGS) $(EXTRA_CFLAGS) -DHAVE_CONFIG_H -I .
-CFLAGS_OPT = $(CFLAGS) -O3
@@ -12,7 +13,7 @@
INSTALL ?= install
INSTALLFLAGS = -s
prefix = $(DESTDIR)/usr
-@@ -35,7 +32,7 @@ LIB = lib
+@@ -36,7 +32,7 @@ LIB = lib
LIBDIR = /usr/$(LIB)
COMPILER = $(shell $(CC) --version | head -n1)
ID = $(shell git describe --tags || cat REL-ID)
@@ -21,7 +22,7 @@
OUT = -o dd_rescue
PIC = -fPIC
PIE = -fPIE
-@@ -70,19 +67,13 @@ else
+@@ -71,19 +67,13 @@ else
HAVE_XATTR=0
endif
@@ -42,7 +43,7 @@
ISX86 := 1
LIB = lib64
endif
-@@ -261,7 +252,7 @@ libddr_MD5.so: libddr_hash.so
+@@ -289,7 +279,7 @@ libddr_MD5.so: libddr_hash.so
ln -sf $< $@
libddr_lzo.so: libddr_lzo.po
@@ -51,7 +52,7 @@
libddr_null.so: libddr_null.po
$(CC) -shared -o $@ $^
-@@ -324,7 +315,7 @@ libfalloc-static: $(SRCDIR)/dd_rescue.c $(DDR_HEADERS)
+@@ -360,7 +350,7 @@ libfalloc-static: $(SRCDIR)/dd_rescue.c $(DDR_HEADERS)
# This is the default built
dd_rescue: $(SRCDIR)/dd_rescue.c $(DDR_HEADERS) $(OBJECTS) $(OBJECTS2)
diff --git a/sysutils/dd_rescue/files/patch-secmem.c b/sysutils/dd_rescue/files/patch-secmem.c
new file mode 100644
index 000000000000..fb58122fe821
--- /dev/null
+++ b/sysutils/dd_rescue/files/patch-secmem.c
@@ -0,0 +1,10 @@
+--- secmem.c.orig 2021-05-04 08:16:41 UTC
++++ secmem.c
+@@ -10,6 +10,7 @@
+ #include <unistd.h>
+ #include <errno.h>
+ #include <sys/mman.h>
++#include <stddef.h>
+ #ifdef HAVE_MALLOC_H
+ # include <malloc.h>
+ #endif