aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Chardon <laurent.chardon@gmail.com>2024-05-23 15:55:24 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-05-24 18:02:19 +0000
commitdb58ce631809aeb3e8c4d975fd8351c748aa567c (patch)
treede828a61153aa06ea6d284459bd8e89ec5ca21ad
parent83ee3d446fedf5ae52d534a052403a86dc095c17 (diff)
downloadports-db58ce631809aeb3e8c4d975fd8351c748aa567c.tar.gz
ports-db58ce631809aeb3e8c4d975fd8351c748aa567c.zip
sysutils/modules: Upgrade to 5.4.0
ChangeLog: https://github.com/cea-hpc/modules/releases/tag/v5.4.0 PR: 279055 Reported by: laurent.chardon@gmail.com (maintainer)
-rw-r--r--sysutils/modules/Makefile14
-rw-r--r--sysutils/modules/distinfo6
-rw-r--r--sysutils/modules/files/patch-Makefile11
-rw-r--r--sysutils/modules/files/patch-doc_Makefile53
-rw-r--r--sysutils/modules/files/patch-doc_build_modulefile.511
-rw-r--r--sysutils/modules/pkg-plist2
6 files changed, 13 insertions, 84 deletions
diff --git a/sysutils/modules/Makefile b/sysutils/modules/Makefile
index 1e242706e264..9d65671ba161 100644
--- a/sysutils/modules/Makefile
+++ b/sysutils/modules/Makefile
@@ -1,6 +1,5 @@
PORTNAME= modules
-DISTVERSION= 5.3.1
-PORTREVISION= 1
+DISTVERSION= 5.4.0
CATEGORIES= sysutils tcl
MASTER_SITES= https://github.com/cea-hpc/modules/releases/download/v${PORTVERSION}/
@@ -19,14 +18,17 @@ GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
GNU_CONFIGURE_PREFIX= ${PREFIX}/Modules
CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
-CONFIGURE_ARGS= --disable-compat-version \
- --enable-versioning \
+CONFIGURE_ARGS= --enable-versioning \
--with-python="${PYTHON_CMD}"
PLIST_SUB= MODULES_VERSION=${PORTVERSION}
-post-extract:
- ${MV} ${WRKSRC}/doc/build/modulefile.4 ${WRKSRC}/doc/build/modulefile.5
+post-stage:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/profile.d
+ ${RLN} ${STAGEDIR}${PREFIX}/Modules/${PORTVERSION}/init/profile.sh \
+ ${STAGEDIR}${PREFIX}/etc/profile.d/module.sh
+ ${RLN} ${STAGEDIR}${PREFIX}/Modules/${PORTVERSION}/init/profile.csh \
+ ${STAGEDIR}${PREFIX}/etc/profile.d/module.csh
post-install:
@${STRIP_CMD} ${STAGEDIR}${GNU_CONFIGURE_PREFIX}/${PORTVERSION}/lib/libtclenvmodules.so
diff --git a/sysutils/modules/distinfo b/sysutils/modules/distinfo
index c9d965bc29e6..92afd411ed62 100644
--- a/sysutils/modules/distinfo
+++ b/sysutils/modules/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1699876784
-SHA256 (modules-5.3.1.tar.bz2) = 171f7faebc1363c8738a6905b31074636dd81d303098002b1c25801ee5483d86
-SIZE (modules-5.3.1.tar.bz2) = 1820274
+TIMESTAMP = 1715939712
+SHA256 (modules-5.4.0.tar.bz2) = c494f70cb533b5f24ad69803aa053bb4a509bec4632d6a066e7ac041db461a72
+SIZE (modules-5.4.0.tar.bz2) = 1899923
diff --git a/sysutils/modules/files/patch-Makefile b/sysutils/modules/files/patch-Makefile
deleted file mode 100644
index d479ec3e10d5..000000000000
--- a/sysutils/modules/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2023-06-27 17:22:08 UTC
-+++ Makefile
-@@ -763,7 +763,7 @@ dist-tar: ChangeLog.gz contrib/rpm/environment-modules
- lib/configure lib/config.h.in $(DIST_AUTORECONF_EXTRA) ChangeLog.gz \
- doc/build/MIGRATING.txt doc/build/changes.txt doc/build/INSTALL.txt \
- doc/build/INSTALL-win.txt doc/build/NEWS.txt doc/build/CONTRIBUTING.txt \
-- doc/build/module.1.in doc/build/ml.1 doc/build/modulefile.4 \
-+ doc/build/module.1.in doc/build/ml.1 doc/build/modulefile.5 \
- contrib/rpm/environment-modules.spec
-
- dist-gzip: dist-tar
diff --git a/sysutils/modules/files/patch-doc_Makefile b/sysutils/modules/files/patch-doc_Makefile
deleted file mode 100644
index b4ff4d40f60e..000000000000
--- a/sysutils/modules/files/patch-doc_Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
---- doc/Makefile.orig 2023-06-27 17:22:08 UTC
-+++ doc/Makefile
-@@ -37,7 +37,7 @@ ALL_RST := $(wildcard $(SOURCE_DIR)/*.rst $(SOURCE_DIR
- $(SOURCE_DIR)/design/*.rst)
- ALL_TXT := $(patsubst $(SOURCE_DIR)/%,$(BUILD_DIR)/%,$(patsubst %.rst,%.txt,$(ALL_RST)))
- ALL_HTML := $(patsubst $(SOURCE_DIR)/%,$(BUILD_DIR)/%,$(patsubst %.rst,%.html,$(ALL_RST)))
--ALL_MAN := $(BUILD_DIR)/module.1 $(BUILD_DIR)/ml.1 $(BUILD_DIR)/modulefile.4
-+ALL_MAN := $(BUILD_DIR)/module.1 $(BUILD_DIR)/ml.1 $(BUILD_DIR)/modulefile.5
-
- all: man txt
-
-@@ -97,10 +97,10 @@ $(BUILD_DIR)/%.txt: $(SOURCE_DIR)/%.rst $(SOURCE_DIR)/
- $(ECHO_GEN2) $(ECHO_DIR_PREFIX)$(BUILD_DIR)/*.txt
- $(SPHINXBUILD) $(SPHINXOPTS) -b text "$(SOURCE_DIR)" "$(BUILD_DIR)"
-
--$(BUILD_DIR)/module.1.in $(BUILD_DIR)/modulefile.4 $(BUILD_DIR)/ml.1: $(ALL_RST) $(SOURCE_DIR)/version.py
-+$(BUILD_DIR)/module.1.in $(BUILD_DIR)/modulefile.5 $(BUILD_DIR)/ml.1: $(ALL_RST) $(SOURCE_DIR)/version.py
- $(ECHO_GEN2) $(ECHO_DIR_PREFIX)$(BUILD_DIR)/ml.1
- $(ECHO_GEN2) $(ECHO_DIR_PREFIX)$(BUILD_DIR)/module.1.in
-- $(ECHO_GEN2) $(ECHO_DIR_PREFIX)$(BUILD_DIR)/modulefile.4
-+ $(ECHO_GEN2) $(ECHO_DIR_PREFIX)$(BUILD_DIR)/modulefile.5
- $(SPHINXBUILD) $(SPHINXOPTS) -t pathsubs -b man "$(SOURCE_DIR)" "$(BUILD_DIR)"
- $(if $(findstring module.1.in,$@),mv $(BUILD_DIR)/module.1 $@)
- endif
-@@ -109,7 +109,7 @@ $(BUILD_DIR)/module.1: $(BUILD_DIR)/module.1.in
- $(translate-in-script)
-
- install: man txt
-- $(INSTALL_DIR) '$(DESTDIR)$(mandir)/man1' '$(DESTDIR)$(mandir)/man4'
-+ $(INSTALL_DIR) '$(DESTDIR)$(mandir)/man1' '$(DESTDIR)$(mandir)/man5'
- ifeq ($(docinstall),y)
- $(INSTALL_DIR) '$(DESTDIR)$(docdir)'
- $(INSTALL_DATA) $(BUILD_DIR)/changes.txt '$(DESTDIR)$(docdir)/'
-@@ -121,7 +121,7 @@ ifeq ($(docinstall),y)
- endif
- $(INSTALL_DATA) $(BUILD_DIR)/module.1 '$(DESTDIR)$(mandir)/man1/'
- $(INSTALL_DATA) $(BUILD_DIR)/ml.1 '$(DESTDIR)$(mandir)/man1/'
-- $(INSTALL_DATA) $(BUILD_DIR)/modulefile.4 '$(DESTDIR)$(mandir)/man4/'
-+ $(INSTALL_DATA) $(BUILD_DIR)/modulefile.5 '$(DESTDIR)$(mandir)/man5/'
-
- uninstall:
- ifeq ($(docinstall),y)
-@@ -135,8 +135,8 @@ ifeq ($(docinstall),y)
- endif
- rm -f '$(DESTDIR)$(mandir)/man1/module.1'
- rm -f '$(DESTDIR)$(mandir)/man1/ml.1'
-- rm -f '$(DESTDIR)$(mandir)/man4/modulefile.4'
-- rmdir '$(DESTDIR)$(mandir)/man1' '$(DESTDIR)$(mandir)/man4'
-+ rm -f '$(DESTDIR)$(mandir)/man5/modulefile.5'
-+ rmdir '$(DESTDIR)$(mandir)/man1' '$(DESTDIR)$(mandir)/man5'
- rmdir '$(DESTDIR)$(mandir)'
-
- clean:
diff --git a/sysutils/modules/files/patch-doc_build_modulefile.5 b/sysutils/modules/files/patch-doc_build_modulefile.5
deleted file mode 100644
index 04fac3c56cea..000000000000
--- a/sysutils/modules/files/patch-doc_build_modulefile.5
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/build/modulefile.5.orig 2023-06-27 17:25:15 UTC
-+++ doc/build/modulefile.5
-@@ -27,7 +27,7 @@ level margin: \\n[rst2man-indent\\n[rst2man-indent-lev
- .\" new: \\n[rst2man-indent\\n[rst2man-indent-level]]
- .in \\n[rst2man-indent\\n[rst2man-indent-level]]u
- ..
--.TH "MODULEFILE" "4" "2023-06-27" "5.3.1" "Modules"
-+.TH "MODULEFILE" "5" "2023-06-27" "5.3.1" "Modules"
- .SH NAME
- modulefile \- files containing Tcl code for the Modules package
- .SH DESCRIPTION
diff --git a/sysutils/modules/pkg-plist b/sysutils/modules/pkg-plist
index 2886daff39c9..8baf47d344ba 100644
--- a/sysutils/modules/pkg-plist
+++ b/sysutils/modules/pkg-plist
@@ -52,6 +52,8 @@ Modules/%%MODULES_VERSION%%/share/vim/vimfiles/ftdetect/modulefile.vim
Modules/%%MODULES_VERSION%%/share/vim/vimfiles/ftplugin/modulefile.vim
Modules/%%MODULES_VERSION%%/share/vim/vimfiles/syntax/modulefile.vim
Modules/versions/%%MODULES_VERSION%%
+etc/profile.d/module.csh
+etc/profile.d/module.sh
share/man/man1/ml.1.gz
share/man/man1/module.1.gz
share/man/man5/modulefile.5.gz