aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-04-26 18:49:11 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-04-26 18:53:05 +0000
commitdc17c19f15dab57c22d2967a525573d4b8020930 (patch)
tree09136c9ddf19c969b3e89eb20b3347d62a635a4c
parent045a0fa59ee83a3503785f60b738e802eb38143e (diff)
downloadports-dc17c19f15dab57c22d2967a525573d4b8020930.tar.gz
ports-dc17c19f15dab57c22d2967a525573d4b8020930.zip
www/firefox: fix build with sndio
upstream sndio handling was fixed for non-OpenBSD systems: https://bugzilla.mozilla.org/show_bug.cgi?id=1351378 so our own "fixing" actually broke build. PR: 263587 Reported by: Robert Cina, jkim@ (cherry picked from commit 48a481f83ecbb669a22c2c9f9dc3712bf5a7b71c)
-rw-r--r--Mk/bsd.gecko.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index acd930def68c..8473c10a2c1f 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -270,11 +270,16 @@ MOZ_OPTIONS+= --disable-pulseaudio
.if ${PORT_OPTIONS:MSNDIO}
BUILD_DEPENDS+= ${LOCALBASE}/include/sndio.h:audio/sndio
+MOZ_OPTIONS+= --enable-sndio
+. if ${MOZILLA_VER:R:R} < 100
post-patch-SNDIO-on:
@${REINPLACE_CMD} -e 's|OpenBSD|${OPSYS}|g' \
-e '/DISABLE_LIBSNDIO_DLOPEN/d' \
${MOZSRC}/media/libcubeb/src/moz.build
-.endif
+. endif
+. else
+MOZ_OPTIONS+= --disable-sndio
+. endif
.if ${PORT_OPTIONS:MDEBUG}
MOZ_OPTIONS+= --enable-debug --disable-release