aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-05-20 11:44:04 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-05-21 17:27:20 +0000
commitdc299b36fdc2faedaab1b411afa5e6cae7b68619 (patch)
tree0ab809e25527c3c7af7c63b028e56bb35664ac99
parent747d377bf148ab150cb223b6af58adf7fcb1c31e (diff)
downloadports-dc299b36fdc2faedaab1b411afa5e6cae7b68619.tar.gz
ports-dc299b36fdc2faedaab1b411afa5e6cae7b68619.zip
textproc/py-sphinxcontrib-svg2pdfconverter: depend on correct librsvg2 automatically
Instead of providing a port option, have USES=gnome figure out the right librsvg2 to depend on. This avoids conflicts when installing mame with other ports that depend on librsvg2{,-rust}. Approved by: agh@riseup.net (maintainer) MFH: 2023Q2 PR: 271530 (cherry picked from commit bce94ecce5f905028f4f922b80bb32e5e1563dda)
-rw-r--r--textproc/py-sphinxcontrib-svg2pdfconverter/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/textproc/py-sphinxcontrib-svg2pdfconverter/Makefile b/textproc/py-sphinxcontrib-svg2pdfconverter/Makefile
index 4e96ce2f215f..23beba86d18b 100644
--- a/textproc/py-sphinxcontrib-svg2pdfconverter/Makefile
+++ b/textproc/py-sphinxcontrib-svg2pdfconverter/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sphinxcontrib-svg2pdfconverter
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,20 +14,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
-USES= python:3.8+
+USES= gnome python:3.8+
+USE_GNOME= librsvg2
USE_PYTHON= autoplist concurrent distutils flavors
NO_ARCH= yes
-OPTIONS_DEFINE= RSVGIMPL
-RSVGIMPL_DESC= Depend on the Rust implementation of rsvg-convert
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MRSVGIMPL}
-RUN_DEPENDS+= rsvg-convert:graphics/librsvg2-rust
-.else
-RUN_DEPENDS+= rsvg-convert:graphics/librsvg2
-.endif
-
.include <bsd.port.mk>