aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-08-30 01:08:02 +0000
committerCy Schubert <cy@FreeBSD.org>2022-08-30 01:11:05 +0000
commitdc2f6b92465447b81470fe2c56963053e04039fd (patch)
tree104532319c707026740de3768e725dfe3052bd08
parent70f144086a038ed1d67cd99e5a9f4e4f10124323 (diff)
downloadports-dc2f6b92465447b81470fe2c56963053e04039fd.tar.gz
ports-dc2f6b92465447b81470fe2c56963053e04039fd.zip
Revert "sysutils/nut*: Add upslog support for multiple UPSs"
upslog is failing to make multiple connections to upsd resulting in some UPSs logging and others not. This is likely some bug in upsd's socket handling. Even though this patch worked for me locally it did not for the person reporting the problem. A better approach would be to use select() instead. PR: 265963 This reverts commit dec4ecc3afecab035a4d4fa59c35093d9f53ffd5.
-rw-r--r--sysutils/nut-devel/Makefile2
-rw-r--r--sysutils/nut-devel/files/patch-clients_upslog.c167
-rw-r--r--sysutils/nut-devel/files/patch-docs_man_upslog.txt16
-rw-r--r--sysutils/nut/Makefile2
-rw-r--r--sysutils/nut/files/patch-clients_upslog.c166
-rw-r--r--sysutils/nut/files/patch-docs_man_upslog.816
-rw-r--r--sysutils/nut/files/patch-include_nut__stdint.h31
7 files changed, 2 insertions, 398 deletions
diff --git a/sysutils/nut-devel/Makefile b/sysutils/nut-devel/Makefile
index 398569e10c81..b3d796bfec97 100644
--- a/sysutils/nut-devel/Makefile
+++ b/sysutils/nut-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nut
PORTVERSION= ${NUT_COMMIT_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
PKGNAMESUFFIX= -devel
# MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
diff --git a/sysutils/nut-devel/files/patch-clients_upslog.c b/sysutils/nut-devel/files/patch-clients_upslog.c
deleted file mode 100644
index b00846526b21..000000000000
--- a/sysutils/nut-devel/files/patch-clients_upslog.c
+++ /dev/null
@@ -1,167 +0,0 @@
---- clients/upslog.c.orig 2022-08-26 15:25:26.539215000 -0700
-+++ clients/upslog.c 2022-08-26 15:26:10.909994000 -0700
-@@ -32,6 +32,10 @@
- */
-
- #include "common.h"
-+#include <signal.h>
-+#include <unistd.h>
-+#include <sys/types.h>
-+#include <sys/wait.h>
- #include "nut_platform.h"
- #include "upsclient.h"
-
-@@ -41,17 +45,32 @@
- #include "upslog.h"
-
- static int reopen_flag = 0, exit_flag = 0;
-+ static int wait_status;
- static uint16_t port;
- static char *upsname, *hostname;
- static UPSCONN_t ups;
-
- static FILE *logfile;
-- static const char *logfn, *monhost;
-+ static char *logfn, *monhost;
- static sigset_t nut_upslog_sigmask;
- static char logbuffer[LARGEBUF], *logformat;
-
- static flist_t *fhead = NULL;
-+ struct monhost_child {
-+ char *monhost;
-+ char *logfn;
-+ char *pidfilebase;
-+ pid_t pid;
-+ struct monhost_child *next;
-+ };
-+ static struct monhost_child *monhost_child_anchor = NULL;
-+ static struct monhost_child *monhost_child_current = NULL;
-+ static struct monhost_child *monhost_child_prev = NULL;
-+ static struct sigaction upslog_sigaction;
-+ static int trapped_signals[] = { SIGHUP, SIGINT, SIGTERM, SIGCHLD };
-+ static pid_t daemon_pid;
-
-+
- #define DEFAULT_LOGFORMAT "%TIME @Y@m@d @H@M@S% %VAR battery.charge% " \
- "%VAR input.voltage% %VAR ups.load% [%VAR ups.status%] " \
- "%VAR ups.temperature% %VAR input.frequency%"
-@@ -131,6 +150,8 @@
- printf(" -p <pidbase> - Base name for PID file (defaults to \"%s\")\n", prog);
- printf(" -s <ups> - Monitor UPS <ups> - <upsname>@<host>[:<port>]\n");
- printf(" - Example: -s myups@server\n");
-+ printf(" -m <tuple> - Monitor UPS <ups,logfile,pidfile>,\n");
-+ printf(" - Example: -m myups@server,/var/log/myups.log,/var/run/myups.pid\n");
- printf(" -u <user> - Switch to <user> if started as root\n");
-
- printf("\n");
-@@ -393,9 +414,25 @@
- * -u <username>
- */
-
-+static void term_handler(int signo)
-+{
-+ if (signo != SIGCHLD && monhost_child_anchor != NULL) {
-+ for (monhost_child_current = monhost_child_anchor;
-+ monhost_child_current != NULL;
-+ monhost_child_current = monhost_child_current->next
-+ ) {
-+ kill(monhost_child_current->pid, signo);
-+ }
-+
-+ if (signo != SIGHUP)
-+ fatalx(EXIT_FAILURE, "Killed by user");
-+ }
-+}
-+
- int main(int argc, char **argv)
- {
- int interval = 30, i, foreground = -1;
-+ size_t monhost_len = 0, mh;
- const char *prog = xbasename(argv[0]);
- time_t now, nextpoll = 0;
- const char *user = NULL;
-@@ -407,7 +444,7 @@
-
- printf("Network UPS Tools %s %s\n", prog, UPS_VERSION);
-
-- while ((i = getopt(argc, argv, "+hs:l:i:f:u:Vp:FB")) != -1) {
-+ while ((i = getopt(argc, argv, "+hs:l:i:f:u:Vp:FBm:")) != -1) {
- switch(i) {
- case 'h':
- help(prog);
-@@ -415,6 +452,33 @@
- break;
- #endif
-
-+ case 'm': { /* var scope */
-+ char *m_arg, *s;
-+
-+ monhost_child_prev = monhost_child_current;
-+ monhost_child_current = xmalloc(sizeof(struct monhost_child));
-+ if (monhost_child_anchor == NULL)
-+ monhost_child_anchor = monhost_child_current;
-+ else
-+ monhost_child_prev->next = monhost_child_current;
-+ monhost_child_current->next = NULL;
-+ monhost_len++;
-+
-+ /* Be sure to not mangle original optarg, nor rely on its longevity */
-+ s = xstrdup(optarg);
-+ m_arg = s;
-+ monhost_child_current->monhost = xstrdup(strsep(&m_arg, ","));
-+ if (!m_arg)
-+ fatalx(EXIT_FAILURE, "Argument '-m upsspec,logfile,pidfile' requires exactly 3 components in the tuple");
-+ monhost_child_current->logfn = xstrdup(strsep(&m_arg, ","));
-+ if (!m_arg)
-+ fatalx(EXIT_FAILURE, "Argument '-m upsspec,logfile,pidfile' requires exactly 3 components in the tuple");
-+ monhost_child_current->pidfilebase = xstrdup(strsep(&m_arg, ","));
-+ if (m_arg) /* Had a third comma - also unexpected! */
-+ fatalx(EXIT_FAILURE, "Argument '-m upsspec,logfile,pidfile' requires exactly 3 components in the tuple");
-+ free(s);
-+ } /* var scope */
-+ break;
- case 's':
- monhost = optarg;
- break;
-@@ -477,6 +541,41 @@
-
- for (i = 3; i < argc; i++)
- snprintfcat(logformat, LARGEBUF, "%s ", argv[i]);
-+ }
-+
-+ if (monhost_child_anchor != NULL) {
-+ if (foreground > 0)
-+ daemon_pid = 0;
-+ else
-+ daemon_pid = fork();
-+ if (!daemon_pid) {
-+ upsdebugx(1,"Forking to log %" PRIuSIZE " devices", monhost_len);
-+ for (monhost_child_current = monhost_child_anchor;
-+ monhost_child_current != NULL;
-+ monhost_child_current = monhost_child_current->next) {
-+ if ((monhost_child_current->pid = fork()) == 0) {
-+ monhost = monhost_child_current->monhost;
-+ logfn = monhost_child_current->logfn;
-+ pidfilebase = monhost_child_current->pidfilebase;
-+ foreground = 1;
-+ break;
-+ }
-+ }
-+ if (monhost_child_anchor->pid) { /* parent */
-+ for (mh = 0; mh < sizeof(trapped_signals)/sizeof(trapped_signals[0]); mh++) {
-+ upslog_sigaction.sa_handler = &term_handler;
-+ sigfillset(&upslog_sigaction.sa_mask);
-+ upslog_sigaction.sa_flags = SA_NOCLDSTOP | SA_NOCLDWAIT;
-+ sigaction(trapped_signals[mh], &upslog_sigaction, NULL);
-+ }
-+ become_user(get_user_pwent(user));
-+ writepid(pidfilebase);
-+ while(wait(&wait_status) > 0);
-+ exit(EXIT_SUCCESS);
-+ }
-+ } else {
-+ exit(EXIT_SUCCESS);
-+ }
- }
-
- if (!monhost)
diff --git a/sysutils/nut-devel/files/patch-docs_man_upslog.txt b/sysutils/nut-devel/files/patch-docs_man_upslog.txt
deleted file mode 100644
index a8b41f0f7569..000000000000
--- a/sysutils/nut-devel/files/patch-docs_man_upslog.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/docs/man/upslog.txt b/docs/man/upslog.txt
-index f4051048..f49695fe 100644
---- docs/man/upslog.txt
-+++ docs/man/upslog.txt
-@@ -78,6 +78,11 @@ upslog will run in the background, regardless of logging target.
- Monitor this UPS. The format for this option is
- +upsname[@hostname[:port]]+. The default hostname is "localhost".
-
-+*-m* 'tuple'::
-+Monitor multiple UPSs. The format for this option is a tuple of
-+ups, logfile, and pidfile separated by commas. An example would be:
-+`upsname@hostname:9999,/var/log/nut/cps.log,/var/run/cps.pid`
-+
- *-u* 'username'::
-
- If started as root, upslog will *setuid*(2) to the user id
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index 0e1209bbc376..1bad77416107 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nut
PORTVERSION= 2.8.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= sysutils
MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
diff --git a/sysutils/nut/files/patch-clients_upslog.c b/sysutils/nut/files/patch-clients_upslog.c
deleted file mode 100644
index 1602d8b65067..000000000000
--- a/sysutils/nut/files/patch-clients_upslog.c
+++ /dev/null
@@ -1,166 +0,0 @@
---- clients/upslog.c.orig 2022-08-26 15:25:00.233023000 -0700
-+++ clients/upslog.c 2022-08-26 15:26:30.983822000 -0700
-@@ -32,6 +32,10 @@
- */
-
- #include "common.h"
-+#include <signal.h>
-+#include <unistd.h>
-+#include <sys/types.h>
-+#include <sys/wait.h>
- #include "nut_platform.h"
- #include "upsclient.h"
-
-@@ -41,17 +45,32 @@
- #include "upslog.h"
-
- static int reopen_flag = 0, exit_flag = 0;
-+ static int wait_status;
- static uint16_t port;
- static char *upsname, *hostname;
- static UPSCONN_t ups;
-
- static FILE *logfile;
-- static const char *logfn, *monhost;
-+ static char *logfn, *monhost;
- static sigset_t nut_upslog_sigmask;
- static char logbuffer[LARGEBUF], *logformat;
-
- static flist_t *fhead = NULL;
-+ struct monhost_child {
-+ char *monhost;
-+ char *logfn;
-+ char *pidfilebase;
-+ pid_t pid;
-+ struct monhost_child *next;
-+ };
-+ static struct monhost_child *monhost_child_anchor = NULL;
-+ static struct monhost_child *monhost_child_current = NULL;
-+ static struct monhost_child *monhost_child_prev = NULL;
-+ static struct sigaction upslog_sigaction;
-+ static int trapped_signals[] = { SIGHUP, SIGINT, SIGTERM, SIGCHLD };
-+ static pid_t daemon_pid;
-
-+
- #define DEFAULT_LOGFORMAT "%TIME @Y@m@d @H@M@S% %VAR battery.charge% " \
- "%VAR input.voltage% %VAR ups.load% [%VAR ups.status%] " \
- "%VAR ups.temperature% %VAR input.frequency%"
-@@ -131,6 +150,8 @@
- printf(" -p <pidbase> - Base name for PID file (defaults to \"%s\")\n", prog);
- printf(" -s <ups> - Monitor UPS <ups> - <upsname>@<host>[:<port>]\n");
- printf(" - Example: -s myups@server\n");
-+ printf(" -m <tuple> - Monitor UPS <ups,logfile,pidfile>,\n");
-+ printf(" - Example: -m myups@server,/var/log/myups.log,/var/run/myups.pid\n");
- printf(" -u <user> - Switch to <user> if started as root\n");
-
- printf("\n");
-@@ -393,9 +414,25 @@
- * -u <username>
- */
-
-+static void term_handler(int signo)
-+{
-+ if (signo != SIGCHLD && monhost_child_anchor != NULL) {
-+ for (monhost_child_current = monhost_child_anchor;
-+ monhost_child_current != NULL;
-+ monhost_child_current = monhost_child_current->next
-+ ) {
-+ kill(monhost_child_current->pid, signo);
-+ }
-+
-+ if (signo != SIGHUP)
-+ fatalx(EXIT_FAILURE, "Killed by user");
-+ }
-+}
-+
- int main(int argc, char **argv)
- {
- int interval = 30, i, foreground = -1;
-+ size_t monhost_len = 0, mh;
- const char *prog = xbasename(argv[0]);
- time_t now, nextpoll = 0;
- const char *user = NULL;
-@@ -407,7 +444,7 @@
-
- printf("Network UPS Tools %s %s\n", prog, UPS_VERSION);
-
-- while ((i = getopt(argc, argv, "+hs:l:i:f:u:Vp:FB")) != -1) {
-+ while ((i = getopt(argc, argv, "+hs:l:i:f:u:Vp:FBm:")) != -1) {
- switch(i) {
- case 'h':
- help(prog);
-@@ -415,6 +452,33 @@
- break;
- #endif
-
-+ case 'm': { /* var scope */
-+ char *m_arg, *s;
-+
-+ monhost_child_prev = monhost_child_current;
-+ monhost_child_current = xmalloc(sizeof(struct monhost_child));
-+ if (monhost_child_anchor == NULL)
-+ monhost_child_anchor = monhost_child_current;
-+ else
-+ monhost_child_prev->next = monhost_child_current;
-+ monhost_child_current->next = NULL;
-+ monhost_len++;
-+
-+ /* Be sure to not mangle original optarg, nor rely on its longevity */
-+ s = xstrdup(optarg);
-+ m_arg = s;
-+ monhost_child_current->monhost = xstrdup(strsep(&m_arg, ","));
-+ if (!m_arg)
-+ fatalx(EXIT_FAILURE, "Argument '-m upsspec,logfile,pidfile' requires exactly 3 components in the tuple");
-+ monhost_child_current->logfn = xstrdup(strsep(&m_arg, ","));
-+ if (!m_arg)
-+ fatalx(EXIT_FAILURE, "Argument '-m upsspec,logfile,pidfile' requires exactly 3 components in the tuple");
-+ monhost_child_current->pidfilebase = xstrdup(strsep(&m_arg, ","));
-+ if (m_arg) /* Had a third comma - also unexpected! */
-+ fatalx(EXIT_FAILURE, "Argument '-m upsspec,logfile,pidfile' requires exactly 3 components in the tuple");
-+ free(s);
-+ } /* var scope */
-+ break;
- case 's':
- monhost = optarg;
- break;
-@@ -477,6 +541,40 @@
-
- for (i = 3; i < argc; i++)
- snprintfcat(logformat, LARGEBUF, "%s ", argv[i]);
-+ }
-+
-+ if (monhost_child_anchor != NULL) {
-+ if (foreground > 0)
-+ daemon_pid = 0;
-+ else
-+ daemon_pid = fork();
-+ if (!daemon_pid) {
-+ for (monhost_child_current = monhost_child_anchor;
-+ monhost_child_current != NULL;
-+ monhost_child_current = monhost_child_current->next) {
-+ if ((monhost_child_current->pid = fork()) == 0) {
-+ monhost = monhost_child_current->monhost;
-+ logfn = monhost_child_current->logfn;
-+ pidfilebase = monhost_child_current->pidfilebase;
-+ foreground = 1;
-+ break;
-+ }
-+ }
-+ if (monhost_child_anchor->pid) { /* parent */
-+ for (mh = 0; mh < sizeof(trapped_signals)/sizeof(trapped_signals[0]); mh++) {
-+ upslog_sigaction.sa_handler = &term_handler;
-+ sigfillset(&upslog_sigaction.sa_mask);
-+ upslog_sigaction.sa_flags = SA_NOCLDSTOP | SA_NOCLDWAIT;
-+ sigaction(trapped_signals[mh], &upslog_sigaction, NULL);
-+ }
-+ become_user(get_user_pwent(user));
-+ writepid(pidfilebase);
-+ while(wait(&wait_status) > 0);
-+ exit(EXIT_SUCCESS);
-+ }
-+ } else {
-+ exit(EXIT_SUCCESS);
-+ }
- }
-
- if (!monhost)
diff --git a/sysutils/nut/files/patch-docs_man_upslog.8 b/sysutils/nut/files/patch-docs_man_upslog.8
deleted file mode 100644
index 10335395cea9..000000000000
--- a/sysutils/nut/files/patch-docs_man_upslog.8
+++ /dev/null
@@ -1,16 +0,0 @@
---- docs/man/upslog.8.orig 2022-04-26 15:07:16.000000000 -0700
-+++ docs/man/upslog.8 2022-08-24 07:39:07.356811000 -0700
-@@ -134,6 +134,13 @@
- upsname[@hostname[:port]]\&. The default hostname is "localhost"\&.
- .RE
- .PP
-+\fB\-m\fR \fItuple\fR
-+.RS 4
-+Monitor multiple UPSs. The format for this option is a tuple of
-+ups, logfile, and pidfile separated by commas. An example would be:
-+`upsname@hostname:9999,/var/log/nut/cps.log,/var/run/cps.pid`
-+.RE
-+.PP
- \fB\-u\fR \fIusername\fR
- .RS 4
- If started as root, upslog will
diff --git a/sysutils/nut/files/patch-include_nut__stdint.h b/sysutils/nut/files/patch-include_nut__stdint.h
deleted file mode 100644
index fdd2bd783c61..000000000000
--- a/sysutils/nut/files/patch-include_nut__stdint.h
+++ /dev/null
@@ -1,31 +0,0 @@
---- include/nut_stdint.h.orig 2022-08-24 07:49:23.934399000 -0700
-+++ include/nut_stdint.h 2022-08-24 07:56:48.050406000 -0700
-@@ -52,6 +52,28 @@
- #endif
-
- /* Printing format for size_t and ssize_t */
-+#ifndef PRIuSIZE
-+# ifdef PRIsize
-+# define PRIuSIZE PRIsize
-+# else
-+# if defined(__MINGW32__) || defined (WIN32)
-+# define PRIuSIZE "llu"
-+# else
-+# define PRIuSIZE "zu"
-+# endif
-+# endif
-+#endif
-+
-+#ifndef PRIxSIZE
-+# if defined(__MINGW32__) || defined (WIN32)
-+# define PRIxSIZE "llx"
-+# else
-+# define PRIxSIZE "zx"
-+# endif
-+#endif
-+
-+/* Note: Windows headers are known to define at least "d" values,
-+ * so macros below revolve around that and not "i" directly */
- #ifndef PRIsize
- # if defined(__MINGW32__)
- # define PRIsize "u"