aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2024-03-04 16:37:58 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2024-03-04 16:37:58 +0000
commitdc54c23abc95eebbd14d84a74716c7b24ef79b34 (patch)
tree5a783a8f4207cf3f013ebb2d8f95310bad6a408f
parent647eff0a345198ed8084133a35472127f3a2b757 (diff)
downloadports-dc54c23abc95eebbd14d84a74716c7b24ef79b34.tar.gz
ports-dc54c23abc95eebbd14d84a74716c7b24ef79b34.zip
net-mgmt/p5-Prometheus-Tiny: Add new port
Prometheus::Tiny is a minimal metrics client for the Prometheus time-series database. Approved by: hrs (mentor)
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/p5-Prometheus-Tiny/Makefile28
-rw-r--r--net-mgmt/p5-Prometheus-Tiny/distinfo3
-rw-r--r--net-mgmt/p5-Prometheus-Tiny/pkg-descr13
4 files changed, 45 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index a7d20601fe6b..c580de378c80 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -266,6 +266,7 @@
SUBDIR += p5-NetAddr-IP-Lite
SUBDIR += p5-NetApp
SUBDIR += p5-POE-Component-SNMP
+ SUBDIR += p5-Prometheus-Tiny
SUBDIR += p5-RDR-Collector
SUBDIR += p5-SNMP-Info
SUBDIR += p5-SNMP-MIB-Compiler
diff --git a/net-mgmt/p5-Prometheus-Tiny/Makefile b/net-mgmt/p5-Prometheus-Tiny/Makefile
new file mode 100644
index 000000000000..8fc60ea52cd4
--- /dev/null
+++ b/net-mgmt/p5-Prometheus-Tiny/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= Prometheus-Tiny
+PORTVERSION= 0.011
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Tiny Prometheus client
+WWW= https://metacpan.org/release/Prometheus-Tiny
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+#TEST_DEPENDS= p5-HTTP-Request-Common>0:p5-HTTP-Request-Common \
+# p5-Plack-Test>0:p5-Plack-Test \
+# p5-Test-Exception>0:devel/p5-Test-Exception \
+# p5-Test-Warn>0:devel/p5-Test-Warn
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+NO_TEST= yes # not work by a lack of some ports #
+
+PLIST_FILES= ${SITE_MAN3_REL}/Prometheus::Tiny.3.gz \
+ ${SITE_PERL_REL}/Prometheus/Tiny.pm
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Prometheus-Tiny/distinfo b/net-mgmt/p5-Prometheus-Tiny/distinfo
new file mode 100644
index 000000000000..6bb03e2075ad
--- /dev/null
+++ b/net-mgmt/p5-Prometheus-Tiny/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708678167
+SHA256 (Prometheus-Tiny-0.011.tar.gz) = 8db1480f3c89eb86d414cf5f47feed8df3112b38c463cb8f65b4c064e20b1e13
+SIZE (Prometheus-Tiny-0.011.tar.gz) = 18129
diff --git a/net-mgmt/p5-Prometheus-Tiny/pkg-descr b/net-mgmt/p5-Prometheus-Tiny/pkg-descr
new file mode 100644
index 000000000000..c994763c5b85
--- /dev/null
+++ b/net-mgmt/p5-Prometheus-Tiny/pkg-descr
@@ -0,0 +1,13 @@
+Prometheus::Tiny is a minimal metrics client for the Prometheus
+time-series database.
+
+It does the following things differently to Net::Prometheus:
+
+ - No setup. You don't need to pre-declare metrics to get something useful.
+ - Labels are passed in a hash. Positional parameters get awkward.
+ - No inbuilt collectors, PSGI apps, etc. Just the metrics.
+ - Doesn't know anything about different metric types. You get what you ask for.
+
+These could all be pros or cons, depending on what you need. For me,
+I needed a compact base that I could back on a shared memory region.
+See Prometheus::Tiny::Shared for that!