aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-10-14 19:34:43 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2021-10-14 19:50:37 +0000
commitdc703bd694e830e33dcdc3b371648e3d8920e859 (patch)
treed5d6dcfb980d64249b41a67c8a1ae4be0f33faca
parentc6f10a7b5ed6b991cf4c47254628ed7130e0116e (diff)
downloadports-dc703bd694e830e33dcdc3b371648e3d8920e859.tar.gz
ports-dc703bd694e830e33dcdc3b371648e3d8920e859.zip
textproc/htmldoc: Update to 1.9.12 +
- fix line break in USES that lead to wrong X11 usage - make USE=jpeg unconditional because it is needed even if HTMLDOCGUI is off - make pkgconfig unconditional because it is needed even if gnutls is not used - remove arm64 pre-build as it doesn't seem to be needed (perhaps ndowens knows more; he added it) - remove a PPC patch by pkubaj as it no longer required - apply formatting fixes from linters (portclippy, portfmt, portlint) Changelogs: https://www.msweet.org/blog/2021-05-17-htmldoc-1.9.12.html https://www.msweet.org/blog/2020-12-24-htmldoc-1.9.11.html https://www.msweet.org/blog/2020-09-05-htmldoc-1.9.10.html https://www.msweet.org/blog/2020-06-11-htmldoc-1.9.9.html https://www.msweet.org/blog/2020-02-15-htmldoc-1.9.8.html https://www.msweet.org/blog/2019-10-09-htmldoc-1.9.7.html https://www.msweet.org/blog/2019-09-25-htmldoc-1.9.6.html https://www.msweet.org/blog/2019-01-23-htmldoc-1.9.5.html https://www.msweet.org/blog/2018-08-31-htmldoc-1.9.4.html PR: 258507 Approved by: jose@diasfernandes.pt (maintainer)
-rw-r--r--textproc/htmldoc/Makefile35
-rw-r--r--textproc/htmldoc/distinfo6
-rw-r--r--textproc/htmldoc/files/patch-png_pngpriv.h14
3 files changed, 16 insertions, 39 deletions
diff --git a/textproc/htmldoc/Makefile b/textproc/htmldoc/Makefile
index 7d15f85c70af..b03520ef30bd 100644
--- a/textproc/htmldoc/Makefile
+++ b/textproc/htmldoc/Makefile
@@ -1,10 +1,9 @@
# Created by: Glenn Trewitt <glenn@trewitt.org>
-PORTNAME= htmldoc
-PORTVERSION= 1.9.3
-PORTREVISION= 1
+PORTNAME= htmldoc
+PORTVERSION= 1.9.12
DISTVERSIONPREFIX= v
-CATEGORIES= textproc
+CATEGORIES= textproc
MAINTAINER= jose@diasfernandes.pt
COMMENT= Converts HTML to PDF and/or PostScript
@@ -12,40 +11,32 @@ COMMENT= Converts HTML to PDF and/or PostScript
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_mips= Complains of expecting ) before png_ptr
+BROKEN_mips= complains about expecting ) before png_ptr
LIB_DEPENDS= libpng.so:graphics/png
-USES= compiler:c11 cpe
+USES= compiler:c11 cpe jpeg pkgconfig
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
GH_ACCOUNT= michaelrsweet
HAS_CONFIGURE= yes
-OPTIONS_DEFINE= HTMLDOCGUI GNUTLS
+OPTIONS_DEFINE= GNUTLS HTMLDOCGUI
OPTIONS_DEFAULT= GNUTLS
HTMLDOCGUI_DESC= Build GUI front-end
-HTMLDOCGUI_CONFIGURE_WITH= gui=yes
+
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+GNUTLS_CONFIGURE_ENABLE= gnutls
+
HTMLDOCGUI_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig
HTMLDOCGUI_USES= xorg
-HTMLDOCGUI_USE= XORG=x11,xrender,xcursor,xfixes \
- xext,xft,xinerama jpeg
-GNUTLS_CONFIGURE_ENABLE= gnutls
-GNUTLS_USES= pkgconfig
-GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-
-.include <bsd.port.pre.mk>
-
-# Fix arm64 build
-.if ${ARCH} == "aarch64"
-pre-build:
- ${REINPLACE_CMD} -e '/PNG_FILTER_OPTIMIZATIONS(pp, bpp);/d' ${WRKSRC}/png/pngrutil.c
-.endif
+HTMLDOCGUI_USE= XORG=x11,xcursor,xext,xfixes,xft,xinerama,xrender
+HTMLDOCGUI_CONFIGURE_WITH= gui=yes
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/htmldoc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/htmldoc/distinfo b/textproc/htmldoc/distinfo
index bfb93ec0b446..ed2f7b2c02f5 100644
--- a/textproc/htmldoc/distinfo
+++ b/textproc/htmldoc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535061183
-SHA256 (michaelrsweet-htmldoc-v1.9.3_GH0.tar.gz) = 601ad21f6aa7adf57a6fcfeab180dc39d6b99ec2f52f0e559df5bb57f087eb2e
-SIZE (michaelrsweet-htmldoc-v1.9.3_GH0.tar.gz) = 4482204
+TIMESTAMP = 1631647902
+SHA256 (michaelrsweet-htmldoc-v1.9.12_GH0.tar.gz) = abeb50b9a0247fee4a83af98c56ba3bc35804f593af1893899de084830315a05
+SIZE (michaelrsweet-htmldoc-v1.9.12_GH0.tar.gz) = 3422902
diff --git a/textproc/htmldoc/files/patch-png_pngpriv.h b/textproc/htmldoc/files/patch-png_pngpriv.h
deleted file mode 100644
index 8c770f7c90fb..000000000000
--- a/textproc/htmldoc/files/patch-png_pngpriv.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- png/pngpriv.h.orig 2021-03-16 01:04:47 UTC
-+++ png/pngpriv.h
-@@ -193,11 +193,7 @@
- #endif
-
- #ifndef PNG_POWERPC_VSX_OPT
--# if defined(__PPC64__) && defined(__ALTIVEC__) && defined(__VSX__)
--# define PNG_POWERPC_VSX_OPT 2
--# else
- # define PNG_POWERPC_VSX_OPT 0
--# endif
- #endif
-
- #ifndef PNG_INTEL_SSE_OPT