aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorR. Christian McDonald <rcm@rcm.sh>2023-05-30 19:03:18 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-06-26 23:30:28 +0000
commitdcb400297a3bd5a5880c2abf0cead0dc53004ca3 (patch)
treee5f674b6b762e4d0c6b782f7bed983b2279001fc
parentcb40b0a43949a621f407fa3b65dff7349b024ba2 (diff)
downloadports-dcb400297a3bd5a5880c2abf0cead0dc53004ca3.tar.gz
ports-dcb400297a3bd5a5880c2abf0cead0dc53004ca3.zip
net/miniupnpd: remove ipfw port option
It is well-known that net/miniupnpd does not work with IPFW. However, the port options still allow building with IPFW support. In order to prevent unnecessary foot-shooting, let us eliminate this option outright and unconditionally use pf instead. PR: 271732 Approved by: squat@squat.no (maintainer timeout, two weeks) Sponsored by: Rubicon Communications, LLC ("Netgate")
-rw-r--r--net/miniupnpd/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 3c5e4e28f813..1c9e6e87aebd 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -1,10 +1,11 @@
PORTNAME= miniupnpd
-PORTVERSION= 2.3.3
+DISTVERSION= 2.3.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MAINTAINER= squat@squat.no
-COMMENT= UPnP IGD implementation which uses pf/ipf
+COMMENT= UPnP IGD implementation which uses pf
WWW= http://miniupnp.free.fr/
LICENSE= BSD3CLAUSE
@@ -31,23 +32,19 @@ PLIST_FILES= etc/miniupnpd.conf.sample \
man/man8/miniupnpd.8.gz \
sbin/miniupnpd
+# unconditionally use pf, ipfw does not work on FreeBSD
+CONFIGURE_ARGS= --firewall=pf
+
OPTIONS_DEFINE= CHECK_PORTINUSE IPV6 LEASEFILE UPNP_IGDV2 \
UPNP_STRICT
-OPTIONS_DEFAULT= AUTODETECT_FW
-OPTIONS_SINGLE= FIREWALL
-OPTIONS_SINGLE_FIREWALL= AUTODETECT_FW IPFW PF
-AUTODETECT_FW_DESC= Try to autodetect firewall type
CHECK_PORTINUSE_DESC= Check if ports are in use
-IPFW_DESC= Use IPFW as firewall type
LEASEFILE_DESC= Enable lease file
-PF_DESC= Use PF as firewall type
UPNP_IGDV2_DESC= Build an IGDv2 instead of an IGDv1
UPNP_STRICT_DESC= More strict UPnP specification compliance
CHECK_PORTINUSE_CONFIGURE_ON= --portinuse
IPV6_CONFIGURE_ON= --ipv6
LEASEFILE_CONFIGURE_ON= --leasefile
-PF_CONFIGURE_ON= --firewall=pf
UPNP_IGDV2_CONFIGURE_ON= --igd2
UPNP_STRICT_CONFIGURE_ON= --strict