aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2024-03-11 20:32:33 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2024-03-15 20:45:11 +0000
commitdcf72144b330cb4c54c7760382a58f1217944413 (patch)
tree06d0b0947d546ac2c7d1f70492944ffac65bd029
parent4d6dff20cdbc7e3bc41a3e0b668d474033d9bb2c (diff)
downloadports-dcf72144b330cb4c54c7760382a58f1217944413.tar.gz
ports-dcf72144b330cb4c54c7760382a58f1217944413.zip
graphics/qgis*: Use GRASS8
Approved by: rhurlin (via mail)
-rw-r--r--graphics/qgis-ltr/Makefile22
-rw-r--r--graphics/qgis-ltr/pkg-plist30
-rw-r--r--graphics/qgis/Makefile23
-rw-r--r--graphics/qgis/pkg-plist30
4 files changed, 32 insertions, 73 deletions
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index 724e998cdde4..157c1ee004b0 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.34.4
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
PKGNAMESUFFIX= -ltr
@@ -149,22 +150,17 @@ CMAKE_ARGS+= -Wno-dev
CMAKE_OFF+= SUPPRESS_QT_WARNINGS
.endif
-OPTIONS_DEFINE= SERVER
-OPTIONS_DEFAULT= SERVER GRASS8
-OPTIONS_RADIO= GRASS
-OPTIONS_RADIO_GRASS= GRASS7 GRASS8
+OPTIONS_DEFINE= SERVER GRASS
+OPTIONS_DEFAULT= SERVER GRASS
NO_OPTIONS_SORT= yes
OPTIONS_SUB= yes
GRASS_DESC= Add GRASS GIS to processing tools
SERVER_DESC= Enable QGIS server
-GRASS7_BUILD_DEPENDS= grass7:databases/grass7
-GRASS7_RUN_DEPENDS= ${GRASS7_BUILD_DEPENDS}
-GRASS7_CMAKE_BOOL= WITH_GRASS7
-GRASS8_BUILD_DEPENDS= grass8:databases/grass8
-GRASS8_RUN_DEPENDS= ${GRASS8_BUILD_DEPENDS}
-GRASS8_CMAKE_BOOL= WITH_GRASS8
+GRASS_BUILD_DEPENDS= grass8:databases/grass8
+GRASS_RUN_DEPENDS= ${GRASS_BUILD_DEPENDS}
+GRASS_CMAKE_BOOL= WITH_GRASS8
SERVER_LIB_DEPENDS= libfcgi.so:www/fcgi
SERVER_CMAKE_BOOL= WITH_SERVER WITH_SERVER_PLUGINS WITH_QSPATIALITE
@@ -187,12 +183,6 @@ post-patch:
pre-configure:
${MKDIR} ${CONFIGURE_WRKSRC}/bin && ${LN} -s ${PYTHON_CMD} ${CONFIGURE_WRKSRC}/bin/python3
-.if ${PORT_OPTIONS:MGRASS7} || ${PORT_OPTIONS:MGRASS8}
-PLIST_SUB+= GRASS="" NO_GRASS="@comment "
-.else
-PLIST_SUB+= GRASS="@comment " NO_GRASS=""
-.endif
-
post-install:
@${RM} ${STAGEDIR}${DATADIR}/python/pytz/tzfile.py.bak
diff --git a/graphics/qgis-ltr/pkg-plist b/graphics/qgis-ltr/pkg-plist
index db77019a93b3..a1ed32824d2c 100644
--- a/graphics/qgis-ltr/pkg-plist
+++ b/graphics/qgis-ltr/pkg-plist
@@ -2365,24 +2365,17 @@ lib/libqgis_native.so
lib/libqgis_native.so.%%DISTVERSION%%
%%SERVER%%lib/libqgis_server.so
%%SERVER%%lib/libqgis_server.so.%%DISTVERSION%%
-%%GRASS7%%lib/libqgisgrass7.so
-%%GRASS8%%lib/libqgisgrass8.so
-%%GRASS7%%lib/libqgisgrass7.so.%%DISTVERSION%%
-%%GRASS8%%lib/libqgisgrass8.so.%%DISTVERSION%%
+%%GRASS%%lib/libqgisgrass8.so
+%%GRASS%%lib/libqgisgrass8.so.%%DISTVERSION%%
lib/libqgispython.so
lib/libqgispython.so.%%DISTVERSION%%
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qgis_customwidgets.py
lib/qgis/crssync
-%%GRASS7%%lib/qgis/grass/bin/qgis.g.browser7
-%%GRASS8%%lib/qgis/grass/bin/qgis.g.browser8
-%%GRASS7%%lib/qgis/grass/modules/qgis.d.rast7
-%%GRASS8%%lib/qgis/grass/modules/qgis.d.rast8
-%%GRASS7%%lib/qgis/grass/modules/qgis.g.info7
-%%GRASS8%%lib/qgis/grass/modules/qgis.g.info8
-%%GRASS7%%lib/qgis/grass/modules/qgis.r.in7
-%%GRASS8%%lib/qgis/grass/modules/qgis.r.in8
-%%GRASS7%%lib/qgis/grass/modules/qgis.v.in7
-%%GRASS8%%lib/qgis/grass/modules/qgis.v.in8
+%%GRASS%%lib/qgis/grass/bin/qgis.g.browser8
+%%GRASS%%lib/qgis/grass/modules/qgis.d.rast8
+%%GRASS%%lib/qgis/grass/modules/qgis.g.info8
+%%GRASS%%lib/qgis/grass/modules/qgis.r.in8
+%%GRASS%%lib/qgis/grass/modules/qgis.v.in8
lib/qgis/pdal_wrench
lib/qgis/plugins/libauthmethod_apiheader.so
lib/qgis/plugins/libauthmethod_awss3.so
@@ -2394,18 +2387,15 @@ lib/qgis/plugins/libauthmethod_oauth2.so
lib/qgis/plugins/libauthmethod_pkcs12.so
lib/qgis/plugins/libauthmethod_pkipaths.so
lib/qgis/plugins/libplugin_geometrychecker.so
-%%GRASS7%%lib/qgis/plugins/libplugin_grass7.so
-%%GRASS8%%lib/qgis/plugins/libplugin_grass8.so
+%%GRASS%%lib/qgis/plugins/libplugin_grass8.so
lib/qgis/plugins/libplugin_offlineediting.so
lib/qgis/plugins/libplugin_topology.so
lib/qgis/plugins/libprovider_arcgisfeatureserver.so
lib/qgis/plugins/libprovider_arcgismapserver.so
lib/qgis/plugins/libprovider_delimitedtext.so
lib/qgis/plugins/libprovider_gpx.so
-%%GRASS7%%lib/qgis/plugins/libprovider_grass7.so
-%%GRASS8%%lib/qgis/plugins/libprovider_grass8.so
-%%GRASS7%%lib/qgis/plugins/libprovider_grassraster7.so
-%%GRASS8%%lib/qgis/plugins/libprovider_grassraster8.so
+%%GRASS%%lib/qgis/plugins/libprovider_grass8.so
+%%GRASS%%lib/qgis/plugins/libprovider_grassraster8.so
lib/qgis/plugins/libprovider_mdal.so
lib/qgis/plugins/libprovider_mssql.so
lib/qgis/plugins/libprovider_pdal.so
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index d1f4a63c6e54..6ecfa05bbff2 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -1,6 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.36.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
@@ -146,22 +146,17 @@ CMAKE_ARGS+= -Wno-dev
CMAKE_OFF+= SUPPRESS_QT_WARNINGS
.endif
-OPTIONS_DEFINE= SERVER
-OPTIONS_DEFAULT= SERVER GRASS8
-OPTIONS_RADIO= GRASS
-OPTIONS_RADIO_GRASS= GRASS7 GRASS8
+OPTIONS_DEFINE= SERVER GRASS
+OPTIONS_DEFAULT= SERVER GRASS
NO_OPTIONS_SORT= yes
OPTIONS_SUB= yes
GRASS_DESC= Add GRASS GIS to processing tools
SERVER_DESC= Enable QGIS server
-GRASS7_BUILD_DEPENDS= grass7:databases/grass7
-GRASS7_RUN_DEPENDS= ${GRASS7_BUILD_DEPENDS}
-GRASS7_CMAKE_BOOL= WITH_GRASS7
-GRASS8_BUILD_DEPENDS= grass8:databases/grass8
-GRASS8_RUN_DEPENDS= ${GRASS8_BUILD_DEPENDS}
-GRASS8_CMAKE_BOOL= WITH_GRASS8
+GRASS_BUILD_DEPENDS= grass8:databases/grass8
+GRASS_RUN_DEPENDS= ${GRASS_BUILD_DEPENDS}
+GRASS_CMAKE_BOOL= WITH_GRASS8
SERVER_LIB_DEPENDS= libfcgi.so:www/fcgi
SERVER_CMAKE_BOOL= WITH_SERVER WITH_SERVER_PLUGINS WITH_QSPATIALITE
@@ -184,12 +179,6 @@ post-patch:
pre-configure:
${MKDIR} ${CONFIGURE_WRKSRC}/bin && ${LN} -s ${PYTHON_CMD} ${CONFIGURE_WRKSRC}/bin/python3
-.if ${PORT_OPTIONS:MGRASS7} || ${PORT_OPTIONS:MGRASS8}
-PLIST_SUB+= GRASS="" NO_GRASS="@comment "
-.else
-PLIST_SUB+= GRASS="@comment " NO_GRASS=""
-.endif
-
post-install:
@${RM} ${STAGEDIR}${DATADIR}/python/pytz/tzfile.py.bak
diff --git a/graphics/qgis/pkg-plist b/graphics/qgis/pkg-plist
index 60d4865bd948..23f61a4b814b 100644
--- a/graphics/qgis/pkg-plist
+++ b/graphics/qgis/pkg-plist
@@ -2400,24 +2400,17 @@ lib/libqgis_native.so
lib/libqgis_native.so.%%DISTVERSION%%
%%SERVER%%lib/libqgis_server.so
%%SERVER%%lib/libqgis_server.so.%%DISTVERSION%%
-%%GRASS7%%lib/libqgisgrass7.so
-%%GRASS8%%lib/libqgisgrass8.so
-%%GRASS7%%lib/libqgisgrass7.so.%%DISTVERSION%%
-%%GRASS8%%lib/libqgisgrass8.so.%%DISTVERSION%%
+%%GRASS%%lib/libqgisgrass8.so
+%%GRASS%%lib/libqgisgrass8.so.%%DISTVERSION%%
lib/libqgispython.so
lib/libqgispython.so.%%DISTVERSION%%
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qgis_customwidgets.py
lib/qgis/crssync
-%%GRASS7%%lib/qgis/grass/bin/qgis.g.browser7
-%%GRASS8%%lib/qgis/grass/bin/qgis.g.browser8
-%%GRASS7%%lib/qgis/grass/modules/qgis.d.rast7
-%%GRASS8%%lib/qgis/grass/modules/qgis.d.rast8
-%%GRASS7%%lib/qgis/grass/modules/qgis.g.info7
-%%GRASS8%%lib/qgis/grass/modules/qgis.g.info8
-%%GRASS7%%lib/qgis/grass/modules/qgis.r.in7
-%%GRASS8%%lib/qgis/grass/modules/qgis.r.in8
-%%GRASS7%%lib/qgis/grass/modules/qgis.v.in7
-%%GRASS8%%lib/qgis/grass/modules/qgis.v.in8
+%%GRASS%%lib/qgis/grass/bin/qgis.g.browser8
+%%GRASS%%lib/qgis/grass/modules/qgis.d.rast8
+%%GRASS%%lib/qgis/grass/modules/qgis.g.info8
+%%GRASS%%lib/qgis/grass/modules/qgis.r.in8
+%%GRASS%%lib/qgis/grass/modules/qgis.v.in8
lib/qgis/pdal_wrench
lib/qgis/plugins/libauthmethod_apiheader.so
lib/qgis/plugins/libauthmethod_awss3.so
@@ -2429,18 +2422,15 @@ lib/qgis/plugins/libauthmethod_oauth2.so
lib/qgis/plugins/libauthmethod_pkcs12.so
lib/qgis/plugins/libauthmethod_pkipaths.so
lib/qgis/plugins/libplugin_geometrychecker.so
-%%GRASS7%%lib/qgis/plugins/libplugin_grass7.so
-%%GRASS8%%lib/qgis/plugins/libplugin_grass8.so
+%%GRASS%%lib/qgis/plugins/libplugin_grass8.so
lib/qgis/plugins/libplugin_offlineediting.so
lib/qgis/plugins/libplugin_topology.so
lib/qgis/plugins/libprovider_arcgisfeatureserver.so
lib/qgis/plugins/libprovider_arcgismapserver.so
lib/qgis/plugins/libprovider_delimitedtext.so
lib/qgis/plugins/libprovider_gpx.so
-%%GRASS7%%lib/qgis/plugins/libprovider_grass7.so
-%%GRASS8%%lib/qgis/plugins/libprovider_grass8.so
-%%GRASS7%%lib/qgis/plugins/libprovider_grassraster7.so
-%%GRASS8%%lib/qgis/plugins/libprovider_grassraster8.so
+%%GRASS%%lib/qgis/plugins/libprovider_grass8.so
+%%GRASS%%lib/qgis/plugins/libprovider_grassraster8.so
lib/qgis/plugins/libprovider_mdal.so
lib/qgis/plugins/libprovider_mssql.so
lib/qgis/plugins/libprovider_pdal.so