aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-04-25 10:42:39 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2023-04-25 10:46:21 +0000
commitdd35cf3590e882c46413e3cc19443d5822610662 (patch)
tree6721a3d8a9b805468ea34c26d73033b4302ca38d
parentf15980d52797d012d4d346d93a454a47c8a5146d (diff)
downloadports-dd35cf3590e882c46413e3cc19443d5822610662.tar.gz
ports-dd35cf3590e882c46413e3cc19443d5822610662.zip
net-im/telegram-desktop: update 4.8.0 -> 4.8.1
Fix build with QT6. (*) Also, fix SYSTEM_FONTS option. Patches from: https://github.com/telegramdesktop/tdesktop/pull/26219 (*) Fixes: f7596f833caa1b18c84714e4648008a3fc78bbb2
-rw-r--r--net-im/telegram-desktop/Makefile4
-rw-r--r--net-im/telegram-desktop/distinfo6
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp14
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp23
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp14
-rw-r--r--net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp14
6 files changed, 70 insertions, 5 deletions
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index de037500570a..aa3c5e5089b8 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -1,5 +1,5 @@
PORTNAME= telegram-desktop
-DISTVERSION= 4.8.0
+DISTVERSION= 4.8.1
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@@ -93,7 +93,7 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
ALSA_CMAKE_BOOL_OFF= LIBTGVOIP_DISABLE_ALSA
PULSEAUDIO_CMAKE_BOOL_OFF= LIBTGVOIP_DISABLE_PULSEAUDIO
-SYSTEM_FONTS_CMAKE_BOOL= DESKTOP_APP_USE_PACKAGED_FONTS
+SYSTEM_FONTS_CMAKE_BOOL_OFF= DESKTOP_APP_USE_PACKAGED_FONTS
# Telegram asks each custom build to have its own API ID and hash.
TELEGRAM_API_HASH= 20a3432aab43f24bb4460fceac5ba38d
diff --git a/net-im/telegram-desktop/distinfo b/net-im/telegram-desktop/distinfo
index 7d720dfa71db..ac711158bb98 100644
--- a/net-im/telegram-desktop/distinfo
+++ b/net-im/telegram-desktop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1682201134
-SHA256 (tdesktop-4.8.0-full.tar.gz) = 99d50c75171c8c6e74b2b9298db48deff32a60ced35195f9279469914b8ee1f9
-SIZE (tdesktop-4.8.0-full.tar.gz) = 63994851
+TIMESTAMP = 1682388062
+SHA256 (tdesktop-4.8.1-full.tar.gz) = 96660bb151c035a80c5b32a8fe043cecb54e9fe450329cf612ecb752db68c06f
+SIZE (tdesktop-4.8.1-full.tar.gz) = 63997319
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp
new file mode 100644
index 000000000000..267e419cb7ca
--- /dev/null
+++ b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp
@@ -0,0 +1,14 @@
+unbreak clang 13 build
+
+Index: Telegram/SourceFiles/api/api_chat_filters.cpp
+--- Telegram/SourceFiles/api/api_chat_filters.cpp.orig
++++ Telegram/SourceFiles/api/api_chat_filters.cpp
+@@ -227,7 +227,7 @@ void ImportInvite(
+ };
+ auto inputs = peers | ranges::views::transform([](auto peer) {
+ return MTPInputPeer(peer->input);
+- }) | ranges::to<QVector>();
++ }) | ranges::to<QVector<MTPInputPeer>>();
+ if (!slug.isEmpty()) {
+ api->request(MTPchatlists_JoinChatlistInvite(
+ MTP_string(slug),
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp
new file mode 100644
index 000000000000..f9cf3585a624
--- /dev/null
+++ b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp
@@ -0,0 +1,23 @@
+unbreak clang 13 build
+
+Index: Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp
+--- Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp.orig
++++ Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp
+@@ -1028,7 +1028,7 @@ void ExportFilterLink(
+ const auto session = &front->session();
+ auto mtpPeers = peers | ranges::views::transform(
+ [](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); }
+- ) | ranges::to<QVector>();
++ ) | ranges::to<QVector<MTPInputPeer>>();
+ session->api().request(MTPchatlists_ExportChatlistInvite(
+ MTP_inputChatlistDialogFilter(MTP_int(id)),
+ MTP_string(), // title
+@@ -1061,7 +1061,7 @@ void EditLinkChats(
+ const auto session = &front->session();
+ auto mtpPeers = peers | ranges::views::transform(
+ [](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); }
+- ) | ranges::to<QVector>();
++ ) | ranges::to<QVector<MTPInputPeer>>();
+ session->api().request(MTPchatlists_EditExportedInvite(
+ MTP_flags(MTPchatlists_EditExportedInvite::Flag::f_peers),
+ MTP_inputChatlistDialogFilter(MTP_int(link.id)),
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp
new file mode 100644
index 000000000000..bb4b01dcc26d
--- /dev/null
+++ b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp
@@ -0,0 +1,14 @@
+unbreak clang 13 build
+
+Index: Telegram/SourceFiles/settings/settings_folders.cpp
+--- Telegram/SourceFiles/settings/settings_folders.cpp.orig
++++ Telegram/SourceFiles/settings/settings_folders.cpp
+@@ -696,7 +696,7 @@ void FilterRowButton::paintEvent(QPaintEvent *e) {
+ row.removePeers
+ ) | ranges::views::transform([](not_null<PeerData*> peer) {
+ return MTPInputPeer(peer->input);
+- }) | ranges::to<QVector>();
++ }) | ranges::to<QVector<MTPInputPeer>>();
+ removeChatlistRequests.push_back(
+ MTPchatlists_LeaveChatlist(
+ MTP_inputChatlistDialogFilter(MTP_int(newId)),
diff --git a/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp
new file mode 100644
index 000000000000..931f5b673762
--- /dev/null
+++ b/net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp
@@ -0,0 +1,14 @@
+unbreak clang 13 build
+
+Index: Telegram/SourceFiles/window/window_filters_menu.cpp
+--- Telegram/SourceFiles/window/window_filters_menu.cpp.orig
++++ Telegram/SourceFiles/window/window_filters_menu.cpp
+@@ -494,7 +494,7 @@ void FiltersMenu::remove(
+ leave
+ ) | ranges::views::transform([](not_null<PeerData*> peer) {
+ return MTPInputPeer(peer->input);
+- }) | ranges::to<QVector>())
++ }) | ranges::to<QVector<MTPInputPeer>>())
+ )).done([=](const MTPUpdates &result) {
+ api->applyUpdates(result);
+ }).send();