aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2022-07-26 16:11:38 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2022-07-26 17:21:08 +0000
commitdd6d86470a90b4ec66a4d73026fc52d38a231cd5 (patch)
tree493c90983b45be73319f266133eaea568866f3a0
parent6f94e40e34dbb6d709068840e1bbb946eac250f2 (diff)
downloadports-dd6d86470a90b4ec66a4d73026fc52d38a231cd5.tar.gz
ports-dd6d86470a90b4ec66a4d73026fc52d38a231cd5.zip
sysutils/git-prev-next: Add port
git-prev-next allows to easily navigate commits, and amend them. It is built on top of interactive rebase. WWW: https://github.com/ridiculousfish/git-prev-next
-rw-r--r--devel/Makefile1
-rw-r--r--devel/git-prev-next/Makefile36
-rw-r--r--devel/git-prev-next/distinfo3
-rw-r--r--devel/git-prev-next/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 31b69b8de8bf..1598f4f1b638 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -794,6 +794,7 @@
SUBDIR += git-merge-changelog
SUBDIR += git-modes
SUBDIR += git-p4
+ SUBDIR += git-prev-next
SUBDIR += git-review
SUBDIR += git-subrepo
SUBDIR += git-svn
diff --git a/devel/git-prev-next/Makefile b/devel/git-prev-next/Makefile
new file mode 100644
index 000000000000..6c5bfdd19b34
--- /dev/null
+++ b/devel/git-prev-next/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= git-prev-next
+DISTVERSION= g20220319
+CATEGORIES= devel
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Git commands for navigating and editing Git commit history
+
+LICENSE= CC0-1.0
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= ridiculousfish
+GH_TAGNAME= 6d070d3
+SHEBANG_FILES= ${_SCRIPTS}
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= ${_SCRIPTS:S|^|bin/|}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+_SCRIPTS= git-prev git-next
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${_SCRIPTS} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/git-prev-next/distinfo b/devel/git-prev-next/distinfo
new file mode 100644
index 000000000000..0b82f7bcfac7
--- /dev/null
+++ b/devel/git-prev-next/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1658850133
+SHA256 (ridiculousfish-git-prev-next-g20220319-6d070d3_GH0.tar.gz) = c368edd531373c64b765b1ace51858432604a02ddab8b32b672c670296a0959e
+SIZE (ridiculousfish-git-prev-next-g20220319-6d070d3_GH0.tar.gz) = 2163
diff --git a/devel/git-prev-next/pkg-descr b/devel/git-prev-next/pkg-descr
new file mode 100644
index 000000000000..6748363d60ab
--- /dev/null
+++ b/devel/git-prev-next/pkg-descr
@@ -0,0 +1,4 @@
+git-prev-next allows to easily navigate commits, and amend them.
+It is built on top of interactive rebase.
+
+WWW: https://github.com/ridiculousfish/git-prev-next