aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDarcy <darcy@dbitech.ca>2023-06-03 09:51:39 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-06-03 09:56:21 +0000
commitddb66bae1b1694cab21a0b52d6bd4d8f17260100 (patch)
tree2362caee6d2ce834c2df07ef4440c55e0fcee60e
parent7ef23b4e8c1ee4bd47f56a42025346bef5cf4315 (diff)
downloadports-ddb66bae1b1694cab21a0b52d6bd4d8f17260100.tar.gz
ports-ddb66bae1b1694cab21a0b52d6bd4d8f17260100.zip
databases/imposm3: New port: Utility to import OpenStreetMap data into PostgreSQL
- Submitter becomes maintainer Imposm is an importer for OpenStreetMap data. It reads PBF files and imports the data into PostgreSQL/PostGIS. It can also automatically update the database with the latest changes from OSM. It is designed to create databases that are optimized for rendering (i.e. generating tiles or for WMS services). WWW: http://imposm.org/docs/imposm3/latest/ PR: 258945
-rw-r--r--databases/Makefile1
-rw-r--r--databases/imposm3/Makefile31
-rw-r--r--databases/imposm3/distinfo5
-rw-r--r--databases/imposm3/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e6e3be1338e9..a21d2585c5cf 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -103,6 +103,7 @@
SUBDIR += hiredis
SUBDIR += hsqldb
SUBDIR += immudb
+ SUBDIR += imposm3
SUBDIR += influxdb
SUBDIR += influxdb2-cli
SUBDIR += innotop
diff --git a/databases/imposm3/Makefile b/databases/imposm3/Makefile
new file mode 100644
index 000000000000..862e4e58d631
--- /dev/null
+++ b/databases/imposm3/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= imposm3
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.11.1
+CATEGORIES= databases geography
+
+MAINTAINER= darcy@dbitech.ca
+COMMENT= Imposm imports OpenStreetMap data into PostGIS
+WWW= http://imposm.org/docs/imposm3/latest/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgeos.so:graphics/geos \
+ libleveldb.so:databases/leveldb
+
+USES= go:modules
+GO_MODULE= github.com/omniscale/imposm3
+GO_TARGET= ./cmd/imposm
+GO_BUILDFLAGS= -ldflags "\
+ -X github.com/omniscale/imposm3.Version=${DISTVERSION}"
+
+PLIST_FILES= bin/imposm
+
+PORTEXAMPLES= example-mapping.json example-mapping.yml
+OPTIONS_DEFINE= EXAMPLES
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/databases/imposm3/distinfo b/databases/imposm3/distinfo
new file mode 100644
index 000000000000..bf2a56fa976b
--- /dev/null
+++ b/databases/imposm3/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1675057218
+SHA256 (go/databases_imposm3/imposm3-v0.11.1/v0.11.1.mod) = 9aa4a2a81d8d8bdce8b45ad927017112d345d37ba85954c942dd49422c78a9da
+SIZE (go/databases_imposm3/imposm3-v0.11.1/v0.11.1.mod) = 589
+SHA256 (go/databases_imposm3/imposm3-v0.11.1/v0.11.1.zip) = 1887daa48293a460bb64cae3800162329d7e7d455f1421bd3c8bffbc39544cec
+SIZE (go/databases_imposm3/imposm3-v0.11.1/v0.11.1.zip) = 834723
diff --git a/databases/imposm3/pkg-descr b/databases/imposm3/pkg-descr
new file mode 100644
index 000000000000..568547ba8dfd
--- /dev/null
+++ b/databases/imposm3/pkg-descr
@@ -0,0 +1,6 @@
+Imposm is an importer for OpenStreetMap data. It reads PBF files and
+imports the data into PostgreSQL/PostGIS. It can also automatically
+update the database with the latest changes from OSM.
+
+It is designed to create databases that are optimized for rendering
+(i.e. generating tiles or for WMS services).