aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-06-10 02:09:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-06-10 02:10:57 +0000
commitddd5d93e0916ead2ae4693b513210344c25eb7e0 (patch)
treed90e146ec261a33643fff6fab3e79b94c7a973da
parent94e386c088804022c0b0677483505e28acc2dd5e (diff)
downloadports-ddd5d93e0916ead2ae4693b513210344c25eb7e0.tar.gz
ports-ddd5d93e0916ead2ae4693b513210344c25eb7e0.zip
databases/sqlitecpp: New port: SQLiteC++: Easy to use C++ SQLite3 wrapper
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sqlitecpp/Makefile25
-rw-r--r--databases/sqlitecpp/distinfo3
-rw-r--r--databases/sqlitecpp/pkg-descr4
-rw-r--r--databases/sqlitecpp/pkg-plist18
5 files changed, 51 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 8d19611241b2..988dc8f7876e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -1008,6 +1008,7 @@
SUBDIR += sqlite3
SUBDIR += sqlitebrowser
SUBDIR += sqliteconvert
+ SUBDIR += sqlitecpp
SUBDIR += sqlitemanager
SUBDIR += sqliteodbc
SUBDIR += sqlitestudio
diff --git a/databases/sqlitecpp/Makefile b/databases/sqlitecpp/Makefile
new file mode 100644
index 000000000000..1c435e9350cd
--- /dev/null
+++ b/databases/sqlitecpp/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= sqlitecpp
+DISTVERSION= 3.1.1-28
+DISTVERSIONSUFFIX= -g0c46d86
+CATEGORIES= databases devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= SQLiteC++: Easy to use C++ SQLite3 wrapper
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+TEST_DEPENDS= googletest>0:devel/googletest
+
+USES= cmake:testing compiler:c++11-lang sqlite
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= SRombauts
+GH_PROJECT= SQLiteCpp
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= SQLITECPP_INTERNAL_SQLITE SQLITECPP_RUN_CPPLINT
+CMAKE_TESTING_ON= SQLITECPP_BUILD_TESTS
+
+.include <bsd.port.mk>
diff --git a/databases/sqlitecpp/distinfo b/databases/sqlitecpp/distinfo
new file mode 100644
index 000000000000..9e0f4b726fa3
--- /dev/null
+++ b/databases/sqlitecpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623289372
+SHA256 (SRombauts-SQLiteCpp-3.1.1-28-g0c46d86_GH0.tar.gz) = f7037c4726fae366988467b21d8c699211c6a19f051c5544653b4d413087dc7f
+SIZE (SRombauts-SQLiteCpp-3.1.1-28-g0c46d86_GH0.tar.gz) = 2431117
diff --git a/databases/sqlitecpp/pkg-descr b/databases/sqlitecpp/pkg-descr
new file mode 100644
index 000000000000..0221061b0b31
--- /dev/null
+++ b/databases/sqlitecpp/pkg-descr
@@ -0,0 +1,4 @@
+SQLiteC++ offers an encapsulation layer around the native C APIs of SQLite, with
+a few intuitive and well documented C++ classes.
+
+WWW: https://github.com/SRombauts/SQLiteCpp
diff --git a/databases/sqlitecpp/pkg-plist b/databases/sqlitecpp/pkg-plist
new file mode 100644
index 000000000000..5bcbec25253a
--- /dev/null
+++ b/databases/sqlitecpp/pkg-plist
@@ -0,0 +1,18 @@
+include/SQLiteCpp/Assertion.h
+include/SQLiteCpp/Backup.h
+include/SQLiteCpp/Column.h
+include/SQLiteCpp/Database.h
+include/SQLiteCpp/Exception.h
+include/SQLiteCpp/ExecuteMany.h
+include/SQLiteCpp/SQLiteCpp.h
+include/SQLiteCpp/Savepoint.h
+include/SQLiteCpp/Statement.h
+include/SQLiteCpp/Transaction.h
+include/SQLiteCpp/Utils.h
+include/SQLiteCpp/VariadicBind.h
+lib/cmake/SQLiteCpp/SQLiteCppConfig.cmake
+lib/cmake/SQLiteCpp/SQLiteCppConfigVersion.cmake
+lib/cmake/SQLiteCpp/SQLiteCppTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/SQLiteCpp/SQLiteCppTargets.cmake
+lib/libSQLiteCpp.so
+lib/libSQLiteCpp.so.0