aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2023-07-29 09:06:18 +0000
committerThomas Zander <riggs@FreeBSD.org>2023-07-29 09:09:47 +0000
commitddda6e3a47177bce8e76fa8a90162227c73f4dfe (patch)
tree5f95c8754164782f7a901e1db7d9e6d9cbf05561
parentafb6e31c9183eb482854f9d4237ba62100810e1c (diff)
downloadports-ddda6e3a47177bce8e76fa8a90162227c73f4dfe.tar.gz
ports-ddda6e3a47177bce8e76fa8a90162227c73f4dfe.zip
multimedia/mplayer: Update CFLAGS for clang16+
clang16+ will error on incompatible function pointer types. Workaround by adding -Wno-incompatible-function-pointer-types to clang CFLAGS.
-rw-r--r--multimedia/mplayer/Makefile.options2
1 files changed, 2 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index afbc1e060369..f7392d0b2314 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -41,6 +41,8 @@ DEFAULT_KERN_HZ=1024
.if ${CHOSEN_COMPILER_TYPE} == clang
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang-version
+# Turn off incompatible function pointer check for clang16+
+CFLAGS+= -Wno-incompatible-function-pointer-types
# Require 16 byte stack realignment on i386 to interface
# properly with hand crafted assembler code in ffmpeg
CFLAGS_i386+= -mstack-alignment=16 -mstackrealign