aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-19 18:18:59 +0000
committerRonald Klop <ronald@FreeBSD.org>2024-05-20 18:24:02 +0000
commitde08bd77dd68cafbcdebe32e1109a9ebf41019bf (patch)
tree240fe8946c9d993dad538ab19ee781f5006df244
parente0559b9574bb7c00de5b88e743646d3bf2bc26ef (diff)
downloadports-de08bd77dd68cafbcdebe32e1109a9ebf41019bf.tar.gz
ports-de08bd77dd68cafbcdebe32e1109a9ebf41019bf.zip
databases/mongodb70: Convert post-patch to EXTRACT_AFTER_ARGS
Saves I/O by not extracting bundled deps PR: 278769
-rw-r--r--databases/mongodb70/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/databases/mongodb70/Makefile b/databases/mongodb70/Makefile
index 378843c96075..3ce09d8e0126 100644
--- a/databases/mongodb70/Makefile
+++ b/databases/mongodb70/Makefile
@@ -1,7 +1,7 @@
PORTNAME= mongodb
DISTVERSIONPREFIX= r
DISTVERSION= 7.0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases net
PKGNAMESUFFIX= ${DISTVERSION:R:S/.//}
@@ -50,6 +50,15 @@ USE_RC_SUBR= mongod
SHEBANG_FILES= buildscripts/scons.py
python_OLD_CMD= @python_interpreter@
+EXTRACT_AFTER_ARGS= --exclude src/third_party/pcre2 \
+ --exclude src/third_party/snappy-* \
+ --exclude src/third_party/libstemmer_c \
+ --exclude src/third_party/unwind \
+ --exclude src/third_party/yaml-cpp \
+ --exclude src/third_party/zlib-* \
+ --exclude src/third_party/zstandard \
+ --no-same-owner --no-same-permissions
+
MAKE_ARGS= --allocator=system \
--cxx-std=20 \
--disable-warnings-as-errors \
@@ -115,14 +124,6 @@ MOZJS_ARCH= ${ARCH}
.endif
post-patch:
- ${RM} -rf ${WRKSRC}/src/third_party/pcre2
- ${RM} -rf ${WRKSRC}/src/third_party/snappy-*
- ${RM} -rf ${WRKSRC}/src/third_party/libstemmer_c
- ${RM} -rf ${WRKSRC}/src/third_party/unwind
- ${RM} -rf ${WRKSRC}/src/third_party/yaml-cpp
- ${RM} -rf ${WRKSRC}/src/third_party/zlib-*
- ${RM} -rf ${WRKSRC}/src/third_party/zstandard
-
# fix build with python-3.11
${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/util.py
${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/preprocessor.py