aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-05-27 19:01:35 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-05-27 19:32:16 +0000
commitde9b411d494c9fe6ff80e718851516ef7f0579ce (patch)
treea2acf4adab8e9ada1542e44e27d6feeb3347aa4b
parenta5f5201cef816e85f837b64fcdb95f61edcf61aa (diff)
downloadports-de9b411d494c9fe6ff80e718851516ef7f0579ce.tar.gz
ports-de9b411d494c9fe6ff80e718851516ef7f0579ce.zip
audio/moc: Disable FFmpeg plugin
Disable plugin as it no longer works as intended with FFmpeg 6 PR: 271338 Approved by: rzinkov@gmail.com (maintainer timeout, 2+ weeks)
-rw-r--r--audio/moc/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/audio/moc/Makefile b/audio/moc/Makefile
index 81a9732cbd18..0fb1a22f2b29 100644
--- a/audio/moc/Makefile
+++ b/audio/moc/Makefile
@@ -21,7 +21,9 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
LDFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
-OPTIONS_DEFINE= AAC CURL DEBUG FFMPEG FLAC JACK MODPLUG MP3 MUSEPACK RCC \
+CONFIGURE_ARGS= --without-ffmpeg
+
+OPTIONS_DEFINE= AAC CURL DEBUG FLAC JACK MODPLUG MP3 MUSEPACK RCC \
SAMPLERATE SIDPLAY2 SNDFILE SPEEX VORBIS WAVPACK
OPTIONS_DEFAULT= MP3 VORBIS FLAC CURL WAVPACK
CURL_DESC= curl support (Internet streams)
@@ -37,10 +39,6 @@ CURL_CONFIGURE_OFF= --without-curl
DEBUG_CONFIGURE_OFF= --enable-debug=no
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-FFMPEG_PLIST_FILES= lib/moc/decoder_plugins/libffmpeg_decoder.so
-FFMPEG_CONFIGURE_OFF= --without-ffmpeg
-
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
FLAC_PLIST_FILES= lib/moc/decoder_plugins/libflac_decoder.so
FLAC_CONFIGURE_OFF= --without-flac