aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaram Qashat <cyberbotx@cyberbotx.com>2024-06-13 08:44:10 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2024-06-13 09:42:08 +0000
commitdf65ca710c5f3a2ab709549607ea169015fc9bb4 (patch)
tree83167c130c59b81e0bedd81e56e083bd19864ed3
parent44bcfa5968484af91a02537d968d8dbe09eed0ce (diff)
downloadports-df65ca710c5f3a2ab709549607ea169015fc9bb4.tar.gz
ports-df65ca710c5f3a2ab709549607ea169015fc9bb4.zip
sysutils/u-boot: Allow building with different openssl
Add ssl to USES and export the needed variables so u-boot can be built with openssl from ports. PR: 279531
-rw-r--r--sysutils/u-boot-master/Makefile8
-rw-r--r--sysutils/u-boot-tools/Makefile2
2 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index bf867cdca70d..03e3df082d81 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -27,7 +27,8 @@ BUILD_DEPENDS+= ${COMPILER}:devel/${COMPILER}
BUILD_DEPENDS+= e2fsprogs-libuuid>=0:misc/e2fsprogs-libuuid \
gnutls>=0:security/gnutls
-USES= bison gmake python:build pkgconfig shebangfix tar:bz2
+USES= bison compiler:c11 gmake python:build pkgconfig shebangfix ssl \
+ tar:bz2
BINARY_ALIAS= bison=${LOCALBASE}/bin/bison dtc=${LOCALBASE}/bin/dtc sed=gsed python3=${PYTHON_CMD}
SHEBANG_FILES= tools/binman/binman
@@ -36,8 +37,9 @@ UBOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
INST= ${PREFIX}/${UBOOT_DIR}
DESCR?= ${.CURDIR}/pkg-descr
-MAKE_ENV+= V=1 CROSS_COMPILE=${CROSS_COMPILE} PYTHON=${PYTHON_CMD} CC=clang
-MAKE_ARGS+= ${ARCHFLAGS}
+MAKE_ENV+= CROSS_COMPILE=${CROSS_COMPILE} PYTHON=${PYTHON_CMD}
+MAKE_ARGS+= ${ARCHFLAGS} V=1 HOSTCFLAGS="${CFLAGS} -I${OPENSSLINC}" \
+ HOSTLDFLAGS="${LDFLAGS} -L${OPENSSLLIB}"
NO_ARCH= yes
diff --git a/sysutils/u-boot-tools/Makefile b/sysutils/u-boot-tools/Makefile
index c4debfd500c7..0bca20f9d0d7 100644
--- a/sysutils/u-boot-tools/Makefile
+++ b/sysutils/u-boot-tools/Makefile
@@ -22,6 +22,8 @@ MAKE_ARGS= ARCH=sandbox \
HOSTCC="${CC}" \
KBUILD_VERBOSE=1 \
NOSTDINC_FLAGS="" \
+ HOSTCFLAGS="${CFLAGS} -I${OPENSSLINC}" \
+ HOSTLDFLAGS="${LDFLAGS} -L${OPENSSLLIB}"
PLIST_FILES= bin/mkimage bin/mkenvimage bin/dumpimage bin/fit_info