aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2024-06-07 14:57:20 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2024-06-07 14:57:20 +0000
commitdfcddca68e5b97c1b8c3905e5c5ec35a88fd8372 (patch)
treec17b5ef497eb4b1151378557ba090462f5c12398
parent9bfd3e9878f1fc155a3e34f438309f664057ede2 (diff)
downloadports-dfcddca68e5b97c1b8c3905e5c5ec35a88fd8372.tar.gz
ports-dfcddca68e5b97c1b8c3905e5c5ec35a88fd8372.zip
misc/hashdb: fix build
add setuptools dependency to fix build. the error was: checking for python3.11... /usr/local/bin/python3.11 checking for a version of Python >= '2.1.0'... yes checking for the distutils Python package... no configure: error: cannot import Python module "distutils". Please check your Python installation. The error was: <string>:1: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives Reported by: pkg fallout Approved by: portmgr (blanket approval)
-rw-r--r--misc/hashdb/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/misc/hashdb/Makefile b/misc/hashdb/Makefile
index 15712e214493..a52d59269a02 100644
--- a/misc/hashdb/Makefile
+++ b/misc/hashdb/Makefile
@@ -12,7 +12,8 @@ WWW= https://github.com/NPS-DEEP/hashdb
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= swig:devel/swig
+BUILD_DEPENDS= swig:devel/swig \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR}
LIB_DEPENDS= libewf.so:devel/libewf
USES= autoreconf compiler:c++11-lang gmake libtool localbase:ldflags \