aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-04 06:48:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-04 06:48:34 +0000
commitdfe2319296033da86a2d3502594b4a4a912499d4 (patch)
tree01f970244f3543008600ac511a7a3f55a3ccb449
parentc689f104b72dbbddbbdbf4f475d116ca024a8493 (diff)
downloadports-dfe2319296033da86a2d3502594b4a4a912499d4.tar.gz
ports-dfe2319296033da86a2d3502594b4a4a912499d4.zip
devel/fbthrift: Update 2022.04.11.00 -> 2022.05.30.00
-rw-r--r--devel/fbthrift/Makefile5
-rw-r--r--devel/fbthrift/distinfo6
-rw-r--r--devel/fbthrift/pkg-plist113
3 files changed, 94 insertions, 30 deletions
diff --git a/devel/fbthrift/Makefile b/devel/fbthrift/Makefile
index c60c0a5e01b6..cf731acedf17 100644
--- a/devel/fbthrift/Makefile
+++ b/devel/fbthrift/Makefile
@@ -1,7 +1,6 @@
PORTNAME= fbthrift
DISTVERSIONPREFIX= v
-DISTVERSION= 2022.03.28.00
-PORTREVISION= 2
+DISTVERSION= 2022.05.30.00
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -27,8 +26,6 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libwangle.so:net/wangle \
libzstd.so:archivers/zstd
-BROKEN= error: implicit instantiation of undefined template 'std::basic_ofstream<char>'
-
USES= bison cmake compiler:c++17-lang ssl
USE_GITHUB= yes
GH_ACCOUNT= facebook
diff --git a/devel/fbthrift/distinfo b/devel/fbthrift/distinfo
index c8c66f054f64..c01d57452149 100644
--- a/devel/fbthrift/distinfo
+++ b/devel/fbthrift/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1648492053
-SHA256 (facebook-fbthrift-v2022.03.28.00_GH0.tar.gz) = 5c4e9215a475cd34665471cb26927d766a6656bafaa5876f62085c8f58154781
-SIZE (facebook-fbthrift-v2022.03.28.00_GH0.tar.gz) = 7395322
+TIMESTAMP = 1654315038
+SHA256 (facebook-fbthrift-v2022.05.30.00_GH0.tar.gz) = b9e384a72f9ac55dc47adc7d875420fb3f2fb571ed3597515a398a0100b75942
+SIZE (facebook-fbthrift-v2022.05.30.00_GH0.tar.gz) = 7794596
diff --git a/devel/fbthrift/pkg-plist b/devel/fbthrift/pkg-plist
index c4a29db7bd4c..b80fb527ad0c 100644
--- a/devel/fbthrift/pkg-plist
+++ b/devel/fbthrift/pkg-plist
@@ -105,7 +105,6 @@ include/thrift/lib/cpp2/FieldRefHash.h
include/thrift/lib/cpp2/FieldRefTraits.h
include/thrift/lib/cpp2/Flags.h
include/thrift/lib/cpp2/GeneratedCodeHelper.h
-include/thrift/lib/cpp2/GeneratedHeaderHelper.h
include/thrift/lib/cpp2/IndirectionWrapper.h
include/thrift/lib/cpp2/PluggableFunction.h
include/thrift/lib/cpp2/SerializationSwitch.h
@@ -115,7 +114,6 @@ include/thrift/lib/cpp2/TypeClass.h
include/thrift/lib/cpp2/async/AsyncClient.h
include/thrift/lib/cpp2/async/AsyncProcessor.h
include/thrift/lib/cpp2/async/AsyncProcessorHelper.h
-include/thrift/lib/cpp2/async/AsyncProcessorHolder.h
include/thrift/lib/cpp2/async/ChannelCallbacks.h
include/thrift/lib/cpp2/async/ClientBufferedStream.h
include/thrift/lib/cpp2/async/ClientChannel.h
@@ -125,6 +123,8 @@ include/thrift/lib/cpp2/async/Cpp2Channel.h
include/thrift/lib/cpp2/async/DuplexChannel.h
include/thrift/lib/cpp2/async/FramingHandler.h
include/thrift/lib/cpp2/async/FutureRequest.h
+include/thrift/lib/cpp2/async/GuardedRequestChannel-inl.h
+include/thrift/lib/cpp2/async/GuardedRequestChannel.h
include/thrift/lib/cpp2/async/HTTPClientChannel.h
include/thrift/lib/cpp2/async/HeaderChannel.h
include/thrift/lib/cpp2/async/HeaderChannelTrait.h
@@ -208,12 +208,17 @@ include/thrift/lib/cpp2/op/DeterministicAccumulator.h
include/thrift/lib/cpp2/op/Get.h
include/thrift/lib/cpp2/op/Hash.h
include/thrift/lib/cpp2/op/Patch.h
+include/thrift/lib/cpp2/op/Serializer.h
+include/thrift/lib/cpp2/op/Sha256Hasher.h
include/thrift/lib/cpp2/op/StdHasher.h
+include/thrift/lib/cpp2/op/StdSerializer.h
include/thrift/lib/cpp2/op/Testing.h
include/thrift/lib/cpp2/op/detail/BasePatch.h
include/thrift/lib/cpp2/op/detail/Clear.h
include/thrift/lib/cpp2/op/detail/Compare.h
+include/thrift/lib/cpp2/op/detail/ContainerPatch.h
include/thrift/lib/cpp2/op/detail/Create.h
+include/thrift/lib/cpp2/op/detail/Get.h
include/thrift/lib/cpp2/op/detail/Hash.h
include/thrift/lib/cpp2/op/detail/HashProtocol.h
include/thrift/lib/cpp2/op/detail/Patch.h
@@ -233,8 +238,6 @@ include/thrift/lib/cpp2/protocol/JSONProtocol.h
include/thrift/lib/cpp2/protocol/JSONProtocolCommon-inl.h
include/thrift/lib/cpp2/protocol/JSONProtocolCommon.h
include/thrift/lib/cpp2/protocol/LazyDeserializationFlags.h
-include/thrift/lib/cpp2/protocol/NimbleProtocol-inl.h
-include/thrift/lib/cpp2/protocol/NimbleProtocol.h
include/thrift/lib/cpp2/protocol/Protocol.h
include/thrift/lib/cpp2/protocol/ProtocolReaderStructReadState.h
include/thrift/lib/cpp2/protocol/ProtocolReaderWireTypeInfo.h
@@ -250,17 +253,6 @@ include/thrift/lib/cpp2/protocol/VirtualProtocol.h
include/thrift/lib/cpp2/protocol/detail/ReservedId.h
include/thrift/lib/cpp2/protocol/detail/index.h
include/thrift/lib/cpp2/protocol/detail/protocol_methods.h
-include/thrift/lib/cpp2/protocol/nimble/BufferingNimbleDecoder.h
-include/thrift/lib/cpp2/protocol/nimble/BufferingNimbleEncoder.h
-include/thrift/lib/cpp2/protocol/nimble/ChunkRepr.h
-include/thrift/lib/cpp2/protocol/nimble/ControlBitHelpers.h
-include/thrift/lib/cpp2/protocol/nimble/DecodeNimbleBlock.h
-include/thrift/lib/cpp2/protocol/nimble/Decoder.h
-include/thrift/lib/cpp2/protocol/nimble/EncodeNimbleBlock.h
-include/thrift/lib/cpp2/protocol/nimble/Encoder.h
-include/thrift/lib/cpp2/protocol/nimble/NimbleTypes.h
-include/thrift/lib/cpp2/protocol/nimble/Vectorization.h
-include/thrift/lib/cpp2/protocol/nimble/test/BufferingEncoderDecoderBenchmarksCommon.h
include/thrift/lib/cpp2/reflection/debug.h
include/thrift/lib/cpp2/reflection/demo/json_print.h
include/thrift/lib/cpp2/reflection/diff.h
@@ -306,6 +298,7 @@ include/thrift/lib/cpp2/server/ControlServerInterface.h
include/thrift/lib/cpp2/server/Cpp2ConnContext.h
include/thrift/lib/cpp2/server/Cpp2Connection.h
include/thrift/lib/cpp2/server/Cpp2Worker.h
+include/thrift/lib/cpp2/server/ExecutorToThreadManagerAdaptor.h
include/thrift/lib/cpp2/server/IOWorkerContext.h
include/thrift/lib/cpp2/server/LoggingEvent.h
include/thrift/lib/cpp2/server/LoggingEventHelper.h
@@ -315,6 +308,7 @@ include/thrift/lib/cpp2/server/MonitoringServerInterface.h
include/thrift/lib/cpp2/server/ParallelConcurrencyController.h
include/thrift/lib/cpp2/server/PolledServiceHealth.h
include/thrift/lib/cpp2/server/PreprocessParams.h
+include/thrift/lib/cpp2/server/ReactiveToggle.h
include/thrift/lib/cpp2/server/RequestDebugLog.h
include/thrift/lib/cpp2/server/RequestPileBase.h
include/thrift/lib/cpp2/server/RequestPileInterface.h
@@ -328,6 +322,7 @@ include/thrift/lib/cpp2/server/ServerFlags.h
include/thrift/lib/cpp2/server/ServerInstrumentation.h
include/thrift/lib/cpp2/server/ServiceHealthPoller.h
include/thrift/lib/cpp2/server/StatusServerInterface.h
+include/thrift/lib/cpp2/server/ThreadManagerLoggingWrapper.h
include/thrift/lib/cpp2/server/ThriftProcessor.h
include/thrift/lib/cpp2/server/ThriftServer.h
include/thrift/lib/cpp2/server/TransportRoutingHandler.h
@@ -336,8 +331,8 @@ include/thrift/lib/cpp2/server/WeightedRequestPileQueue.h
include/thrift/lib/cpp2/server/peeking/PeekingManager.h
include/thrift/lib/cpp2/server/peeking/TLSHelper.h
include/thrift/lib/cpp2/test/IndirectionWrapperTest.h
-include/thrift/lib/cpp2/test/Matcher.h
include/thrift/lib/cpp2/test/Matcher-inl.h
+include/thrift/lib/cpp2/test/Matcher.h
include/thrift/lib/cpp2/test/MockCpp2ConnContext.h
include/thrift/lib/cpp2/test/ProtoBufStructs-inl.h
include/thrift/lib/cpp2/test/Structs.h
@@ -407,24 +402,31 @@ include/thrift/lib/cpp2/transport/rocket/test/util/TestUtil.h
include/thrift/lib/cpp2/transport/rocket/test/util/VersionServicesMock.h
include/thrift/lib/cpp2/transport/util/ConnectionManager.h
include/thrift/lib/cpp2/transport/util/ConnectionThread.h
+include/thrift/lib/cpp2/type/Any.h
include/thrift/lib/cpp2/type/AnyRef.h
-include/thrift/lib/cpp2/type/AnyType.h
include/thrift/lib/cpp2/type/AnyValue.h
include/thrift/lib/cpp2/type/BaseType.h
include/thrift/lib/cpp2/type/Field.h
include/thrift/lib/cpp2/type/Name.h
+include/thrift/lib/cpp2/type/NativeType.h
+include/thrift/lib/cpp2/type/Protocol.h
include/thrift/lib/cpp2/type/Tag.h
include/thrift/lib/cpp2/type/Testing.h
include/thrift/lib/cpp2/type/ThriftType.h
include/thrift/lib/cpp2/type/Traits.h
+include/thrift/lib/cpp2/type/Type.h
+include/thrift/lib/cpp2/type/TypeRegistry.h
include/thrift/lib/cpp2/type/UniversalHashAlgorithm.h
include/thrift/lib/cpp2/type/UniversalName.h
include/thrift/lib/cpp2/type/detail/AnyData.h
include/thrift/lib/cpp2/type/detail/AnyType.h
include/thrift/lib/cpp2/type/detail/Field.h
include/thrift/lib/cpp2/type/detail/Name.h
-include/thrift/lib/cpp2/type/detail/Traits.h
+include/thrift/lib/cpp2/type/detail/NativeType.h
include/thrift/lib/cpp2/type/detail/ThriftTypeInfo.h
+include/thrift/lib/cpp2/type/detail/Traits.h
+include/thrift/lib/cpp2/type/detail/TypeRegistry.h
+include/thrift/lib/cpp2/type/detail/Wrap.h
include/thrift/lib/cpp2/util/BucketedRate.h
include/thrift/lib/cpp2/util/Checksum.h
include/thrift/lib/cpp2/util/DebugString.h
@@ -460,13 +462,15 @@ include/thrift/lib/py3/test/is_overload/func.h
include/thrift/lib/py3/types.h
include/thrift/lib/thrift/RpcMetadata_extra.h
include/thrift/lib/thrift/SerializableDynamic.h
-include/thrift/lib/thrift/gen-cpp2/RocketUpgrade.h
+include/thrift/lib/thrift/gen-cpp2/RocketUpgrade.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade.tcc
include/thrift/lib/thrift/gen-cpp2/RocketUpgradeAsyncClient.h
+include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_clients.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_constants.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_custom_protocol.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_data.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_handlers.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_metadata.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_types.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_types.tcc
@@ -474,9 +478,11 @@ include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_types_custom_protocol.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_visit_by_thrift_field_metadata.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_visit_union.h
include/thrift/lib/thrift/gen-cpp2/RocketUpgrade_visitation.h
+include/thrift/lib/thrift/gen-cpp2/RpcMetadata_clients.h
include/thrift/lib/thrift/gen-cpp2/RpcMetadata_constants.h
include/thrift/lib/thrift/gen-cpp2/RpcMetadata_data.h
include/thrift/lib/thrift/gen-cpp2/RpcMetadata_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/RpcMetadata_handlers.h
include/thrift/lib/thrift/gen-cpp2/RpcMetadata_metadata.h
include/thrift/lib/thrift/gen-cpp2/RpcMetadata_types.h
include/thrift/lib/thrift/gen-cpp2/RpcMetadata_types.tcc
@@ -488,9 +494,23 @@ include/thrift/lib/thrift/gen-cpp2/ThriftMetadataService.h
include/thrift/lib/thrift/gen-cpp2/ThriftMetadataService.tcc
include/thrift/lib/thrift/gen-cpp2/ThriftMetadataServiceAsyncClient.h
include/thrift/lib/thrift/gen-cpp2/ThriftMetadataService_custom_protocol.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_clients.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_constants.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_data.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_handlers.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_metadata.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_types.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_types.tcc
+include/thrift/lib/thrift/gen-cpp2/any_rep_types_custom_protocol.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_visit_by_thrift_field_metadata.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_visit_union.h
+include/thrift/lib/thrift/gen-cpp2/any_rep_visitation.h
+include/thrift/lib/thrift/gen-cpp2/frozen_clients.h
include/thrift/lib/thrift/gen-cpp2/frozen_constants.h
include/thrift/lib/thrift/gen-cpp2/frozen_data.h
include/thrift/lib/thrift/gen-cpp2/frozen_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/frozen_handlers.h
include/thrift/lib/thrift/gen-cpp2/frozen_metadata.h
include/thrift/lib/thrift/gen-cpp2/frozen_types.h
include/thrift/lib/thrift/gen-cpp2/frozen_types.tcc
@@ -498,9 +518,23 @@ include/thrift/lib/thrift/gen-cpp2/frozen_types_custom_protocol.h
include/thrift/lib/thrift/gen-cpp2/frozen_visit_by_thrift_field_metadata.h
include/thrift/lib/thrift/gen-cpp2/frozen_visit_union.h
include/thrift/lib/thrift/gen-cpp2/frozen_visitation.h
+include/thrift/lib/thrift/gen-cpp2/id_clients.h
+include/thrift/lib/thrift/gen-cpp2/id_constants.h
+include/thrift/lib/thrift/gen-cpp2/id_data.h
+include/thrift/lib/thrift/gen-cpp2/id_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/id_handlers.h
+include/thrift/lib/thrift/gen-cpp2/id_metadata.h
+include/thrift/lib/thrift/gen-cpp2/id_types.h
+include/thrift/lib/thrift/gen-cpp2/id_types.tcc
+include/thrift/lib/thrift/gen-cpp2/id_types_custom_protocol.h
+include/thrift/lib/thrift/gen-cpp2/id_visit_by_thrift_field_metadata.h
+include/thrift/lib/thrift/gen-cpp2/id_visit_union.h
+include/thrift/lib/thrift/gen-cpp2/id_visitation.h
+include/thrift/lib/thrift/gen-cpp2/metadata_clients.h
include/thrift/lib/thrift/gen-cpp2/metadata_constants.h
include/thrift/lib/thrift/gen-cpp2/metadata_data.h
include/thrift/lib/thrift/gen-cpp2/metadata_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/metadata_handlers.h
include/thrift/lib/thrift/gen-cpp2/metadata_metadata.h
include/thrift/lib/thrift/gen-cpp2/metadata_types.h
include/thrift/lib/thrift/gen-cpp2/metadata_types.tcc
@@ -508,9 +542,11 @@ include/thrift/lib/thrift/gen-cpp2/metadata_types_custom_protocol.h
include/thrift/lib/thrift/gen-cpp2/metadata_visit_by_thrift_field_metadata.h
include/thrift/lib/thrift/gen-cpp2/metadata_visit_union.h
include/thrift/lib/thrift/gen-cpp2/metadata_visitation.h
+include/thrift/lib/thrift/gen-cpp2/reflection_clients.h
include/thrift/lib/thrift/gen-cpp2/reflection_constants.h
include/thrift/lib/thrift/gen-cpp2/reflection_data.h
include/thrift/lib/thrift/gen-cpp2/reflection_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/reflection_handlers.h
include/thrift/lib/thrift/gen-cpp2/reflection_metadata.h
include/thrift/lib/thrift/gen-cpp2/reflection_types.h
include/thrift/lib/thrift/gen-cpp2/reflection_types.tcc
@@ -518,10 +554,36 @@ include/thrift/lib/thrift/gen-cpp2/reflection_types_custom_protocol.h
include/thrift/lib/thrift/gen-cpp2/reflection_visit_by_thrift_field_metadata.h
include/thrift/lib/thrift/gen-cpp2/reflection_visit_union.h
include/thrift/lib/thrift/gen-cpp2/reflection_visitation.h
+include/thrift/lib/thrift/gen-cpp2/standard_clients.h
+include/thrift/lib/thrift/gen-cpp2/standard_constants.h
+include/thrift/lib/thrift/gen-cpp2/standard_data.h
+include/thrift/lib/thrift/gen-cpp2/standard_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/standard_handlers.h
+include/thrift/lib/thrift/gen-cpp2/standard_metadata.h
+include/thrift/lib/thrift/gen-cpp2/standard_types.h
+include/thrift/lib/thrift/gen-cpp2/standard_types.tcc
+include/thrift/lib/thrift/gen-cpp2/standard_types_custom_protocol.h
+include/thrift/lib/thrift/gen-cpp2/standard_visit_by_thrift_field_metadata.h
+include/thrift/lib/thrift/gen-cpp2/standard_visit_union.h
+include/thrift/lib/thrift/gen-cpp2/standard_visitation.h
+include/thrift/lib/thrift/gen-cpp2/type_clients.h
include/thrift/lib/thrift/gen-cpp2/type_constants.h
include/thrift/lib/thrift/gen-cpp2/type_data.h
include/thrift/lib/thrift/gen-cpp2/type_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/type_handlers.h
include/thrift/lib/thrift/gen-cpp2/type_metadata.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_clients.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_constants.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_data.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_for_each_field.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_handlers.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_metadata.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_types.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_types.tcc
+include/thrift/lib/thrift/gen-cpp2/type_rep_types_custom_protocol.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_visit_by_thrift_field_metadata.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_visit_union.h
+include/thrift/lib/thrift/gen-cpp2/type_rep_visitation.h
include/thrift/lib/thrift/gen-cpp2/type_types.h
include/thrift/lib/thrift/gen-cpp2/type_types.tcc
include/thrift/lib/thrift/gen-cpp2/type_types_custom_protocol.h
@@ -533,20 +595,23 @@ lib/cmake/fbthrift/FBThriftTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/fbthrift/FBThriftTargets.cmake
lib/libasync.so
lib/libasync.so.1.0.0
+lib/libcompiler.so
+lib/libcompiler.so.1.0.0
lib/libcompiler_ast.so
lib/libcompiler_ast.so.1.0.0
lib/libcompiler_base.so
lib/libcompiler_base.so.1.0.0
-lib/libcompiler_lib.so
-lib/libcompiler_lib.so.1.0.0
lib/libconcurrency.so
lib/libconcurrency.so.1.0.0
-lib/libmustache_lib.so
-lib/libmustache_lib.so.1.0.0
+lib/libmustache.so
+lib/libmustache.so.1.0.0
lib/librpcmetadata.so
lib/librpcmetadata.so.1.0.0
lib/libthrift-core.so
lib/libthrift-core.so.1.0.0
+lib/libthriftannotation.so
+lib/libthriftannotation.so.1.0.0
+lib/libthriftanyrep.so
lib/libthriftcpp2.so
lib/libthriftcpp2.so.1.0.0
lib/libthriftfrozen2.so
@@ -557,5 +622,7 @@ lib/libthriftprotocol.so
lib/libthriftprotocol.so.1.0.0
lib/libthrifttype.so
lib/libthrifttype.so.1.0.0
+lib/libthrifttyperep.so
+lib/libthrifttyperep.so.1.0.0
lib/libtransport.so
lib/libtransport.so.1.0.0