aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2023-05-07 08:50:15 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2023-05-07 08:50:15 +0000
commite00ade28ed48734e8678019e215fdadd40d8a512 (patch)
treef549e65c974a82382ba47d2eea77de21f968a2c4
parent2da279ebe6bdf2ca20eca737e682f9bfdaf8e27d (diff)
downloadports-e00ade28ed48734e8678019e215fdadd40d8a512.tar.gz
ports-e00ade28ed48734e8678019e215fdadd40d8a512.zip
editors/vscode: update to 1.78.0
Changelog: https://code.visualstudio.com/updates/v1_78 Reported by: GitHub (watch releases)
-rw-r--r--editors/vscode/Makefile66
-rw-r--r--editors/vscode/distinfo14
-rw-r--r--editors/vscode/files/node_modules/patch-extensions_node__modules__at_parcel_watcher_binding.gyp23
-rw-r--r--editors/vscode/files/node_modules/patch-node__modules__at_parcel_watcher_binding.gyp23
-rw-r--r--editors/vscode/files/node_modules/patch-node__modules_node-pty_src_unix_pty.cc11
-rw-r--r--editors/vscode/files/node_modules/patch-remote_node__modules__at_parcel_watcher_binding.gyp23
-rw-r--r--editors/vscode/files/node_modules/patch-remote_node__modules_node-pty_src_unix_pty.cc11
-rw-r--r--editors/vscode/files/patch-build_gulpfile.vscode.js11
-rw-r--r--editors/vscode/files/patch-build_lib_layersChecker.ts4
-rw-r--r--editors/vscode/files/patch-build_npm_postinstall.js10
-rw-r--r--editors/vscode/files/patch-product.json4
-rw-r--r--editors/vscode/files/patch-src_main.js4
-rw-r--r--editors/vscode/files/patch-src_vs_base_node_ps.ts6
-rw-r--r--editors/vscode/files/patch-src_vs_code_electron-main_app.ts4
-rw-r--r--editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts4
-rw-r--r--editors/vscode/pkg-plist23
16 files changed, 163 insertions, 78 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index b97efaeea3c0..6b3610b781ed 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -1,6 +1,5 @@
PORTNAME= vscode
-DISTVERSION= 1.77.3
-PORTREVISION= 2
+DISTVERSION= 1.78.0
CATEGORIES= editors
MASTER_SITES= https://github.com/tagattie/FreeBSD-VSCode/releases/download/${DISTVERSION}/:yarn_cache
DISTFILES= yarn-offline-cache-${DISTVERSION}${EXTRACT_SUFX}:yarn_cache \
@@ -24,10 +23,11 @@ BUILD_DEPENDS= zip:archivers/zip \
LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-core \
libatspi.so:accessibility/at-spi2-core \
libsnappy.so:archivers/snappy \
- libasound.so:audio/alsa-lib \
libFLAC.so:audio/flac \
libopus.so:audio/opus \
+ libsndio.so:audio/sndio \
libdbus-1.so:devel/dbus \
+ libicuuc.so:devel/icu \
libevent.so:devel/libevent \
libinotify.so:devel/libinotify \
libnotify.so:devel/libnotify \
@@ -63,7 +63,7 @@ USES= desktop-file-utils gl gmake gnome iconv:wchar_t jpeg \
USE_GITHUB= yes
GH_ACCOUNT= microsoft
-SOURCE_COMMIT_HASH= 704ed70d4fd1c6bd6342c436f1ede30d1cff4710
+SOURCE_COMMIT_HASH= 252e5463d60e63238250799aef7375787f68b4ee
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -77,10 +77,6 @@ USE_LDCONFIG= ${DATADIR}
# Keep NODE_VER in sync with www/node16 DISTVERSION
NODE_VER= 16.20.0
NODE_VER_MAJOR= ${NODE_VER:C/\..*$//}
-# See ${WRKSRC}/build/package.json for ESBUILD_VER_BUILD
-ESBUILD_VER_BUILD= 0.15.5
-# See ${WRKSRC}/extensions/package.json for ESBUILD_VER_EXTENSIONS
-ESBUILD_VER_EXTENSIONS= 0.15.14
SHEBANG_REGEX= ./(extensions|resources|scripts|src)/.*\.sh$$
PATHFIX_FILES= src/vs/workbench/contrib/debug/node/terminals.ts
@@ -102,7 +98,7 @@ OPTIONS_DEFINE= REH
OPTIONS_DEFAULT=# none
REH_DESC= Build remote extension host
-ELECTRON_DIR= ${.CURDIR}/../../devel/electron19
+ELECTRON_DIR= ${.CURDIR}/../../devel/electron22
.include "${ELECTRON_DIR}/Makefile.version"
ELECTRON_DOWNLOAD_URL= https://github.com/electron/electron/releases/download/v${ELECTRON_VER}
@@ -161,18 +157,42 @@ post-patch:
-exec ${SED} -i '' -e "s|/usr/bin/pgrep|/bin/pgrep|g" \
-e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash|' {} ';')
-pre-build:
- # # install node_modules without executing post-installation scripts
- # cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- # yarn --frozen-lockfile --ignore-scripts --offline
- # # copy rg binary files to vscode-ripgrep module directory
- # ${MKDIR} ${WRKSRC}/node_modules/vscode-ripgrep/bin
- # ${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/node_modules/vscode-ripgrep/bin
- # ${MKDIR} ${WRKSRC}/remote/node_modules/vscode-ripgrep/bin
- # ${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/remote/node_modules/vscode-ripgrep/bin
- # install node_modules
+pre-build: install-node-modules patch-node-modules rebuild-node-modules copy-rg-binary
+install-node-modules:
+ # install node_modules without executing post-installation scripts
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- yarn --frozen-lockfile --offline
+ yarn --frozen-lockfile --ignore-scripts --offline
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ yarn postinstall --frozen-lockfile --ignore-scripts --offline
+patch-node-modules:
+ # patch install node modules before building native node modules
+ for p in ${PATCHDIR}/node_modules/patch-*; do \
+ ${PATCH} -p0 -s -d ${WRKSRC} < $${p}; \
+ done
+rebuild-node-modules:
+ # rebuild native node modules for electron
+ for subdir in `${FIND} ${WRKSRC}/node_modules -type f -name binding.gyp -exec ${DIRNAME} {} ';'`; do \
+ cd $${subdir} && \
+ ${SETENV} ${MAKE_ENV} \
+ npm_config_runtime=electron \
+ npm_config_target=${ELECTRON_VER} \
+ npm_config_nodedir=${LOCALBASE}/share/electron${ELECTRON_VER_MAJOR}/node_headers \
+ node ${LOCALBASE}/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js rebuild; \
+ done
+ cd ${WRKSRC}/extensions && \
+ ${SETENV} ${MAKE_ENV} \
+ npm_config_runtime=electron \
+ npm_config_target=${ELECTRON_VER} \
+ npm_config_nodedir=${LOCALBASE}/share/electron${ELECTRON_VER_MAJOR}/node_headers \
+ npm rebuild --verbose
+ # rebuild native node modules for node
+.for dir in build remote
+ cd ${WRKSRC}/${dir} && \
+ ${SETENV} ${MAKE_ENV} \
+ npm_config_nodedir=${LOCALBASE} \
+ npm rebuild --verbose
+.endfor
+copy-rg-binary:
# copy rg binary files to vscode-ripgrep module directory
${MKDIR} ${WRKSRC}/node_modules/@vscode/ripgrep/bin
${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/node_modules/@vscode/ripgrep/bin
@@ -228,8 +248,8 @@ do-install:
cd ${WRKDIR}/VSCode-linux-x64 && \
${TAR} -cf - . | ${TAR} -xf - -C ${STAGEDIR}${DATADIR}
cd ${STAGEDIR}${DATADIR}/resources/app/node_modules.asar.unpacked && \
- ${FIND} . -type f -name '*.node' -exec ${STRIP_CMD} {} ';'
- ${STRIP_CMD} ${STAGEDIR}${DATADIR}/resources/app/node_modules.asar.unpacked/node-pty/build/Release/spawn-helper
+ ${FIND} . -type f -exec ${FILE} {} ';' | \
+ ${GREP} 'ELF.*FreeBSD' | ${AWK} -F ':' '{print $$1}' | ${XARGS} ${STRIP_CMD}
.for f in chromedriver mksnapshot v8_context_snapshot_generator
${RM} ${STAGEDIR}${DATADIR}/${f}
.endfor
@@ -260,7 +280,7 @@ make-yarn-cache:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
yarn --frozen-lockfile --ignore-scripts
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- yarn postinstall --frozen-lockfile
+ yarn postinstall --frozen-lockfile --ignore-scripts
cd ${WRKDIR} && ${TAR} -czf \
yarn-offline-cache-${DISTVERSION}${EXTRACT_SUFX} yarn-offline-cache
diff --git a/editors/vscode/distinfo b/editors/vscode/distinfo
index 8295c0ca02ad..2c3040d3c137 100644
--- a/editors/vscode/distinfo
+++ b/editors/vscode/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1681369555
-SHA256 (vscode/yarn-offline-cache-1.77.3.tar.gz) = 45068a1b0b89caff5942b10cdc53c28624a85a5655edcbd0795da08f658b5f2a
-SIZE (vscode/yarn-offline-cache-1.77.3.tar.gz) = 398864023
-SHA256 (vscode/vscode-marketplace-exts-1.77.3.tar.gz) = 8363709d51f9202c9d6ed9e3a084054e2000fa7097b3cbb99218bb800c084c82
-SIZE (vscode/vscode-marketplace-exts-1.77.3.tar.gz) = 1752206
-SHA256 (vscode/microsoft-vscode-1.77.3_GH0.tar.gz) = 3d1c487667fe543c860254c512b9ab4ade4149286c43819b6aa1cdb729a8d781
-SIZE (vscode/microsoft-vscode-1.77.3_GH0.tar.gz) = 16600485
+TIMESTAMP = 1683356189
+SHA256 (vscode/yarn-offline-cache-1.78.0.tar.gz) = c4a219c5af4d0694440a2c955193f61540091808068a4b094b826191c5588aab
+SIZE (vscode/yarn-offline-cache-1.78.0.tar.gz) = 334909091
+SHA256 (vscode/vscode-marketplace-exts-1.78.0.tar.gz) = c47419d89fa7a5b45e4d453eb65fbbd98912edac35da22550ff934f24a36f1a8
+SIZE (vscode/vscode-marketplace-exts-1.78.0.tar.gz) = 1722299
+SHA256 (vscode/microsoft-vscode-1.78.0_GH0.tar.gz) = 7ce0a9ae87c1cb3450d758f2838f53825c471bc8a536e94968b442da0e2f7634
+SIZE (vscode/microsoft-vscode-1.78.0_GH0.tar.gz) = 16370919
diff --git a/editors/vscode/files/node_modules/patch-extensions_node__modules__at_parcel_watcher_binding.gyp b/editors/vscode/files/node_modules/patch-extensions_node__modules__at_parcel_watcher_binding.gyp
new file mode 100644
index 000000000000..6f5b9d8862d7
--- /dev/null
+++ b/editors/vscode/files/node_modules/patch-extensions_node__modules__at_parcel_watcher_binding.gyp
@@ -0,0 +1,23 @@
+--- extensions/node_modules/@parcel/watcher/binding.gyp.orig 2023-05-05 08:51:33 UTC
++++ extensions/node_modules/@parcel/watcher/binding.gyp
+@@ -34,7 +34,7 @@
+ "ARCHS": ["arm64"]
+ }
+ }],
+- ['OS=="linux"', {
++ ['OS=="linux" or OS=="freebsd"', {
+ "sources": [
+ "src/watchman/BSER.cc",
+ "src/watchman/WatchmanBackend.cc",
+@@ -46,6 +46,11 @@
+ "WATCHMAN",
+ "INOTIFY",
+ "BRUTE_FORCE"
++ ]
++ }],
++ ['OS=="freebsd"', {
++ "libraries": [
++ "-linotify"
+ ]
+ }],
+ ['OS=="win"', {
diff --git a/editors/vscode/files/node_modules/patch-node__modules__at_parcel_watcher_binding.gyp b/editors/vscode/files/node_modules/patch-node__modules__at_parcel_watcher_binding.gyp
new file mode 100644
index 000000000000..84da531dfd68
--- /dev/null
+++ b/editors/vscode/files/node_modules/patch-node__modules__at_parcel_watcher_binding.gyp
@@ -0,0 +1,23 @@
+--- node_modules/@parcel/watcher/binding.gyp.orig 2023-05-05 08:53:32 UTC
++++ node_modules/@parcel/watcher/binding.gyp
+@@ -34,7 +34,7 @@
+ "ARCHS": ["arm64"]
+ }
+ }],
+- ['OS=="linux"', {
++ ['OS=="linux" or OS=="freebsd"', {
+ "sources": [
+ "src/watchman/BSER.cc",
+ "src/watchman/WatchmanBackend.cc",
+@@ -46,6 +46,11 @@
+ "WATCHMAN",
+ "INOTIFY",
+ "BRUTE_FORCE"
++ ]
++ }],
++ ['OS=="freebsd"', {
++ "libraries": [
++ "-linotify"
+ ]
+ }],
+ ['OS=="win"', {
diff --git a/editors/vscode/files/node_modules/patch-node__modules_node-pty_src_unix_pty.cc b/editors/vscode/files/node_modules/patch-node__modules_node-pty_src_unix_pty.cc
new file mode 100644
index 000000000000..c037e9ed555b
--- /dev/null
+++ b/editors/vscode/files/node_modules/patch-node__modules_node-pty_src_unix_pty.cc
@@ -0,0 +1,11 @@
+--- node_modules/node-pty/src/unix/pty.cc.orig 2023-05-05 07:40:15 UTC
++++ node_modules/node-pty/src/unix/pty.cc
+@@ -36,6 +36,8 @@
+ #include <pty.h>
+ #elif defined(__APPLE__)
+ #include <util.h>
++#elif defined(__FreeBSD__)
++#include <libutil.h>
+ #endif
+
+ /* Some platforms name VWERASE and VDISCARD differently */
diff --git a/editors/vscode/files/node_modules/patch-remote_node__modules__at_parcel_watcher_binding.gyp b/editors/vscode/files/node_modules/patch-remote_node__modules__at_parcel_watcher_binding.gyp
new file mode 100644
index 000000000000..d3079d24a61f
--- /dev/null
+++ b/editors/vscode/files/node_modules/patch-remote_node__modules__at_parcel_watcher_binding.gyp
@@ -0,0 +1,23 @@
+--- remote/node_modules/@parcel/watcher/binding.gyp.orig 2023-05-05 08:51:33 UTC
++++ remote/node_modules/@parcel/watcher/binding.gyp
+@@ -34,7 +34,7 @@
+ "ARCHS": ["arm64"]
+ }
+ }],
+- ['OS=="linux"', {
++ ['OS=="linux" or OS=="freebsd"', {
+ "sources": [
+ "src/watchman/BSER.cc",
+ "src/watchman/WatchmanBackend.cc",
+@@ -46,6 +46,11 @@
+ "WATCHMAN",
+ "INOTIFY",
+ "BRUTE_FORCE"
++ ]
++ }],
++ ['OS=="freebsd"', {
++ "libraries": [
++ "-linotify"
+ ]
+ }],
+ ['OS=="win"', {
diff --git a/editors/vscode/files/node_modules/patch-remote_node__modules_node-pty_src_unix_pty.cc b/editors/vscode/files/node_modules/patch-remote_node__modules_node-pty_src_unix_pty.cc
new file mode 100644
index 000000000000..443e5ac03a3d
--- /dev/null
+++ b/editors/vscode/files/node_modules/patch-remote_node__modules_node-pty_src_unix_pty.cc
@@ -0,0 +1,11 @@
+--- remote/node_modules/node-pty/src/unix/pty.cc.orig 2023-05-05 07:41:23 UTC
++++ remote/node_modules/node-pty/src/unix/pty.cc
+@@ -36,6 +36,8 @@
+ #include <pty.h>
+ #elif defined(__APPLE__)
+ #include <util.h>
++#elif defined(__FreeBSD__)
++#include <libutil.h>
+ #endif
+
+ /* Some platforms name VWERASE and VDISCARD differently */
diff --git a/editors/vscode/files/patch-build_gulpfile.vscode.js b/editors/vscode/files/patch-build_gulpfile.vscode.js
deleted file mode 100644
index 580369e40129..000000000000
--- a/editors/vscode/files/patch-build_gulpfile.vscode.js
+++ /dev/null
@@ -1,11 +0,0 @@
---- build/gulpfile.vscode.js.orig 2023-02-28 11:07:20 UTC
-+++ build/gulpfile.vscode.js
-@@ -336,7 +336,7 @@ function packageTask(platform, arch, sourceFolderName,
- .pipe(util.skipDirectories())
- .pipe(util.fixWin32DirectoryPermissions())
- .pipe(filter(['**', '!**/.github/**'], { dot: true })) // https://github.com/microsoft/vscode/issues/116523
-- .pipe(electron({ ...config, platform, arch: arch === 'armhf' ? 'arm' : arch, ffmpegChromium: true }))
-+ .pipe(electron({ ...config, platform, arch: arch === 'armhf' ? 'arm' : arch, ffmpegChromium: false }))
- .pipe(filter(['**', '!LICENSE', '!LICENSES.chromium.html', '!version'], { dot: true }));
-
- if (platform === 'linux') {
diff --git a/editors/vscode/files/patch-build_lib_layersChecker.ts b/editors/vscode/files/patch-build_lib_layersChecker.ts
index ee1d9bdf3597..c5e8462ad8fb 100644
--- a/editors/vscode/files/patch-build_lib_layersChecker.ts
+++ b/editors/vscode/files/patch-build_lib_layersChecker.ts
@@ -1,6 +1,6 @@
---- build/lib/layersChecker.ts.orig 2023-03-29 09:14:46 UTC
+--- build/lib/layersChecker.ts.orig 2023-05-03 19:37:04 UTC
+++ build/lib/layersChecker.ts
-@@ -317,7 +317,7 @@ function checkFile(program: ts.Program, sourceFile: ts
+@@ -305,7 +305,7 @@ function checkFile(program: ts.Program, sourceFile: ts
function createProgram(tsconfigPath: string): ts.Program {
const tsConfig = ts.readConfigFile(tsconfigPath, ts.sys.readFile);
diff --git a/editors/vscode/files/patch-build_npm_postinstall.js b/editors/vscode/files/patch-build_npm_postinstall.js
index 81e9a96dc775..fc909031ffd7 100644
--- a/editors/vscode/files/patch-build_npm_postinstall.js
+++ b/editors/vscode/files/patch-build_npm_postinstall.js
@@ -1,11 +1,13 @@
---- build/npm/postinstall.js.orig 2023-04-04 22:49:54 UTC
+--- build/npm/postinstall.js.orig 2023-05-03 19:37:04 UTC
+++ build/npm/postinstall.js
-@@ -20,7 +20,13 @@ function yarnInstall(location, opts) {
+@@ -41,8 +41,14 @@ function yarnInstall(dir, opts) {
const raw = process.env['npm_config_argv'] || '{}';
const argv = JSON.parse(raw);
const original = argv.original || [];
- const args = original.filter(arg => arg === '--ignore-optional' || arg === '--frozen-lockfile' || arg === '--check-files');
-+ const passargs = ['--ignore-optional', '--frozen-lockfile', '--check-files', '--offline', '--no-progress', '--verbose'];
+-
++ const passargs = ['--ignore-optional', '--frozen-lockfile', '--check-files',
++ '--ignore-scripts', '--offline', '--no-progress', '--verbose'];
+ const args = original.filter(arg => passargs.includes(arg));
+ if (opts.cwd === 'remote') {
+ args.push('--use-yarnrc=' + process.env.PWD + '/' + opts.cwd + '/.yarnrc');
@@ -15,7 +17,7 @@
if (opts.ignoreEngines) {
args.push('--ignore-engines');
delete opts.ignoreEngines;
-@@ -73,5 +79,5 @@ for (let dir of dirs) {
+@@ -108,5 +114,5 @@ for (let dir of dirs) {
yarnInstall(dir, opts);
}
diff --git a/editors/vscode/files/patch-product.json b/editors/vscode/files/patch-product.json
index e2637d0cf164..bcaed7efd1c4 100644
--- a/editors/vscode/files/patch-product.json
+++ b/editors/vscode/files/patch-product.json
@@ -1,6 +1,6 @@
---- product.json.orig 2023-04-04 22:49:54 UTC
+--- product.json.orig 2023-05-03 19:37:04 UTC
+++ product.json
-@@ -29,6 +29,16 @@
+@@ -32,6 +32,16 @@
"reportIssueUrl": "https://github.com/microsoft/vscode/issues/new",
"urlProtocol": "code-oss",
"webviewContentExternalBaseUrlTemplate": "https://{{uuid}}.vscode-cdn.net/insider/ef65ac1ba57f57f2a3961bfe94aa20481caca4c6/out/vs/workbench/contrib/webview/browser/pre/",
diff --git a/editors/vscode/files/patch-src_main.js b/editors/vscode/files/patch-src_main.js
index 93509b19b8de..2d27f73d8fa4 100644
--- a/editors/vscode/files/patch-src_main.js
+++ b/editors/vscode/files/patch-src_main.js
@@ -1,6 +1,6 @@
---- src/main.js.orig 2023-03-29 09:14:46 UTC
+--- src/main.js.orig 2023-05-03 19:37:04 UTC
+++ src/main.js
-@@ -189,7 +189,7 @@ function configureCommandlineSwitchesSync(cliArgs) {
+@@ -181,7 +181,7 @@ function configureCommandlineSwitchesSync(cliArgs) {
'force-color-profile'
];
diff --git a/editors/vscode/files/patch-src_vs_base_node_ps.ts b/editors/vscode/files/patch-src_vs_base_node_ps.ts
index b6d78791330d..3d9c6f18dd7e 100644
--- a/editors/vscode/files/patch-src_vs_base_node_ps.ts
+++ b/editors/vscode/files/patch-src_vs_base_node_ps.ts
@@ -1,6 +1,6 @@
---- src/vs/base/node/ps.ts.orig 2023-03-29 09:14:46 UTC
+--- src/vs/base/node/ps.ts.orig 2023-05-03 19:37:04 UTC
+++ src/vs/base/node/ps.ts
-@@ -214,7 +214,7 @@ export function listProcesses(rootPid: number): Promis
+@@ -217,7 +217,7 @@ export function listProcesses(rootPid: number): Promis
exec('which ps', {}, (err, stdout, stderr) => {
if (err || stderr) {
@@ -9,7 +9,7 @@
reject(err || new Error(stderr.toString()));
} else {
const cmd = JSON.stringify(FileAccess.asFileUri('vs/base/node/ps.sh').fsPath);
-@@ -229,7 +229,8 @@ export function listProcesses(rootPid: number): Promis
+@@ -232,7 +232,8 @@ export function listProcesses(rootPid: number): Promis
}
} else {
const ps = stdout.toString().trim();
diff --git a/editors/vscode/files/patch-src_vs_code_electron-main_app.ts b/editors/vscode/files/patch-src_vs_code_electron-main_app.ts
index 5c823454ed26..2e25d358ad15 100644
--- a/editors/vscode/files/patch-src_vs_code_electron-main_app.ts
+++ b/editors/vscode/files/patch-src_vs_code_electron-main_app.ts
@@ -1,6 +1,6 @@
---- src/vs/code/electron-main/app.ts.orig 2023-03-29 09:14:46 UTC
+--- src/vs/code/electron-main/app.ts.orig 2023-05-03 19:37:04 UTC
+++ src/vs/code/electron-main/app.ts
-@@ -854,7 +854,7 @@ export class CodeApplication extends Disposable {
+@@ -855,7 +855,7 @@ export class CodeApplication extends Disposable {
services.set(IUpdateService, new SyncDescriptor(Win32UpdateService));
break;
diff --git a/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts b/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts
index eaee79547973..027b46b0dc74 100644
--- a/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts
+++ b/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts
@@ -1,6 +1,6 @@
---- src/vs/workbench/contrib/extensions/browser/extensionEditor.ts.orig 2023-02-28 11:07:20 UTC
+--- src/vs/workbench/contrib/extensions/browser/extensionEditor.ts.orig 2023-05-03 19:37:04 UTC
+++ src/vs/workbench/contrib/extensions/browser/extensionEditor.ts
-@@ -1732,7 +1732,8 @@ export class ExtensionEditor extends EditorPane {
+@@ -1733,7 +1733,8 @@ export class ExtensionEditor extends EditorPane {
switch (platform) {
case 'win32': key = rawKeyBinding.win; break;
diff --git a/editors/vscode/pkg-plist b/editors/vscode/pkg-plist
index 75b7530ed090..b20dacbf3a04 100644
--- a/editors/vscode/pkg-plist
+++ b/editors/vscode/pkg-plist
@@ -8,7 +8,6 @@ share/applications/code-oss.desktop
%%DATADIR%%/chrome_100_percent.pak
%%DATADIR%%/chrome_200_percent.pak
%%DATADIR%%/code-oss
-%%DATADIR%%/icudtl.dat
%%DATADIR%%/libEGL.so
%%DATADIR%%/libGLESv2.so
%%DATADIR%%/libffmpeg.so
@@ -358,6 +357,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/markdown-language-features/package.json
%%DATADIR%%/resources/app/extensions/markdown-language-features/package.nls.json
%%DATADIR%%/resources/app/extensions/markdown-language-features/schemas/package.schema.json
+%%DATADIR%%/resources/app/extensions/markdown-language-features/server/CHANGELOG.md
%%DATADIR%%/resources/app/extensions/markdown-language-features/server/README.md
%%DATADIR%%/resources/app/extensions/markdown-language-features/server/build/pipeline.yml
%%DATADIR%%/resources/app/extensions/markdown-language-features/server/dist/node/workerMain.js
@@ -433,7 +433,6 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug-companion/resources/logo.png
%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug/LICENSE.txt
%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug/README.md
-%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug/ThirdPartyNotices.txt
%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug/package.json
%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug/package.nls.json
%%DATADIR%%/resources/app/extensions/ms-vscode.js-debug/resources/dark/configure.svg
@@ -775,7 +774,6 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/typescript-language-features/dist/extension.js
%%DATADIR%%/resources/app/extensions/typescript-language-features/dist/extension.js.LICENSE.txt
%%DATADIR%%/resources/app/extensions/typescript-language-features/media/icon.png
-%%DATADIR%%/resources/app/extensions/typescript-language-features/media/nodejsWalkthroughIcon.png
%%DATADIR%%/resources/app/extensions/typescript-language-features/package.json
%%DATADIR%%/resources/app/extensions/typescript-language-features/package.nls.json
%%DATADIR%%/resources/app/extensions/typescript-language-features/resources/walkthroughs/create-a-js-file.svg
@@ -804,6 +802,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/node_modules.asar.unpacked/@parcel/watcher/build/Release/watcher.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/@vscode/policy-watcher/build/Release/vscode-policy-watcher.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+%%DATADIR%%/resources/app/node_modules.asar.unpacked/@vscode/spdlog/build/Release/spdlog.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/@vscode/sqlite3/build/Release/vscode-sqlite3.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/keytar/build/Release/keytar.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/keytar/build/Release/obj.target/keytar.node
@@ -811,10 +810,8 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/node_modules.asar.unpacked/native-keymap/build/Release/keymapping.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/native-watchdog/build/Release/watchdog.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/node-pty/build/Release/pty.node
-%%DATADIR%%/resources/app/node_modules.asar.unpacked/node-pty/build/Release/spawn-helper
%%DATADIR%%/resources/app/node_modules.asar.unpacked/node-pty/lib/shared/conout.js
%%DATADIR%%/resources/app/node_modules.asar.unpacked/node-pty/lib/worker/conoutSocketWorker.js
-%%DATADIR%%/resources/app/node_modules.asar.unpacked/spdlog/build/Release/spdlog.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/vscode-oniguruma/release/onig.wasm
%%DATADIR%%/resources/app/node_modules.asar.unpacked/windows-foreground-love/build/Release/foreground_love.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/windows-foreground-love/build/Release/obj.target/foreground_love.node
@@ -835,32 +832,26 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/base/node/cpuUsage.sh
%%DATADIR%%/resources/app/out/vs/base/node/ps.sh
%%DATADIR%%/resources/app/out/vs/base/node/terminateProcess.sh
-%%DATADIR%%/resources/app/out/vs/base/parts/sandbox/electron-browser/preload.js
+%%DATADIR%%/resources/app/out/vs/base/parts/sandbox/electron-sandbox/preload.js
%%DATADIR%%/resources/app/out/vs/base/worker/workerMain.js
%%DATADIR%%/resources/app/out/vs/code/electron-main/main.js
%%DATADIR%%/resources/app/out/vs/code/electron-main/main.nls.js
-%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/issue/issueReporter-dev.html
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/issue/issueReporter.html
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/issue/issueReporter.js
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/issue/issueReporterMain.css
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/issue/issueReporterMain.js
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/issue/issueReporterMain.nls.js
-%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/processExplorer/processExplorer-dev.html
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/processExplorer/processExplorer.html
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/processExplorer/processExplorer.js
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/processExplorer/processExplorerMain.css
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/processExplorer/processExplorerMain.js
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/processExplorer/processExplorerMain.nls.js
-%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/workbench/workbench-dev.html
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/workbench/workbench.html
%%DATADIR%%/resources/app/out/vs/code/electron-sandbox/workbench/workbench.js
%%DATADIR%%/resources/app/out/vs/code/node/cli.js
%%DATADIR%%/resources/app/out/vs/code/node/cli.nls.js
%%DATADIR%%/resources/app/out/vs/code/node/cliProcessMain.js
%%DATADIR%%/resources/app/out/vs/code/node/cliProcessMain.nls.js
-%%DATADIR%%/resources/app/out/vs/code/node/sharedProcess/sharedProcess-dev.html
-%%DATADIR%%/resources/app/out/vs/code/node/sharedProcess/sharedProcess.html
-%%DATADIR%%/resources/app/out/vs/code/node/sharedProcess/sharedProcess.js
%%DATADIR%%/resources/app/out/vs/code/node/sharedProcess/sharedProcessMain.js
%%DATADIR%%/resources/app/out/vs/code/node/sharedProcess/sharedProcessMain.nls.js
%%DATADIR%%/resources/app/out/vs/editor/common/services/editorSimpleWorker.nls.js
@@ -879,8 +870,6 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/watcherMain.js
%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/watcherMain.nls.js
%%DATADIR%%/resources/app/out/vs/platform/profiling/electron-sandbox/profileAnalysisWorker.js
-%%DATADIR%%/resources/app/out/vs/platform/sharedProcess/electron-browser/sharedProcessWorkerMain.js
-%%DATADIR%%/resources/app/out/vs/platform/sharedProcess/electron-browser/sharedProcessWorkerMain.nls.js
%%DATADIR%%/resources/app/out/vs/platform/terminal/node/ptyHostMain.js
%%DATADIR%%/resources/app/out/vs/platform/terminal/node/ptyHostMain.nls.js
%%DATADIR%%/resources/app/out/vs/workbench/api/node/extensionHostProcess.js
@@ -903,12 +892,6 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/workbench/contrib/extensions/browser/media/theme-icon.png
%%DATADIR%%/resources/app/out/vs/workbench/contrib/externalTerminal/node/TerminalHelper.scpt
%%DATADIR%%/resources/app/out/vs/workbench/contrib/externalTerminal/node/iTermHelper.scpt
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/interactive/browser/docs/interactive.editor.drawio.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/interactive/browser/docs/interactive.eh.drawio.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/interactive/browser/docs/interactive.model.resolution.drawio.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/browser/docs/cell-resize-above-viewport.drawio.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/browser/docs/hybrid-find.drawio.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/browser/docs/viewport-rendering.drawio.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/common/services/notebookSimpleWorker.js
%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/common/services/notebookSimpleWorker.nls.js
%%DATADIR%%/resources/app/out/vs/workbench/contrib/output/common/outputLinkComputer.js