aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2022-03-04 10:14:40 +0000
committerMikael Urankar <mikael@FreeBSD.org>2022-03-04 13:31:11 +0000
commite012b71bc8e85552739b4bd005f8df71de4c5c1c (patch)
treea12824b1dca6b53b110fa32ef05ab0a85bfcaa6f
parentef459e364a895b94045b1c261fe3fd9df06b7043 (diff)
downloadports-e012b71bc8e85552739b4bd005f8df71de4c5c1c.tar.gz
ports-e012b71bc8e85552739b4bd005f8df71de4c5c1c.zip
www/redmine42: Update to 4.2.4
-rw-r--r--www/redmine42/Makefile3
-rw-r--r--www/redmine42/distinfo6
-rw-r--r--www/redmine42/files/patch-Gemfile20
-rw-r--r--www/redmine42/pkg-plist1
4 files changed, 19 insertions, 11 deletions
diff --git a/www/redmine42/Makefile b/www/redmine42/Makefile
index 59bf1d3b1d05..b9635eaf496a 100644
--- a/www/redmine42/Makefile
+++ b/www/redmine42/Makefile
@@ -1,6 +1,5 @@
PORTNAME= redmine
-PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTVERSION= 4.2.4
CATEGORIES= www
MASTER_SITES= https://www.redmine.org/releases/
PKGNAMESUFFIX= 42
diff --git a/www/redmine42/distinfo b/www/redmine42/distinfo
index c974f4e9b893..49dd3eb74485 100644
--- a/www/redmine42/distinfo
+++ b/www/redmine42/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633877757
-SHA256 (redmine-4.2.3.tar.gz) = 72f633dc954217948558889ca85325fe6410cd18a2d8b39358e5d75932a47a0c
-SIZE (redmine-4.2.3.tar.gz) = 3039136
+TIMESTAMP = 1646387373
+SHA256 (redmine-4.2.4.tar.gz) = cf649f5d4ff783582f82bebd4a5099ef63acb3d5573bbe6b4bf64f293c61c9ce
+SIZE (redmine-4.2.4.tar.gz) = 3040533
diff --git a/www/redmine42/files/patch-Gemfile b/www/redmine42/files/patch-Gemfile
index 7fccf134febe..7921212f9746 100644
--- a/www/redmine42/files/patch-Gemfile
+++ b/www/redmine42/files/patch-Gemfile
@@ -1,7 +1,11 @@
--- Gemfile.orig 2021-04-30 11:34:49 UTC
+++ Gemfile
-@@ -6,14 +6,14 @@ gem 'bundler', '>= 1.12.0'
- gem 'rails', '5.2.6'
+@@ -3,19 +3,19 @@ gem 'bundler', '>= 1.12.0'
+ ruby '>= 2.4.0', '< 2.8.0'
+ gem 'bundler', '>= 1.12.0'
+
+-gem 'rails', '5.2.6.2'
++gem 'rails', '5.2.6'
gem 'sprockets', '~> 3.7.2' if RUBY_VERSION < '2.5'
gem 'globalid', '~> 0.4.2' if Gem.ruby_version < Gem::Version.new('2.6.0')
-gem 'rouge', '~> 3.26.0'
@@ -16,9 +20,12 @@
-gem 'csv', (RUBY_VERSION < '2.5' ? ['>= 3.1.1', '<= 3.1.5'] : '~> 3.1.1')
+gem 'csv', (RUBY_VERSION < '2.5' ? ['>= 3.1.1', '<= 3.1.5'] : '~> 3.2.0')
gem 'nokogiri', (RUBY_VERSION < '2.5' ? '~> 1.10.0' : '~> 1.11.1')
- gem 'i18n', '~> 1.8.2'
+-gem 'i18n', '~> 1.8.2'
++gem 'i18n', '>= 1.8.2'
gem "rbpdf", "~> 1.20.0"
-@@ -38,67 +38,6 @@ group :openid do
+ gem 'addressable'
+ gem 'rubyzip', '~> 2.3.0'
+@@ -38,68 +38,6 @@ end
gem "rack-openid"
end
@@ -38,7 +45,8 @@
-require 'yaml'
-database_file = File.join(File.dirname(__FILE__), "config/database.yml")
-if File.exist?(database_file)
-- database_config = YAML::load(ERB.new(IO.read(database_file)).result)
+- yaml_config = ERB.new(IO.read(database_file)).result
+- database_config = YAML.respond_to?(:unsafe_load) ? YAML.unsafe_load(yaml_config) : YAML.load(yaml_config)
- adapters = database_config.values.map {|c| c['adapter']}.compact.uniq
- if adapters.any?
- adapters.each do |adapter|
@@ -86,7 +94,7 @@
local_gemfile = File.join(File.dirname(__FILE__), "Gemfile.local")
if File.exists?(local_gemfile)
eval_gemfile local_gemfile
-@@ -107,4 +46,8 @@ end
+@@ -108,4 +46,8 @@ Dir.glob File.expand_path("../plugins/*/{Gemfile,Plugi
# Load plugins' Gemfiles
Dir.glob File.expand_path("../plugins/*/{Gemfile,PluginGemfile}", __FILE__) do |file|
eval_gemfile file
diff --git a/www/redmine42/pkg-plist b/www/redmine42/pkg-plist
index 47cd800dc602..55f1348d9f41 100644
--- a/www/redmine42/pkg-plist
+++ b/www/redmine42/pkg-plist
@@ -1753,6 +1753,7 @@
%%WWWDIR%%/test/fixtures/files/import_issues.csv
%%WWWDIR%%/test/fixtures/files/import_issues_auto_mapping.csv
%%WWWDIR%%/test/fixtures/files/import_issues_utf8_with_bom.csv
+%%WWWDIR%%/test/fixtures/files/import_issues_with_relation_and_invalid_issues.csv
%%WWWDIR%%/test/fixtures/files/import_subtasks.csv
%%WWWDIR%%/test/fixtures/files/import_subtasks_with_relations.csv
%%WWWDIR%%/test/fixtures/files/import_subtasks_with_unique_id.csv