aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Chen <jonc@chen.org.nz>2024-06-17 16:59:11 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-06-19 06:32:13 +0000
commite01497c7466babee992e47a1f5c5c035e98a0771 (patch)
treecb6f7a129cd4bcd3f51c9795bfe9adf2a45d3951
parent3a0e9aa1c84b244875de50923fa0a3d41c130182 (diff)
downloadports-e01497c7466babee992e47a1f5c5c035e98a0771.tar.gz
ports-e01497c7466babee992e47a1f5c5c035e98a0771.zip
misc/ini_file_manager: update to version 11
And unbreak (see PR 278922) PR: 279805 Reported by: jonc@chen.org.nz
-rw-r--r--misc/ini_file_manager/Makefile30
-rw-r--r--misc/ini_file_manager/distinfo5
-rw-r--r--misc/ini_file_manager/files/construct.gpr2
-rw-r--r--misc/ini_file_manager/files/example.gpr12
-rw-r--r--misc/ini_file_manager/files/runme.sh.in17
5 files changed, 10 insertions, 56 deletions
diff --git a/misc/ini_file_manager/Makefile b/misc/ini_file_manager/Makefile
index 6a7059013960..6fe8befaadbb 100644
--- a/misc/ini_file_manager/Makefile
+++ b/misc/ini_file_manager/Makefile
@@ -1,8 +1,7 @@
PORTNAME= ini_file_manager
-PORTVERSION= 03
-PORTREVISION= 4
+PORTVERSION= 11
CATEGORIES= misc
-MASTER_SITES= http://sourceforge.net/projects/${SFPATH}/
+MASTER_SITES= SF/ini-files/ini-files
DISTNAME= ini-files-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -11,27 +10,20 @@ WWW= https://sourceforge.net/projects/ini-files/
LICENSE= MIT
-BROKEN= gnatmake: project files are no longer supported by gnatmake; use gprbuild instead
-
+BUILD_DEPENDS= gprbuild>0:devel/gprbuild
USES= ada zip dos2unix
-NO_WRKSUBDIR= yes
-
-SFPATH= ini-files/files/ini-files/ini-files-${PORTVERSION}
-PORTDOCS= ini_file_manager.txt
-PORTEXAMPLES= example.gpr test_config.adb runme.sh
+_GPR_ARGS= -j${MAKE_JOBS_NUMBER} -p
-OPTIONS_DEFINE= DOCS EXAMPLES
+WRKSRC= ${WRKDIR}/ini-files
post-extract:
${CP} ${FILESDIR}/construct.gpr ${WRKSRC}
${MKDIR} ${WRKSRC}/src
${MV} ${WRKSRC}/config.ad[bs] ${WRKSRC}/src
- ${SED} -e "s,@PREFIX@,${LOCALBASE},g" ${FILESDIR}/runme.sh.in \
- > ${WRKSRC}/runme.sh
do-build:
- (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gnatmake -p -Pconstruct)
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gprbuild ${_GPR_ARGS} -P construct
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
@@ -44,14 +36,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lib/* \
${STAGEDIR}${PREFIX}/lib/ini_file_manager
-do-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ini_file_manager.txt ${STAGEDIR}${DOCSDIR}
-
-do-install-EXAMPLES-on:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/runme.sh ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/test_config.adb \
- ${FILESDIR}/example.gpr ${STAGEDIR}${EXAMPLESDIR}
-
.include <bsd.port.mk>
diff --git a/misc/ini_file_manager/distinfo b/misc/ini_file_manager/distinfo
index cd114d78a3c4..2457cbbe5b72 100644
--- a/misc/ini_file_manager/distinfo
+++ b/misc/ini_file_manager/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ini-files-03.zip) = eac1c59d766fe9ce3cde7c126fe98d618c30266cc3a6d93b7e0d0e2a8d47025d
-SIZE (ini-files-03.zip) = 7643
+TIMESTAMP = 1717109745
+SHA256 (ini-files-11.zip) = 224e97dc0f88503c76736dc6c6d7220930ef09404f45c50fc339f19492966774
+SIZE (ini-files-11.zip) = 14859
diff --git a/misc/ini_file_manager/files/construct.gpr b/misc/ini_file_manager/files/construct.gpr
index 74c5d83e9ef9..a7dea0b0b6b4 100644
--- a/misc/ini_file_manager/files/construct.gpr
+++ b/misc/ini_file_manager/files/construct.gpr
@@ -8,7 +8,7 @@ project Construct is
for Library_Kind use "static";
package Builder is
- for Default_Switches ("ada") use ("-gnatf", "-gnatws", "-O2");
+ for Default_Switches ("ada") use ("-j0");
end Builder;
end Construct;
diff --git a/misc/ini_file_manager/files/example.gpr b/misc/ini_file_manager/files/example.gpr
deleted file mode 100644
index bd61316bda2a..000000000000
--- a/misc/ini_file_manager/files/example.gpr
+++ /dev/null
@@ -1,12 +0,0 @@
-with "ini_file_manager";
-project Example is
-
- for Exec_Dir use "/tmp";
- for Object_Dir use "/tmp";
- for Main use ("test_config.adb");
-
- package Compiler is
- for Default_Switches ("ada") use ("-O2", "-gnat05");
- end Compiler;
-
-end Example;
diff --git a/misc/ini_file_manager/files/runme.sh.in b/misc/ini_file_manager/files/runme.sh.in
deleted file mode 100644
index 6c1c8cda598e..000000000000
--- a/misc/ini_file_manager/files/runme.sh.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-# This script will:
-# 1) Build the example executable in /tmp
-# 2) Tell the user how to execute it
-
-GNATMAKE=@PREFIX@/gcc-aux/bin/gnatmake
-ADA_PROJECT_PATH=@PREFIX@/lib/gnat
-export ADA_PROJECT_PATH
-
-${GNATMAKE} -P example
-
-echo
-echo "The source for the example is test_config.adb"
-echo "The executable example is located in /tmp/test_config"
-echo "It requires no options; just run it"
-echo 'You may want to execute "rm /tmp/test_config*" when you are done.'