aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-29 15:49:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-29 16:59:01 +0000
commite06be01f1ef131f645cf2177b38758acf7a2e48a (patch)
treea31796355efa8f369e1c45f8afbdf26337ce0fdc
parentf40164d18b6fb2de77bf535cf09245340de463ba (diff)
downloadports-e06be01f1ef131f645cf2177b38758acf7a2e48a.tar.gz
ports-e06be01f1ef131f645cf2177b38758acf7a2e48a.zip
biology/spoa: update 4.0.7 → 4.1.0
Reported by: portscout
-rw-r--r--biology/spoa/Makefile18
-rw-r--r--biology/spoa/distinfo6
-rw-r--r--biology/spoa/files/patch-CMakeLists.txt118
-rw-r--r--biology/spoa/pkg-plist7
4 files changed, 21 insertions, 128 deletions
diff --git a/biology/spoa/Makefile b/biology/spoa/Makefile
index bf258c57ffe4..378002e2f801 100644
--- a/biology/spoa/Makefile
+++ b/biology/spoa/Makefile
@@ -1,6 +1,5 @@
PORTNAME= spoa
-DISTVERSION= 4.0.7
-PORTREVISION= 4
+DISTVERSION= 4.1.0
CATEGORIES= biology
MAINTAINER= yuri@FreeBSD.org
@@ -11,7 +10,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bioparser>0:biology/bioparser \
- ${LOCALBASE}/include/biosoup/nucleic_acid.hpp:biology/biosoup \
+ biosoup>0:biology/biosoup \
cereal>0:devel/cereal \
simde>0:devel/simde
LIB_DEPENDS= libcpu_features.so:devel/cpu_features
@@ -24,8 +23,17 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= rvaser
-CMAKE_ON= BUILD_SHARED_LIBS spoa_optimize_for_portability spoa_build_executable spoa_use_simde spoa_use_simde_nonvec spoa_use_simde_openmp
-CMAKE_OFF= spoa_optimize_for_native
+CMAKE_ON= BUILD_SHARED_LIBS \
+ spoa_build_exe \
+ spoa_optimize_for_portability \
+ spoa_build_executable \
+ spoa_use_simde \
+ spoa_use_simde_nonvec \
+ spoa_use_simde_openmp \
+ spoa_use_cereal \
+ spoa_use_simde_openmp
+CMAKE_OFF= spoa_optimize_for_native \
+ spoa_build_tests
CXXFLAGS+= -I${LOCALBASE}/include/cpu_features
LDFLAGS+= -lz -lcpu_features
diff --git a/biology/spoa/distinfo b/biology/spoa/distinfo
index b004cd66001d..09296c5fd3cf 100644
--- a/biology/spoa/distinfo
+++ b/biology/spoa/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611045674
-SHA256 (rvaser-spoa-4.0.7_GH0.tar.gz) = f8cb409adcca20ca6cc0025371743b915790879957cf001ca5e155ed16fd14e0
-SIZE (rvaser-spoa-4.0.7_GH0.tar.gz) = 43574
+TIMESTAMP = 1693289273
+SHA256 (rvaser-spoa-4.1.0_GH0.tar.gz) = 43238356f00bce2ad9698fc18b3e320024172a82182dcff24d57c5cf19e342c8
+SIZE (rvaser-spoa-4.1.0_GH0.tar.gz) = 47814
diff --git a/biology/spoa/files/patch-CMakeLists.txt b/biology/spoa/files/patch-CMakeLists.txt
deleted file mode 100644
index a5e7af7845e8..000000000000
--- a/biology/spoa/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,118 +0,0 @@
---- CMakeLists.txt.orig 2021-01-15 03:44:02 UTC
-+++ CMakeLists.txt
-@@ -44,9 +44,10 @@ if (spoa_use_simde OR
- endif ()
- endif ()
-
--if (NOT TARGET cereal)
-- add_subdirectory(vendor/cereal EXCLUDE_FROM_ALL)
--endif ()
-+#if (NOT TARGET cereal)
-+# add_subdirectory(vendor/cereal EXCLUDE_FROM_ALL)
-+#endif ()
-+find_package(cereal REQUIRED)
-
- add_library(${PROJECT_NAME}
- src/alignment_engine.cpp
-@@ -55,19 +56,19 @@ add_library(${PROJECT_NAME}
- src/dispatcher.cpp)
- target_include_directories(${PROJECT_NAME} PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
-- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/vendor/simde>
-- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/vendor/cpu_features/include>
-+ #$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/vendor/simde>
-+ #$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/vendor/cpu_features/include>
- $<INSTALL_INTERFACE:include>)
- target_link_libraries(${PROJECT_NAME}
-- cereal)
-+ cereal::cereal)
- if (BUILD_SHARED_LIBS)
- set_property(TARGET ${PROJECT_NAME} PROPERTY SOVERSION "7.0.0")
- endif ()
-
- if (spoa_generate_dispatch)
-- if (NOT TARGET cpu_features)
-- add_subdirectory(vendor/cpu_features EXCLUDE_FROM_ALL)
-- endif ()
-+ #if (NOT TARGET cpu_features)
-+ # add_subdirectory(vendor/cpu_features EXCLUDE_FROM_ALL)
-+ #endif ()
-
- list(APPEND ARCHITECTURES avx2 sse4.1 sse2)
- foreach(arch IN LISTS ARCHITECTURES)
-@@ -78,7 +79,7 @@ if (spoa_generate_dispatch)
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/vendor/simde>
- $<INSTALL_INTERFACE:include>)
- target_link_libraries(${PROJECT_NAME}_${arch}
-- cereal)
-+ cereal::cereal)
- set_target_properties(${PROJECT_NAME}_${arch} PROPERTIES
- COMPILE_FLAGS "-m${arch}")
- if (BUILD_SHARED_LIBS)
-@@ -92,8 +93,8 @@ if (spoa_generate_dispatch)
- ${PROJECT_NAME}_sse4.1
- ${PROJECT_NAME}_sse2)
-
-- target_link_libraries(${PROJECT_NAME}
-- cpu_features)
-+ #target_link_libraries(${PROJECT_NAME}
-+ # cpu_features)
- endif ()
-
- include(GNUInstallDirs)
-@@ -110,18 +111,19 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/spoa-1.pc
-
- option(spoa_build_executable "Build spoa standalone tool" OFF)
- if (spoa_build_executable)
-- if (NOT TARGET biosoup)
-- add_subdirectory(vendor/bioparser/vendor/biosoup EXCLUDE_FROM_ALL)
-- endif ()
-- if (NOT TARGET bioparser)
-- add_subdirectory(vendor/bioparser EXCLUDE_FROM_ALL)
-- endif ()
-+ #if (NOT TARGET biosoup)
-+ # add_subdirectory(vendor/bioparser/vendor/biosoup EXCLUDE_FROM_ALL)
-+ #endif ()
-+ #if (NOT TARGET bioparser)
-+ # add_subdirectory(vendor/bioparser EXCLUDE_FROM_ALL)
-+ #endif ()
- add_executable(${PROJECT_NAME}_exe
- src/main.cpp)
- target_link_libraries(${PROJECT_NAME}_exe
- ${PROJECT_NAME}
-- bioparser
-- biosoup)
-+ #bioparser
-+ #biosoup
-+ )
- target_compile_definitions(${PROJECT_NAME}_exe PRIVATE
- SPOA_VERSION="v${PROJECT_VERSION}")
- set_property(TARGET ${PROJECT_NAME}_exe PROPERTY
-@@ -134,19 +136,19 @@ endif ()
- option(spoa_build_tests "Build spoa unit tests" OFF)
- if (spoa_build_tests)
- find_package(GTest REQUIRED)
-- if (NOT TARGET biosoup)
-- add_subdirectory(vendor/bioparser/vendor/biosoup EXCLUDE_FROM_ALL)
-- endif ()
-- if (NOT TARGET bioparser)
-- add_subdirectory(vendor/bioparser EXCLUDE_FROM_ALL)
-- endif ()
-+ #if (NOT TARGET biosoup)
-+ # add_subdirectory(vendor/bioparser/vendor/biosoup EXCLUDE_FROM_ALL)
-+ #endif ()
-+ #if (NOT TARGET bioparser)
-+ # add_subdirectory(vendor/bioparser EXCLUDE_FROM_ALL)
-+ #endif ()
- include_directories(${PROJECT_SOURCE_DIR}/src)
- add_executable(${PROJECT_NAME}_test
- test/spoa_test.cpp)
- target_link_libraries(${PROJECT_NAME}_test
- ${PROJECT_NAME}
-- bioparser
-- biosoup
-+ #bioparser
-+ #biosoup
- GTest::Main)
- target_compile_definitions(${PROJECT_NAME}_test PRIVATE
- SPOA_DATA_PATH="${PROJECT_SOURCE_DIR}/test/data/sample.fastq.gz")
diff --git a/biology/spoa/pkg-plist b/biology/spoa/pkg-plist
index 7883602bf5f0..397027fc2850 100644
--- a/biology/spoa/pkg-plist
+++ b/biology/spoa/pkg-plist
@@ -1,8 +1,11 @@
bin/spoa
include/spoa/alignment_engine.hpp
-include/spoa/architectures.hpp
include/spoa/graph.hpp
include/spoa/spoa.hpp
+include/spoa/version.hpp
+lib/cmake/spoa/spoaConfig.cmake
+lib/cmake/spoa/spoaConfigVersion.cmake
+lib/cmake/spoa/spoaTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/spoa/spoaTargets.cmake
lib/libspoa.so
lib/libspoa.so.7.0.0
-libdata/pkgconfig/spoa-1.pc