aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Hein <jcfyecrayz@liamekaens.com>2024-03-31 01:52:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-03-31 02:34:54 +0000
commite0a8cc0d3378269c5e7681ae4177a85e1b8baaf8 (patch)
tree6e3f4656e3a55326d4d417ba610fe2a98d00a677
parent45fd269607b2bf1036139f134d72ec109e689842 (diff)
downloadports-e0a8cc0d3378269c5e7681ae4177a85e1b8baaf8.tar.gz
ports-e0a8cc0d3378269c5e7681ae4177a85e1b8baaf8.zip
net/mpich: Fix failure to build when devel/uthash is installed
PR: 265684
-rw-r--r--net/mpich/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index cc286bb6b560..1b80b870bdb6 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mpich
PORTVERSION= 4.1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net parallel
MASTER_SITES= https://www.mpich.org/static/downloads/${DISTVERSION}/
@@ -65,6 +65,7 @@ L0_CONFIGURE_OFF= --without-ze
CONFIGURE_ARGS= --enable-fast="" \
--with-libfabric=${LOCALBASE} \
+ --with-libfabric-include=${WRKDIR}/include \
pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
MPICHLIB_CFLAGS="${CFLAGS}" \
CFLAGS="-I${LOCALBASE}/include/json-c ${CFLAGS_F2018}" \
@@ -115,5 +116,9 @@ post-extract:
post-patch:
${RM} -r ${WRKSRC}/www
+# To avoid pollution from ${LOCALBASE}/include, set up the build to look in
+# ${WRKDIR} for libfabric include/rdma/ header files (see --with-libfabric
+# configure args).
+ ${MKDIR} ${WRKDIR}/include && ${LN} -s ${LOCALBASE}/include/rdma ${WRKDIR}/include/
.include <bsd.port.post.mk>