aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-10-07 14:47:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-10-25 08:49:09 +0000
commite2500e896b61807ae2c4785baf1f3e3bb9b6424e (patch)
treed2057977c80f3b23bf40937530994e0c431b4a97
parent15d43d187799cc8c11bca0d209111f91599064ed (diff)
downloadports-e2500e896b61807ae2c4785baf1f3e3bb9b6424e.tar.gz
ports-e2500e896b61807ae2c4785baf1f3e3bb9b6424e.zip
deskutils/solanum: Chase USES=cargo's new git source support
PR: 256581
-rw-r--r--deskutils/solanum/Makefile33
-rw-r--r--deskutils/solanum/files/patch-gtk310
2 files changed, 5 insertions, 338 deletions
diff --git a/deskutils/solanum/Makefile b/deskutils/solanum/Makefile
index 39d8a28a10c6..50c1947d6df6 100644
--- a/deskutils/solanum/Makefile
+++ b/deskutils/solanum/Makefile
@@ -11,18 +11,13 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE.md
USES= cargo gettext gnome meson pkgconfig python:build shebangfix
-USE_GITHUB= nodefault
USE_GITLAB= yes
USE_GNOME= gtk40 libadwaita
USE_GSTREAMER1= bad good vorbis
-GH_TUPLE= gtk-rs:gtk3-rs:c58fab4fec1254244f598c4eac7f9310184c5996:gtk3 \
- gtk-rs:gtk4-rs:64d0e1c1344458a065ccf22dcecf105c55b902ca:gtk4
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
GL_PROJECT= Solanum
GL_COMMIT= 3e69272fb31bf18a7aa74ece9d904d445c458274
-GL_TUPLE= https://gitlab.freedesktop.org:gstreamer:gstreamer-rs:0e8b95f1d029530ad3f84a3f08a20d8dfd80a089:gstreamer \
- bilelmoussaoui:libadwaita-rs:b898c11fb6776fc7a9a6b920222fa3173216a80c:libadwaita
SHEBANG_FILES= build-aux/meson/postinstall.py
MAKE_ENV= ${CARGO_ENV}
GLIB_SCHEMAS= org.gnome.Solanum.gschema.xml
@@ -93,29 +88,11 @@ CARGO_CRATES= aho-corasick-0.7.15 \
version_check-0.9.2 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-x86_64-pc-windows-gnu-0.4.0
-CARGO_USE_GITHUB= yes
-CARGO_USE_GITLAB= yes
-CARGO_GIT_SUBDIR= gstreamer:gstreamer-player:gstreamer-player \
- gstreamer:gstreamer:gstreamer \
- gtk3:cairo-rs:cairo \
- gtk3:cairo-sys-rs:cairo/sys \
- gtk3:gdk-pixbuf-sys:gdk-pixbuf/sys \
- gtk3:gdk-pixbuf:gdk-pixbuf \
- gtk3:gio-sys:gio/sys \
- gtk3:gio:gio \
- gtk3:glib-sys:glib/sys \
- gtk3:glib:glib \
- gtk3:gobject-sys:glib/gobject-sys \
- gtk3:graphene-sys:graphene/sys \
- gtk3:graphene:graphene \
- gtk3:pango-sys:pango/sys \
- gtk3:pango:pango \
- gtk4:gdk-sys:gdk4/sys \
- gtk4:gdk:gdk4 \
- gtk4:gtk-sys:gtk4/sys \
- gtk4:gtk:gtk4 \
- libadwaita:libadwaita:libadwaita
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ gdk4,gdk4-sys,gsk4,gsk4-sys,gtk4,gtk4-macros,gtk4-sys@git+https://github.com/gtk-rs/gtk4-rs\#64d0e1c1344458a065ccf22dcecf105c55b902ca \
+ gstreamer,gstreamer-base,gstreamer-base-sys,gstreamer-player,gstreamer-player-sys,gstreamer-sys,gstreamer-video,gstreamer-video-sys@git+https://gitlab.freedesktop.org/gstreamer/gstreamer-rs\#0e8b95f1d029530ad3f84a3f08a20d8dfd80a089 \
+ cairo-rs,cairo-sys-rs,gdk-pixbuf,gdk-pixbuf-sys,gio,gio-sys,glib,glib-macros,glib-sys,gobject-sys,graphene-rs,graphene-sys,pango,pango-sys@git+https://github.com/gtk-rs/gtk3-rs\#c58fab4fec1254244f598c4eac7f9310184c5996 \
+ libadwaita,libadwaita-sys@git+https://gitlab.gnome.org/bilelmoussaoui/libadwaita-rs\#b898c11fb6776fc7a9a6b920222fa3173216a80c
CARGO_BUILD= no
CARGO_INSTALL= no
CARGO_TEST= no
diff --git a/deskutils/solanum/files/patch-gtk b/deskutils/solanum/files/patch-gtk
deleted file mode 100644
index 42aa2f642dca..000000000000
--- a/deskutils/solanum/files/patch-gtk
+++ /dev/null
@@ -1,310 +0,0 @@
-https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256581
-
---- ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer-base/sys/Cargo.toml.orig 2021-01-25 11:56:55 UTC
-+++ ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer-base/sys/Cargo.toml
-@@ -3,12 +3,8 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
- [dependencies.gstreamer-sys]
- path = "../../gstreamer/sys"
---- ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer-player/sys/Cargo.toml.orig 2021-01-25 11:56:55 UTC
-+++ ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer-player/sys/Cargo.toml
-@@ -3,12 +3,8 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
- [dependencies.gstreamer-sys]
- path = "../../gstreamer/sys"
---- ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer-video/sys/Cargo.toml.orig 2021-01-25 11:56:55 UTC
-+++ ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer-video/sys/Cargo.toml
-@@ -3,12 +3,8 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
- [dependencies.gstreamer-base-sys]
- path = "../../gstreamer-base/sys"
---- ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer/sys/Cargo.toml.orig 2021-01-25 11:56:55 UTC
-+++ ../gstreamer-rs-0e8b95f1d029530ad3f84a3f08a20d8dfd80a089/gstreamer/sys/Cargo.toml
-@@ -3,12 +3,8 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
- [dev-dependencies]
- shell-words = "1.0.0"
---- ../gtk4-rs-64d0e1c1344458a065ccf22dcecf105c55b902ca/gdk4/sys/Cargo.toml.orig 2021-01-25 20:09:24 UTC
-+++ ../gtk4-rs-64d0e1c1344458a065ccf22dcecf105c55b902ca/gdk4/sys/Cargo.toml
-@@ -3,24 +3,12 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
--
--[dependencies.cairo-sys-rs]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gdk-pixbuf-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gio-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.pango-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-+cairo-sys-rs = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gdk-pixbuf-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gio-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+pango-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
- [dev-dependencies]
- shell-words = "1.0.0"
---- ../gtk4-rs-64d0e1c1344458a065ccf22dcecf105c55b902ca/gsk4/sys/Cargo.toml.orig 2021-01-25 20:09:24 UTC
-+++ ../gtk4-rs-64d0e1c1344458a065ccf22dcecf105c55b902ca/gsk4/sys/Cargo.toml
-@@ -3,24 +3,14 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
-+cairo-sys-rs = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+graphene-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+pango-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
--[dependencies.cairo-sys-rs]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
- [dependencies.gdk4-sys]
- path = "../../gdk4/sys"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.graphene-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.pango-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-
- [dev-dependencies]
- shell-words = "1.0.0"
---- ../gtk4-rs-64d0e1c1344458a065ccf22dcecf105c55b902ca/gtk4/sys/Cargo.toml.orig 2021-01-25 20:09:24 UTC
-+++ ../gtk4-rs-64d0e1c1344458a065ccf22dcecf105c55b902ca/gtk4/sys/Cargo.toml
-@@ -3,33 +3,19 @@ system-deps = "2.0"
-
- [dependencies]
- libc = "0.2"
-+cairo-sys-rs = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gdk-pixbuf-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gio-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+graphene-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+pango-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-
--[dependencies.cairo-sys-rs]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gdk-pixbuf-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
- [dependencies.gdk4-sys]
- path = "../../gdk4/sys"
-
--[dependencies.gio-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.graphene-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
- [dependencies.gsk4-sys]
- path = "../../gsk4/sys"
--
--[dependencies.pango-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
-
- [dev-dependencies]
- shell-words = "1.0.0"
---- ../libadwaita-rs-b898c11fb6776fc7a9a6b920222fa3173216a80c/libadwaita/Cargo.toml.orig 2021-01-15 00:37:53 UTC
-+++ ../libadwaita-rs-b898c11fb6776fc7a9a6b920222fa3173216a80c/libadwaita/Cargo.toml
-@@ -8,28 +8,15 @@ edition = "2018"
- libc = '0.2'
- bitflags = '1.2'
- lazy_static = '1.4'
-+glib = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gio = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gdk-pixbuf = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+pango = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gdk = { package = "gdk4", git = "https://github.com/gtk-rs/gtk4-rs" }
-+gtk = { package = "gtk4", git = "https://github.com/gtk-rs/gtk4-rs" }
-+
- [lib]
- name = "libadwaita"
--
--[dependencies.glib]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gio]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gdk-pixbuf]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.pango]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gdk]
--package = "gdk4"
--git = "https://github.com/gtk-rs/gtk4-rs"
--
--[dependencies.gtk]
--package = "gtk4"
--git = "https://github.com/gtk-rs/gtk4-rs"
-
- [dependencies.ffi]
- package = "libadwaita-sys"
---- ../libadwaita-rs-b898c11fb6776fc7a9a6b920222fa3173216a80c/libadwaita/sys/Cargo.toml.orig 2021-01-15 00:37:53 UTC
-+++ ../libadwaita-rs-b898c11fb6776fc7a9a6b920222fa3173216a80c/libadwaita/sys/Cargo.toml
-@@ -16,29 +16,13 @@ name = "libadwaita_sys"
-
- [dependencies]
- libc = "0.2"
--
--[dependencies.gio-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gdk-pixbuf-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.pango-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gtk-sys]
--package = "gtk4-sys"
--git = "https://github.com/gtk-rs/gtk4-rs"
--
--[dependencies.gdk-sys]
--package = "gdk4-sys"
--git = "https://github.com/gtk-rs/gtk4-rs"
-+gio-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gdk-pixbuf-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+pango-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gtk-sys = { package = "gtk4-sys", git = "https://github.com/gtk-rs/gtk4-rs" }
-+gdk-sys = { package = "gdk4-sys", git = "https://github.com/gtk-rs/gtk4-rs" }
-
- [build-dependencies]
- system-deps = "2.0"
---- Cargo.toml.orig 2021-02-08 23:38:19 UTC
-+++ Cargo.toml
-@@ -7,42 +7,17 @@ edition = "2018"
- once_cell = "1.4.0"
- regex = "1.3.4"
- gtk-macros = "0.2.0"
-+gtk = { package ="gtk4", git = "https://github.com/gtk-rs/gtk4-rs" }
-+gobject-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+glib-sys = { git = "https://github.com/gtk-rs/gtk3-rs" }
-+gdk = { package = "gdk4", git = "https://github.com/gtk-rs/gtk4-rs" }
-+gio = { git = "https://github.com/gtk-rs/gtk3-rs", features = ["v2_60"] }
-+glib = { git = "https://github.com/gtk-rs/gtk3-rs", features = ["v2_60"] }
-+gstreamer = { git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs" }
-+gstreamer-player = { git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs" }
-+libadwaita = { git = "https://gitlab.gnome.org/bilelmoussaoui/libadwaita-rs" }
-+pango = { git = "https://github.com/gtk-rs/gtk3-rs", features = ["v1_44"] }
-
--[dependencies.gtk]
--git = "https://github.com/gtk-rs/gtk4-rs"
--package ="gtk4"
--
--[dependencies.gobject-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.glib-sys]
--git = "https://github.com/gtk-rs/gtk3-rs"
--
--[dependencies.gdk]
--git = "https://github.com/gtk-rs/gtk4-rs"
--package = "gdk4"
--
--[dependencies.gio]
--git = "https://github.com/gtk-rs/gtk3-rs"
--features = ["v2_60"]
--
--[dependencies.glib]
--git = "https://github.com/gtk-rs/gtk3-rs"
--features = ["v2_60"]
--
--[dependencies.gstreamer]
--git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs"
--
--[dependencies.gstreamer-player]
--git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs"
--
- [dependencies.gettext-rs]
- version = "0.4.4"
- features = ["gettext-system"]
--
--[dependencies.libadwaita]
--git = "https://gitlab.gnome.org/bilelmoussaoui/libadwaita-rs"
--
--[dependencies.pango]
--git = "https://github.com/gtk-rs/gtk3-rs"
--features = ["v1_44"]