aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2022-10-08 14:45:49 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2022-10-08 14:48:21 +0000
commite25ebaf6c33516c30cfc50b738cec486f74544c6 (patch)
tree03bea39b45138c96d9229330dad00ceb4771a493
parentc8e8499d9e65cf263fdfc7183d6a59ef0afb7c60 (diff)
downloadports-e25ebaf6c33516c30cfc50b738cec486f74544c6.tar.gz
ports-e25ebaf6c33516c30cfc50b738cec486f74544c6.zip
devel/cpprestsdk: fix BROKEN by update 2.10.16 -> 2.10.18
Reset maintainership due to no update. <ChangeLog> cpprestsdk (2.10.18) * PR#1571 Add ability to parse and emit the NT Epoch 1601-01-01T00:00:00Z * PR#1571 Update vcpkg submodule * Update CI configuration cpprestsdk (2.10.17) * PR#1550 Fix year calculation for the last day of a leap year * PR#1523 Fix wrong linking of Apple Frameworks on MacOS * PR#1520 Define __STDC_FORMAT_MACROS when it hasn't been defined to avoid duplicate define error. * PR#1415 Delete apparently broken .vcxprojs and .pfxes. * Removed defunct email contact information from the readme </ChangeLog>
-rw-r--r--devel/cpprestsdk/Makefile7
-rw-r--r--devel/cpprestsdk/distinfo6
-rw-r--r--devel/cpprestsdk/files/patch-src_CMakeLists.txt11
3 files changed, 16 insertions, 8 deletions
diff --git a/devel/cpprestsdk/Makefile b/devel/cpprestsdk/Makefile
index f6e6ca45d48d..a28cdac6f76d 100644
--- a/devel/cpprestsdk/Makefile
+++ b/devel/cpprestsdk/Makefile
@@ -1,10 +1,9 @@
PORTNAME= cpprestsdk
-PORTVERSION= 2.10.16
-PORTREVISION= 1
+PORTVERSION= 2.10.18
DISTVERSIONPREFIX= v
CATEGORIES= devel
-MAINTAINER= projects@phess.net
+MAINTAINER= ports@FreeBSD.org
COMMENT= Microsoft C++ REST SDK
WWW= https://github.com/Microsoft/cpprestsdk
@@ -14,8 +13,6 @@ LICENSE_FILE= ${WRKSRC}/../license.txt
BUILD_DEPENDS= ${LOCALBASE}/include/websocketpp/client.hpp:devel/websocketpp
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-BROKEN= error: performing pointer subtraction with a null pointer may have undefined behavior
-
USES= cmake compiler:c++11-lang pkgconfig ssl
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/devel/cpprestsdk/distinfo b/devel/cpprestsdk/distinfo
index ae2db5db25b9..05d6bf4a9623 100644
--- a/devel/cpprestsdk/distinfo
+++ b/devel/cpprestsdk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587775456
-SHA256 (Microsoft-cpprestsdk-v2.10.16_GH0.tar.gz) = 3d75e17c7d79131320438f2a15331f7ca6281c38c0e2daa27f051e290eeb8681
-SIZE (Microsoft-cpprestsdk-v2.10.16_GH0.tar.gz) = 1768423
+TIMESTAMP = 1665067608
+SHA256 (Microsoft-cpprestsdk-v2.10.18_GH0.tar.gz) = 6bd74a637ff182144b6a4271227ea8b6b3ea92389f88b25b215e6f94fd4d41cb
+SIZE (Microsoft-cpprestsdk-v2.10.18_GH0.tar.gz) = 1747792
diff --git a/devel/cpprestsdk/files/patch-src_CMakeLists.txt b/devel/cpprestsdk/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..b99d076519df
--- /dev/null
+++ b/devel/cpprestsdk/files/patch-src_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/CMakeLists.txt.orig 2022-10-06 15:08:19 UTC
++++ src/CMakeLists.txt
+@@ -187,7 +187,7 @@ configure_pch(cpprest stdafx.h pch/stdafx.cpp /Zm120)
+
+ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+ if(WERROR)
+- target_compile_options(cpprest PRIVATE -Werror)
++ target_compile_options(cpprest PRIVATE -Wno-error)
+ endif()
+ target_compile_options(cpprest PRIVATE -pedantic ${WARNINGS})
+ elseif(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")