aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:12:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:06 +0000
commite2bd8b024ee9d1e20c7f1a2fea371b9dbcaa7a2b (patch)
treeea2ab5a3c94d4b0f338bd10747be477e3fa9f061
parentcc65b56368c50c4e560bcb56ea5088688efef245 (diff)
downloadports-e2bd8b024ee9d1e20c7f1a2fea371b9dbcaa7a2b.tar.gz
ports-e2bd8b024ee9d1e20c7f1a2fea371b9dbcaa7a2b.zip
devel/py-pytest-codspeed: Add py-pytest-codspeed 2.2.0
CodSpeed is a continuous benchmarking platform that allows you to track and compare the performance of your codebase during development. It uses a smart runtime engine to measure the performance of your code in an accurate and reproducible way without creating a huge runtime overhead, unlike traditional benchmarks. CodSpeed produces detailed performance reports, helping you improve your codebase performance, directly within your repository provider(Pull Requests comments, Merge checks, ...).
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-codspeed/Makefile32
-rw-r--r--devel/py-pytest-codspeed/distinfo3
-rw-r--r--devel/py-pytest-codspeed/pkg-descr8
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 61aca300f71b..22274e2fa1b0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5404,6 +5404,7 @@
SUBDIR += py-pytest-capturelog
SUBDIR += py-pytest-cases
SUBDIR += py-pytest-checkdocs
+ SUBDIR += py-pytest-codspeed
SUBDIR += py-pytest-console-scripts
SUBDIR += py-pytest-cov
SUBDIR += py-pytest-cpp
diff --git a/devel/py-pytest-codspeed/Makefile b/devel/py-pytest-codspeed/Makefile
new file mode 100644
index 000000000000..6efae88efb02
--- /dev/null
+++ b/devel/py-pytest-codspeed/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= pytest-codspeed
+PORTVERSION= 2.2.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytest_codspeed-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pytest plugin to create CodSpeed benchmarks
+WWW= https://docs.codspeed.io/ \
+ https://github.com/CodSpeedHQ/pytest-codspeed
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.15.1:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}filelock>=3.12.2:sysutils/py-filelock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=3.8,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 31200
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-pytest-codspeed/distinfo b/devel/py-pytest-codspeed/distinfo
new file mode 100644
index 000000000000..965caf6122fa
--- /dev/null
+++ b/devel/py-pytest-codspeed/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448826
+SHA256 (pytest_codspeed-2.2.0.tar.gz) = 665003fc20117b64a98d16ffd1008f5bd6bf3b1e9af142b98c00abff7f626bbd
+SIZE (pytest_codspeed-2.2.0.tar.gz) = 9130
diff --git a/devel/py-pytest-codspeed/pkg-descr b/devel/py-pytest-codspeed/pkg-descr
new file mode 100644
index 000000000000..c77b8d710e39
--- /dev/null
+++ b/devel/py-pytest-codspeed/pkg-descr
@@ -0,0 +1,8 @@
+CodSpeed is a continuous benchmarking platform that allows you to track and
+compare the performance of your codebase during development.
+
+It uses a smart runtime engine to measure the performance of your code in an
+accurate and reproducible way without creating a huge runtime overhead, unlike
+traditional benchmarks. CodSpeed produces detailed performance reports, helping
+you improve your codebase performance, directly within your repository
+provider(Pull Requests comments, Merge checks, ...).