aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2024-02-01 15:40:21 +0000
committerDiane Bruce <db@FreeBSD.org>2024-02-01 15:43:51 +0000
commite2c383399ef69b69bed81b4b6de35e29d0db687d (patch)
tree38b7f8234026eb280e926fd667c3e177b8826361
parent9302d938570172032b9ea137d0fd3fe7c2d44fc8 (diff)
downloadports-e2c383399ef69b69bed81b4b6de35e29d0db687d.tar.gz
ports-e2c383399ef69b69bed81b4b6de35e29d0db687d.zip
comms/svxlink: Fix missing port files
Looks like I missed adding some files
-rw-r--r--comms/svxlink/Makefile1
-rw-r--r--comms/svxlink/files/patch-src_svxlink_svxlink_CMakeLists.txt12
-rw-r--r--comms/svxlink/files/remotetrx.in32
-rw-r--r--comms/svxlink/files/svxlink.in31
-rw-r--r--comms/svxlink/files/svxreflector.in32
-rw-r--r--comms/svxlink/pkg-message22
6 files changed, 130 insertions, 0 deletions
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index f0180a805dce..7caea05c081a 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -1,5 +1,6 @@
PORTNAME?= svxlink
PORTVERSION= 19.09.2
+PORTREVISION= 1
CATEGORIES= comms hamradio
MAINTAINER= hamradio@FreeBSD.org
diff --git a/comms/svxlink/files/patch-src_svxlink_svxlink_CMakeLists.txt b/comms/svxlink/files/patch-src_svxlink_svxlink_CMakeLists.txt
new file mode 100644
index 000000000000..b1f0d566d71d
--- /dev/null
+++ b/comms/svxlink/files/patch-src_svxlink_svxlink_CMakeLists.txt
@@ -0,0 +1,12 @@
+--- src/svxlink/svxlink/CMakeLists.txt.orig 2021-03-09 23:15:07 UTC
++++ src/svxlink/svxlink/CMakeLists.txt
+@@ -55,6 +55,9 @@ add_version_target(SVXLINK VERSION_DEPENDS)
+ set(VERSION_DEPENDS)
+ add_version_target(SVXLINK VERSION_DEPENDS)
+
++# Needed on FreeBSD
++string(PREPEND CMAKE_CXX_FLAGS "-Wl,-export-dynamic ")
++
+ # Build the executable
+ add_executable(svxlink
+ MsgHandler.cpp Module.cpp Logic.cpp SimplexLogic.cpp RepeaterLogic.cpp
diff --git a/comms/svxlink/files/remotetrx.in b/comms/svxlink/files/remotetrx.in
new file mode 100644
index 000000000000..b3c8f6f797f1
--- /dev/null
+++ b/comms/svxlink/files/remotetrx.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: remotetrx
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# remotetrx_enable (bool): Set to NO by default.
+# Set it to YES to enable remotetrx.
+# remotetrx_config (path): Set to %%PREFIX%%/etc/remotetrx/remotetrx
+# by default.
+
+. /etc/rc.subr
+
+name=remotetrx
+rcvar=remotetrx_enable
+
+load_rc_config $name
+
+: ${remotetrx_enable:="NO"}
+: ${remotetrx_config="%%PREFIX%%/etc/remotetrx/remotetrx.conf"}
+
+command=%%PREFIX%%/bin/${name}
+pidfile=/var/run/${name}.pid
+
+command_args="--config $remotetrx_config --daemon --runasuser svxlink --pidfile ${pidfile}"
+
+run_rc_command "$1"
diff --git a/comms/svxlink/files/svxlink.in b/comms/svxlink/files/svxlink.in
new file mode 100644
index 000000000000..aba8a2ecebfc
--- /dev/null
+++ b/comms/svxlink/files/svxlink.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: svxlink
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# svxlink_enable (bool): Set to NO by default.
+# Set it to YES to enable svxlink.
+# svxlink_config (path): Set to %%PREFIX%%/etc/svxlink/svxlink.conf
+# by default.
+
+. /etc/rc.subr
+
+name=svxlink
+rcvar=svxlink_enable
+
+load_rc_config $name
+
+: ${svxlink_enable:="NO"}
+: ${svxlink_config="%%PREFIX%%/etc/svxlink/svxlink.conf"}
+
+command=%%PREFIX%%/bin/${name}
+pidfile=/var/run/${name}.pid
+command_args="--config $svxlink_config --daemon --runasuser ${name} --pidfile ${pidfile}"
+
+run_rc_command "$1"
diff --git a/comms/svxlink/files/svxreflector.in b/comms/svxlink/files/svxreflector.in
new file mode 100644
index 000000000000..0e66932fc4b9
--- /dev/null
+++ b/comms/svxlink/files/svxreflector.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: remotetrx
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# svxreflector_enable (bool): Set to NO by default.
+# Set it to YES to enable svxreflector.
+# svxreflector_config (path): Set to %%PREFIX%%/etc/svxlink/svxreflector.conf
+# by default.
+
+. /etc/rc.subr
+
+name=svxreflector
+rcvar=svxreflector_enable
+
+load_rc_config $name
+
+: ${svxreflector_enable:="NO"}
+: ${svxreflector_config="%%PREFIX%%/etc/svxlink/svxreflector.conf"}
+
+command=%%PREFIX%%/bin/${name}
+pidfile=/var/run/${name}.pid
+
+command_args="--config $svxreflector_config --daemon --runasuser svxlink --pidfile ${pidfile}"
+
+run_rc_command "$1"
diff --git a/comms/svxlink/pkg-message b/comms/svxlink/pkg-message
new file mode 100644
index 000000000000..f1766bf86153
--- /dev/null
+++ b/comms/svxlink/pkg-message
@@ -0,0 +1,22 @@
+[
+{ type: install
+ message: <<EOM
+svxlink is now installed.
+
+configuration files in ${PREFIX}/etc/svxlink
+remotetrx.conf svxlink.conf svxreflector.conf
+TclVoiceMail.conf gpio.conf
+
+More modules are in ${PREFIX}/etc/svxlink/svxlink.d
+
+man svxlink for more information
+
+To start svxlink, svxreflector or remotetrx as needed add to /etc/rc.local
+svxlink_enable="YES"
+svxreflector_enable="YES"
+remotetrx_enable="YES"
+
+EOM
+}
+]
+