aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-09 04:27:18 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-09 05:23:46 +0000
commite37200d60b811ed24fc3b0744184f3573f99da4a (patch)
tree31083e40ebb51ddc657accfef8ffb3fc79512343
parentadb336114717c1dd89318e1378d521694a35a919 (diff)
downloadports-e37200d60b811ed24fc3b0744184f3573f99da4a.tar.gz
ports-e37200d60b811ed24fc3b0744184f3573f99da4a.zip
emulators/{citra,yuzu}: drop runtime dependency on boost-libs
Until subpackaging arrives to bsd.port.mk and boost-libs is split into smaller packages this shaves ~166 MiB of install size. Mainly useful for non-qt5 versions as DEs may bring boost-libs via other routes. (cherry picked from commit 6896626b1d2a8edb8832f5557786079338752d72)
-rw-r--r--emulators/citra/Makefile4
-rw-r--r--emulators/yuzu/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index 397104d9ce50..218dc399f5c6 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE_LGPL21+ = ${_LICENSE_STORE}/LGPL21 # soundtouch
LICENSE_FILE_MIT= ${WRKSRC}/externals/enet/LICENSE
LICENSE_FILE_OpenSSL= ${WRKSRC}/externals/libressl/COPYING
-LIB_DEPENDS= libboost_serialization.so:devel/boost-libs
+BUILD_DEPENDS= boost-libs>0:devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= citra-emu
@@ -42,7 +42,7 @@ GH_TUPLE= citra-emu:ext-boost:36603a1:boost/externals/boost \
USES= cmake:testing compiler:c++17-lang localbase:ldflags sdl
USE_SDL= sdl2
-CMAKE_ON= USE_SYSTEM_BOOST
+CMAKE_ON= USE_SYSTEM_BOOST Boost_USE_STATIC_LIBS
LDFLAGS+= -Wl,--as-needed # Qt5Network
OPTIONS_DEFINE= ALSA FFMPEG PULSEAUDIO JACK SNDIO
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 9d805f8c190c..877fa7714ef6 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -22,13 +22,13 @@ ONLY_FOR_ARCHS= aarch64 amd64 powerpc64
ONLY_FOR_ARCHS_REASON= requires int128
BUILD_DEPENDS= catch>0:devel/catch \
+ boost-libs>0:devel/boost-libs \
nlohmann-json>0:devel/nlohmann-json \
glslangValidator:graphics/glslang
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
libzip.so:archivers/libzip \
libzstd.so:archivers/zstd \
libopus.so:audio/opus \
- libboost_context.so:devel/boost-libs \
libavcodec.so:multimedia/ffmpeg
USE_GITHUB= yes
@@ -50,7 +50,7 @@ GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-115-g8c88150ca:mbedtls/externals/mbedtls \
USES= cmake:testing compiler:c++17-lang localbase:ldflags sdl ssl
USE_GCC= yes:build # libc++ lacks std::atomic_ref, std::ranges
USE_SDL= sdl2
-CMAKE_ON= LIBVA_FOUND
+CMAKE_ON= Boost_USE_STATIC_LIBS LIBVA_FOUND
CMAKE_OFF= YUZU_USE_EXTERNAL_SDL2 ENABLE_GNUTLS ENABLE_MBEDTLS
LDFLAGS+= -static-libstdc++ # avoid libc++ conflict, requires files/patch-fmt
LDFLAGS+= -Wl,--as-needed # Qt5Network