aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-12-06 19:07:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-12-06 19:52:35 +0000
commite389276874426b949a835cfd50f34f54de522884 (patch)
tree38ee12f7d44489da11f5fe0eece603cfad833e13
parent0e93e25cb9da6a9147b0f5f287ae98ee1b2db423 (diff)
downloadports-e389276874426b949a835cfd50f34f54de522884.tar.gz
ports-e389276874426b949a835cfd50f34f54de522884.zip
emulators/yuzu: unbreak build after 455717ffde60
CMake Warning at CMakeLists.txt:313 (find_package): Could not find a configuration file for package "xbyak" that is compatible with requested version "6". The following configuration files were considered but not accepted: /usr/local/lib/cmake/xbyak/xbyak-config.cmake, version: 7.0 CMake Error at externals/CMakeLists.txt:19 (add_subdirectory): The source directory externals/xbyak does not contain a CMakeLists.txt file.
-rw-r--r--emulators/yuzu/files/patch-xbyak726
1 files changed, 26 insertions, 0 deletions
diff --git a/emulators/yuzu/files/patch-xbyak7 b/emulators/yuzu/files/patch-xbyak7
new file mode 100644
index 000000000000..55ee08d293b0
--- /dev/null
+++ b/emulators/yuzu/files/patch-xbyak7
@@ -0,0 +1,26 @@
+CMake Warning at CMakeLists.txt:313 (find_package):
+ Could not find a configuration file for package "xbyak" that is compatible
+ with requested version "6".
+
+ The following configuration files were considered but not accepted:
+
+ /usr/local/lib/cmake/xbyak/xbyak-config.cmake, version: 7.0
+
+CMake Error at externals/CMakeLists.txt:19 (add_subdirectory):
+ The source directory
+
+ externals/xbyak
+
+ does not contain a CMakeLists.txt file.
+
+--- CMakeLists.txt.orig 2023-12-04 02:59:11 UTC
++++ CMakeLists.txt
+@@ -310,7 +310,7 @@
+ endif()
+
+ if (ARCHITECTURE_x86 OR ARCHITECTURE_x86_64)
+- find_package(xbyak 6 CONFIG)
++ find_package(xbyak CONFIG)
+ endif()
+
+ if (ARCHITECTURE_x86_64 OR ARCHITECTURE_arm64)