aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-28 02:26:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-28 02:27:04 +0000
commite413829f295b8c69febf053ab39dbf88ae08161a (patch)
tree5142a126c3b791434345b34a7403e3ea5a21957a
parent33b0eb073cf57e95656700701f8fc4872e3904ff (diff)
downloadports-e413829f295b8c69febf053ab39dbf88ae08161a.tar.gz
ports-e413829f295b8c69febf053ab39dbf88ae08161a.zip
math/g2o: Update 20201223 → 20230223
Reported by: portscout
-rw-r--r--math/g2o/Makefile24
-rw-r--r--math/g2o/distinfo6
-rw-r--r--math/g2o/pkg-plist59
3 files changed, 74 insertions, 15 deletions
diff --git a/math/g2o/Makefile b/math/g2o/Makefile
index e16bc62fe82b..9f27e65cc461 100644
--- a/math/g2o/Makefile
+++ b/math/g2o/Makefile
@@ -1,7 +1,6 @@
PORTNAME= g2o
-DISTVERSION= 20201223
+DISTVERSION= 20230223
DISTVERSIONSUFFIX= _git
-PORTREVISION= 3
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -11,19 +10,28 @@ WWW= https://openslam-org.github.io/g2o.html
LICENSE= LGPL3 GPLv3
LICENSE_COMB= dual
-LIB_DEPENDS= libcxsparse.so:math/suitesparse-cxsparse \
+LIB_DEPENDS= libamd.so:math/suitesparse-amd \
+ libcamd.so:math/suitesparse-camd \
+ libccolamd.so:math/suitesparse-ccolamd \
+ libcholmod.so:math/suitesparse-cholmod \
+ libcolamd.so:math/suitesparse-colamd \
+ libcxsparse.so:math/suitesparse-cxsparse \
libQGLViewer-qt5.so:graphics/libQGLViewer \
libmetis.so:math/metis \
- libopenblas.so:math/openblas
+ libopenblas.so:math/openblas \
+ libsuitesparseconfig.so:math/suitesparse-config
+TEST_DEPENDS= googletest>0:devel/googletest
-USES= cmake compiler:c++11-lang gl eigen:3 blaslapack:netlib qt:5
-USE_GITHUB= yes
-GH_ACCOUNT= RainerKuemmerle
+USES= cmake:testing compiler:c++14-lang gl eigen:3 blaslapack:netlib localbase qt:5
USE_GL= gl glu
USE_QT= core gui opengl xml widgets buildtools:build qmake:build
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= RainerKuemmerle
+
CMAKE_OFF= DO_SSE_AUTODETECT
+CMAKE_TESTING_ON= BUILD_UNITTESTS
OPTIONS_DEFINE= FAST_MATH
OPTIONS_SINGLE= SIMD_${ARCH:tu}
@@ -60,4 +68,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
${WRKSRC}/cmake_modules/*.cmake
+# tests fail to compile, see https://github.com/RainerKuemmerle/g2o/issues/641
+
.include <bsd.port.mk>
diff --git a/math/g2o/distinfo b/math/g2o/distinfo
index a22a39cba01f..be02c922911a 100644
--- a/math/g2o/distinfo
+++ b/math/g2o/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608877363
-SHA256 (RainerKuemmerle-g2o-20201223_git_GH0.tar.gz) = 20af80edf8fd237e29bd21859b8fc734e615680e8838824e8b3f120c5f4c1672
-SIZE (RainerKuemmerle-g2o-20201223_git_GH0.tar.gz) = 1571290
+TIMESTAMP = 1677548063
+SHA256 (RainerKuemmerle-g2o-20230223_git_GH0.tar.gz) = c8cf002f636ce2e83fc96f5e8257be4020cf1ae9f6a9d71838ec024f4d8a16cf
+SIZE (RainerKuemmerle-g2o-20230223_git_GH0.tar.gz) = 1587911
diff --git a/math/g2o/pkg-plist b/math/g2o/pkg-plist
index 0a23f4d0ae7b..22dd95f175d0 100644
--- a/math/g2o/pkg-plist
+++ b/math/g2o/pkg-plist
@@ -1,8 +1,24 @@
bin/g2o
bin/g2o_anonymize_observations
+bin/g2o_incremental
+bin/g2o_online
bin/g2o_simulator2d
bin/g2o_simulator3d
bin/g2o_viewer
+include/g2o/EXTERNAL/ceres/LICENSE
+include/g2o/EXTERNAL/ceres/array_selector.h
+include/g2o/EXTERNAL/ceres/autodiff.h
+include/g2o/EXTERNAL/ceres/disable_warnings.h
+include/g2o/EXTERNAL/ceres/eigen.h
+include/g2o/EXTERNAL/ceres/fixed_array.h
+include/g2o/EXTERNAL/ceres/integer_sequence_algorithm.h
+include/g2o/EXTERNAL/ceres/jet.h
+include/g2o/EXTERNAL/ceres/memory.h
+include/g2o/EXTERNAL/ceres/parameter_dims.h
+include/g2o/EXTERNAL/ceres/reenable_warnings.h
+include/g2o/EXTERNAL/ceres/types.h
+include/g2o/EXTERNAL/ceres/variadic_evaluate.h
+include/g2o/EXTERNAL/freeglut/freeglut_minimal.h
include/g2o/apps/g2o_cli/dl_wrapper.h
include/g2o/apps/g2o_cli/g2o_cli_api.h
include/g2o/apps/g2o_cli/g2o_common.h
@@ -50,14 +66,16 @@ include/g2o/apps/g2o_viewer/ui_base_main_window.h
include/g2o/apps/g2o_viewer/ui_base_properties_widget.h
include/g2o/apps/g2o_viewer/viewer_properties_widget.h
include/g2o/config.h
+include/g2o/core/auto_differentiation.h
include/g2o/core/base_binary_edge.h
-include/g2o/core/base_binary_edge.hpp
include/g2o/core/base_dynamic_vertex.h
include/g2o/core/base_edge.h
+include/g2o/core/base_fixed_sized_edge.h
+include/g2o/core/base_fixed_sized_edge.hpp
include/g2o/core/base_multi_edge.h
-include/g2o/core/base_multi_edge.hpp
include/g2o/core/base_unary_edge.h
-include/g2o/core/base_unary_edge.hpp
+include/g2o/core/base_variable_sized_edge.h
+include/g2o/core/base_variable_sized_edge.hpp
include/g2o/core/base_vertex.h
include/g2o/core/base_vertex.hpp
include/g2o/core/batch_stats.h
@@ -101,6 +119,15 @@ include/g2o/core/sparse_block_matrix_ccs.h
include/g2o/core/sparse_block_matrix_diagonal.h
include/g2o/core/sparse_optimizer.h
include/g2o/core/sparse_optimizer_terminate_action.h
+include/g2o/examples/interactive_slam/g2o_incremental/g2o_incremental_api.h
+include/g2o/examples/interactive_slam/g2o_incremental/graph_optimizer_sparse_incremental.h
+include/g2o/examples/interactive_slam/g2o_incremental/linear_solver_cholmod_online.h
+include/g2o/examples/interactive_slam/g2o_interactive/fast_output.h
+include/g2o/examples/interactive_slam/g2o_interactive/g2o_interactive_api.h
+include/g2o/examples/interactive_slam/g2o_interactive/g2o_slam_interface.h
+include/g2o/examples/interactive_slam/g2o_interactive/graph_optimizer_sparse_online.h
+include/g2o/examples/interactive_slam/g2o_interactive/types_slam2d_online.h
+include/g2o/examples/interactive_slam/g2o_interactive/types_slam3d_online.h
include/g2o/examples/interactive_slam/slam_parser/interface/abstract_slam_interface.h
include/g2o/examples/interactive_slam/slam_parser/interface/parser_interface.h
include/g2o/examples/interactive_slam/slam_parser/interface/slam_context_interface.h
@@ -113,9 +140,11 @@ include/g2o/examples/interactive_slam/slam_parser/parser/position.hh
include/g2o/examples/interactive_slam/slam_parser/parser/scanner.h
include/g2o/examples/interactive_slam/slam_parser/parser/slam_context.h
include/g2o/examples/interactive_slam/slam_parser/parser/stack.hh
-include/g2o/freeglut/freeglut_minimal.h
+include/g2o/solvers/cholmod/cholmod_wrapper.h
+include/g2o/solvers/cholmod/linear_solver_cholmod.h
include/g2o/solvers/csparse/csparse_extension.h
include/g2o/solvers/csparse/csparse_helper.h
+include/g2o/solvers/csparse/csparse_wrapper.h
include/g2o/solvers/csparse/g2o_csparse_api.h
include/g2o/solvers/csparse/g2o_csparse_extension_api.h
include/g2o/solvers/csparse/linear_solver_csparse.h
@@ -137,11 +166,11 @@ include/g2o/stuff/opengl_wrapper.h
include/g2o/stuff/os_specific.h
include/g2o/stuff/property.h
include/g2o/stuff/sampler.h
-include/g2o/stuff/scoped_pointer.h
include/g2o/stuff/sparse_helper.h
include/g2o/stuff/string_tools.h
include/g2o/stuff/tictoc.h
include/g2o/stuff/timeutil.h
+include/g2o/stuff/tuple_tools.h
include/g2o/stuff/unscented.h
include/g2o/types/data/data_queue.h
include/g2o/types/data/g2o_types_data_api.h
@@ -154,10 +183,27 @@ include/g2o/types/data/vertex_ellipse.h
include/g2o/types/data/vertex_tag.h
include/g2o/types/icp/g2o_types_icp_api.h
include/g2o/types/icp/types_icp.h
+include/g2o/types/sba/edge_project_p2mc.h
+include/g2o/types/sba/edge_project_p2sc.h
+include/g2o/types/sba/edge_project_psi2uv.h
+include/g2o/types/sba/edge_project_stereo_xyz.h
+include/g2o/types/sba/edge_project_stereo_xyz_onlypose.h
+include/g2o/types/sba/edge_project_xyz.h
+include/g2o/types/sba/edge_project_xyz2uv.h
+include/g2o/types/sba/edge_project_xyz2uvu.h
+include/g2o/types/sba/edge_project_xyz_onlypose.h
+include/g2o/types/sba/edge_sba_cam.h
+include/g2o/types/sba/edge_sba_scale.h
+include/g2o/types/sba/edge_se3_expmap.h
include/g2o/types/sba/g2o_types_sba_api.h
+include/g2o/types/sba/parameter_cameraparameters.h
+include/g2o/types/sba/sba_utils.h
include/g2o/types/sba/sbacam.h
include/g2o/types/sba/types_sba.h
include/g2o/types/sba/types_six_dof_expmap.h
+include/g2o/types/sba/vertex_cam.h
+include/g2o/types/sba/vertex_intrinsics.h
+include/g2o/types/sba/vertex_se3_expmap.h
include/g2o/types/sclam2d/edge_se2_odom_differential_calib.h
include/g2o/types/sclam2d/edge_se2_sensor_calib.h
include/g2o/types/sclam2d/g2o_types_sclam2d_api.h
@@ -239,10 +285,13 @@ lib/libg2o_core.so
lib/libg2o_csparse_extension.so
lib/libg2o_ext_freeglut_minimal.so
lib/libg2o_hierarchical.so
+lib/libg2o_incremental.so
+lib/libg2o_interactive.so
lib/libg2o_interface.so
lib/libg2o_opengl_helper.so
lib/libg2o_parser.so
lib/libg2o_simulator.so
+lib/libg2o_solver_cholmod.so
lib/libg2o_solver_csparse.so
lib/libg2o_solver_dense.so
lib/libg2o_solver_eigen.so