aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-20 16:07:27 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-20 21:04:37 +0000
commite42223a0756acf2c10f135d1688f8ed793054a15 (patch)
treead4a76d5eab1b2560fe3cb52cf5bce3799697e75
parent8fce7fa967f73d7f5e0c65698581ccdc2d055a19 (diff)
downloadports-e42223a0756acf2c10f135d1688f8ed793054a15.tar.gz
ports-e42223a0756acf2c10f135d1688f8ed793054a15.zip
textproc/amberfish: Optional USES=makeinfo
- Utilize USES=makeinfo only when used specially for DOCS only in this case. - Pet portclippy
-rw-r--r--textproc/amberfish/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/textproc/amberfish/Makefile b/textproc/amberfish/Makefile
index ab46d4fd9376..5eb44ab2d09e 100644
--- a/textproc/amberfish/Makefile
+++ b/textproc/amberfish/Makefile
@@ -14,15 +14,20 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libxerces-c.so:textproc/xerces-c3
-USES= gmake makeinfo
+USES= gmake
+
GNU_CONFIGURE= yes
+
ALL_TARGET= all html
-PLIST_FILES= bin/af man/man1/af.1.gz
+PLIST_FILES= bin/af
PORTDOCS= *
OPTIONS_DEFINE= DOCS
+DOCS_USES= makeinfo
+DOCS_PLIST_FILES= man/man1/af.1.gz
+
post-extract:
${CP} ${FILESDIR}/porter.cc ${WRKSRC}/src
@@ -36,6 +41,10 @@ post-patch:
s|make strip|| ; \
s|cp |$${BSD_INSTALL_PROGRAM} |' ${WRKSRC}/src/Makefile.in
+post-patch-DOCS-off:
+ @${REINPLACE_CMD} -e \
+ '/cd doc/d' ${WRKSRC}/Makefile
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/amberfish.png ${STAGEDIR}${DOCSDIR}