aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-05-08 10:44:01 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-05-22 07:01:15 +0000
commite4570cbbfecd8cb30db25eb3d8daa7d25a7fc182 (patch)
tree4937feb249323a05d60043a853902bc94c657b07
parent373cc51e6cf84c02ac1b435e23c05709817cfd78 (diff)
downloadports-e4570cbbfecd8cb30db25eb3d8daa7d25a7fc182.tar.gz
ports-e4570cbbfecd8cb30db25eb3d8daa7d25a7fc182.zip
games/brutalchess: Fix correupted files by dos2unix
Some files will not load properly due to ASCII conversion corruption. While here, fix other issues including patch format, USES_GL and general formatting. PR: 271303 Reported by: ntspam2@netscape.net Approved by: gustau.perez@gmail.com (maintainer, timeout > 2 weeks) MFH: 2023Q2 (runtime fix) (cherry picked from commit 4f3963f7db891c62a573f85f8becbfba49b6a7a6)
-rw-r--r--games/brutalchess/Makefile26
-rw-r--r--games/brutalchess/files/patch-aclocal.m46
-rw-r--r--games/brutalchess/files/patch-install-sh (renamed from games/brutalchess/files/patch-install.sh)4
-rw-r--r--games/brutalchess/files/patch-src-md3view.cpp8
-rw-r--r--games/brutalchess/files/patch-src-objview.cpp10
-rw-r--r--games/brutalchess/files/patch-src_board.h2
-rw-r--r--games/brutalchess/files/patch-src_fontloader.h4
7 files changed, 37 insertions, 23 deletions
diff --git a/games/brutalchess/Makefile b/games/brutalchess/Makefile
index 9a245380b9fe..7e41b02e9c56 100644
--- a/games/brutalchess/Makefile
+++ b/games/brutalchess/Makefile
@@ -1,25 +1,39 @@
PORTNAME= brutalchess
PORTVERSION= 0.5.2
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-alpha/${PORTNAME}-alpha-${PORTVERSION}
DISTNAME= ${PORTNAME}-alpha-${PORTVERSION}-src
-LIB_DEPENDS= libfreetype.so:print/freetype2
-
MAINTAINER= gustau.perez@gmail.com
COMMENT= Nice looking OpenGL chess game
WWW= http://brutalchess.sourceforge.net/
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfreetype.so:print/freetype2
-GNU_CONFIGURE= yes
USES= dos2unix gl gmake libtool pkgconfig sdl xorg
-USE_GL= yes
+USE_GL= glu
USE_SDL= sdl image
USE_XORG= x11 xext xt xmu xi
+
+DOS2UNIX_FILES= brutalchess.nsi \
+ fonts/!pizzadude.txt \
+ models/debug.obj \
+ NEWS \
+ README \
+ src/board.cpp \
+ src/board.h \
+ src/boardmove.cpp \
+ src/brutalchess.cpp \
+ src/brutalplayer.cpp
+
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
BINARY_ALIAS= freetype-config=true
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
pre-build:
${CHMOD} 0755 ${WRKSRC}/install-sh
diff --git a/games/brutalchess/files/patch-aclocal.m4 b/games/brutalchess/files/patch-aclocal.m4
index 6e0f4e152eb0..18906b9274e6 100644
--- a/games/brutalchess/files/patch-aclocal.m4
+++ b/games/brutalchess/files/patch-aclocal.m4
@@ -1,6 +1,6 @@
---- aclocal.m4.orig Tue Feb 6 23:28:00 2007
-+++ aclocal.m4 Tue Feb 6 23:28:12 2007
-@@ -926,7 +926,7 @@
+--- aclocal.m4.orig 2006-12-27 04:28:00 UTC
++++ aclocal.m4
+@@ -926,7 +926,7 @@ fi
# restrict ourselves to GNU make (using the --version option ensures
# this.)
AC_DEFUN([AM_PROG_MKDIR_P],
diff --git a/games/brutalchess/files/patch-install.sh b/games/brutalchess/files/patch-install-sh
index 565fec308210..aac677cf3602 100644
--- a/games/brutalchess/files/patch-install.sh
+++ b/games/brutalchess/files/patch-install-sh
@@ -1,5 +1,5 @@
---- install-sh.orig Sat Mar 11 01:36:44 2006
-+++ install-sh Tue Feb 6 23:51:32 2007
+--- install-sh.orig 2006-03-11 00:36:44 UTC
++++ install-sh
@@ -0,0 +1,251 @@
+#!/bin/sh
+#
diff --git a/games/brutalchess/files/patch-src-md3view.cpp b/games/brutalchess/files/patch-src-md3view.cpp
index 5be8d4cf9243..364055d0f79d 100644
--- a/games/brutalchess/files/patch-src-md3view.cpp
+++ b/games/brutalchess/files/patch-src-md3view.cpp
@@ -1,6 +1,6 @@
---- src/md3view.cpp.orig 2007-09-02 15:56:32.000000000 +0200
-+++ src/md3view.cpp 2007-09-02 16:00:35.000000000 +0200
-@@ -72,7 +72,7 @@
+--- src/md3view.cpp.orig 2006-04-18 22:26:16 UTC
++++ src/md3view.cpp
+@@ -72,7 +72,7 @@ void quit( int returnCode )
exit( returnCode );
}
@@ -9,7 +9,7 @@
// function to reset our viewport after a window resize
int resizeWindow( int width, int height )
{
-@@ -108,7 +108,7 @@
+@@ -108,7 +108,7 @@ int resizeWindow( int width, int height )
// general OpenGL initialization function
diff --git a/games/brutalchess/files/patch-src-objview.cpp b/games/brutalchess/files/patch-src-objview.cpp
index 4d1415bc1a2d..f324ff90328c 100644
--- a/games/brutalchess/files/patch-src-objview.cpp
+++ b/games/brutalchess/files/patch-src-objview.cpp
@@ -1,6 +1,6 @@
---- src/objview.cpp.orig 2007-09-02 16:01:24.000000000 +0200
-+++ src/objview.cpp 2007-09-02 16:02:00.000000000 +0200
-@@ -73,7 +73,7 @@
+--- src/objview.cpp.orig 2006-04-18 20:34:25 UTC
++++ src/objview.cpp
+@@ -73,7 +73,7 @@ void quit( int returnCode )
exit( returnCode );
}
@@ -9,7 +9,7 @@
// function to reset our viewport after a window resize
int resizeWindow( int width, int height )
{
-@@ -109,7 +109,7 @@
+@@ -109,7 +109,7 @@ int resizeWindow( int width, int height )
// general OpenGL initialization function
@@ -18,7 +18,7 @@
{
cout << "Initializing OpenGL" << endl;
// Enable smooth shading
-@@ -158,7 +158,7 @@
+@@ -158,7 +158,7 @@ int initGL( GLvoid )
}
// Here goes our drawing code
diff --git a/games/brutalchess/files/patch-src_board.h b/games/brutalchess/files/patch-src_board.h
index 857147f510cb..84badbb7a6ca 100644
--- a/games/brutalchess/files/patch-src_board.h
+++ b/games/brutalchess/files/patch-src_board.h
@@ -1,4 +1,4 @@
---- src/board.h.orig 2013-10-01 21:08:24.000000000 +0000
+--- src/board.h.orig 2023-05-08 11:15:17 UTC
+++ src/board.h
@@ -12,6 +12,7 @@
#include <cstdio>
diff --git a/games/brutalchess/files/patch-src_fontloader.h b/games/brutalchess/files/patch-src_fontloader.h
index e1434464ce8d..649bb834c1ca 100644
--- a/games/brutalchess/files/patch-src_fontloader.h
+++ b/games/brutalchess/files/patch-src_fontloader.h
@@ -1,5 +1,5 @@
---- src/fontloader.h.orig 2013-12-13 10:49:49.000000000 +0100
-+++ src/fontloader.h 2013-12-13 10:50:39.000000000 +0100
+--- src/fontloader.h.orig 2006-12-19 04:00:01 UTC
++++ src/fontloader.h
@@ -12,11 +12,9 @@
//FreeType Headers
#include <ft2build.h>