aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:48:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:21 +0000
commite493afc7d8825448d4a24ed25d09677f63eb0185 (patch)
tree2b3b898a2c4b473213bbae3a5b5752f6a7c0a12b
parent85441e9beaf72bfe0784d7e37aceb471534bf6bb (diff)
downloadports-e493afc7d8825448d4a24ed25d09677f63eb0185.tar.gz
ports-e493afc7d8825448d4a24ed25d09677f63eb0185.zip
textproc/py-mdit-py-plugins: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--textproc/py-mdit-py-plugins/Makefile7
-rw-r--r--textproc/py-mdit-py-plugins/files/setup.py45
2 files changed, 3 insertions, 49 deletions
diff --git a/textproc/py-mdit-py-plugins/Makefile b/textproc/py-mdit-py-plugins/Makefile
index fe7cd288e74e..f20a551ccdce 100644
--- a/textproc/py-mdit-py-plugins/Makefile
+++ b/textproc/py-mdit-py-plugins/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mdit-py-plugins
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,14 +12,12 @@ WWW= https://github.com/executablebooks/mdit-py-plugins
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown-it-py>=1.0.0<3.0.0:textproc/py-markdown-it-py@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/textproc/py-mdit-py-plugins/files/setup.py b/textproc/py-mdit-py-plugins/files/setup.py
deleted file mode 100644
index 3a64613df499..000000000000
--- a/textproc/py-mdit-py-plugins/files/setup.py
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['mdit_py_plugins',
- 'mdit_py_plugins.amsmath',
- 'mdit_py_plugins.anchors',
- 'mdit_py_plugins.attrs',
- 'mdit_py_plugins.container',
- 'mdit_py_plugins.deflist',
- 'mdit_py_plugins.dollarmath',
- 'mdit_py_plugins.field_list',
- 'mdit_py_plugins.footnote',
- 'mdit_py_plugins.front_matter',
- 'mdit_py_plugins.myst_blocks',
- 'mdit_py_plugins.myst_role',
- 'mdit_py_plugins.tasklists',
- 'mdit_py_plugins.texmath',
- 'mdit_py_plugins.wordcount']
-
-package_data = \
-{'': ['*']}
-
-install_requires = \
-['markdown-it-py>=1.0.0,<3.0.0']
-
-extras_require = \
-{'code_style': ['pre-commit'],
- 'rtd': ['attrs', 'myst-parser~=0.16.1', 'sphinx-book-theme~=0.1.0'],
- 'testing': ['coverage', 'pytest', 'pytest-cov', 'pytest-regressions']}
-
-setup(name='mdit-py-plugins',
- version='%%PORTVERSION%%',
- description='Collection of plugins for markdown-it-py',
- author=None,
- author_email='Chris Sewell <chrisj_sewell@hotmail.com>',
- url=None,
- packages=packages,
- package_data=package_data,
- install_requires=install_requires,
- extras_require=extras_require,
- python_requires='>=3.7',
- )