aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-12 14:27:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-12 23:07:34 +0000
commite4dafddcdb495751bc4184f10f54b6120b80703c (patch)
tree9fb31f1da068c85e8c50871cea60a73f06285eb0
parentb5425aa1feaf494985606b9857d31772461aa264 (diff)
downloadports-e4dafddcdb495751bc4184f10f54b6120b80703c.tar.gz
ports-e4dafddcdb495751bc4184f10f54b6120b80703c.zip
devel/py-expecttest: New port:Implementation of expect tests
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-expecttest/Makefile22
-rw-r--r--devel/py-expecttest/distinfo3
-rw-r--r--devel/py-expecttest/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ef3a30fd6239..314c71d0d873 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4651,6 +4651,7 @@
SUBDIR += py-exceptiongroup
SUBDIR += py-executing
SUBDIR += py-expandvars
+ SUBDIR += py-expecttest
SUBDIR += py-expiringdict
SUBDIR += py-extras
SUBDIR += py-extremes
diff --git a/devel/py-expecttest/Makefile b/devel/py-expecttest/Makefile
new file mode 100644
index 000000000000..344468acf801
--- /dev/null
+++ b/devel/py-expecttest/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= expecttest
+DISTVERSION= 0.2.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Implementation of expect tests
+WWW= https://github.com/ezyang/expecttest
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-expecttest/distinfo b/devel/py-expecttest/distinfo
new file mode 100644
index 000000000000..a26628cb058f
--- /dev/null
+++ b/devel/py-expecttest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1707768829
+SHA256 (expecttest-0.2.1.tar.gz) = e52b1cf8a6f84506e6962a0bbdd248ea442124d826e849f263ec1c322ebb73f5
+SIZE (expecttest-0.2.1.tar.gz) = 6873
diff --git a/devel/py-expecttest/pkg-descr b/devel/py-expecttest/pkg-descr
new file mode 100644
index 000000000000..8843252d9cf2
--- /dev/null
+++ b/devel/py-expecttest/pkg-descr
@@ -0,0 +1,6 @@
+The expecttest library implements expect tests (also known as "golden" tests).
+Expect tests are a method of writing tests where instead of hard-coding the
+expected output of a test, you run the test to get the output, and the test
+framework automatically populates the expected output. If the output of the
+test changes, you can rerun the test with the environment variable
+EXPECTTEST_ACCEPT=1 to automatically update the expected output.