aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-27 02:03:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-27 02:04:36 +0000
commite50ee05d5e2ba7ea981aae3fdf52d544a3041b88 (patch)
tree192dfc39983570de2caf30689bb6181a4f72ba22
parent8b577eadeadf84edb08ac827f5aab7bac0a5da1f (diff)
downloadports-e50ee05d5e2ba7ea981aae3fdf52d544a3041b88.tar.gz
ports-e50ee05d5e2ba7ea981aae3fdf52d544a3041b88.zip
sysutils/rush: New port: Command-line tool for executing jobs in parallel
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rush/Makefile40
-rw-r--r--sysutils/rush/distinfo35
-rw-r--r--sysutils/rush/pkg-descr8
4 files changed, 84 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ea3a32b21667..dda66170e644 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1222,6 +1222,7 @@
SUBDIR += runit-faster
SUBDIR += runj
SUBDIR += runwhen
+ SUBDIR += rush
SUBDIR += rw
SUBDIR += s-tui
SUBDIR += s6
diff --git a/sysutils/rush/Makefile b/sysutils/rush/Makefile
new file mode 100644
index 000000000000..2537d867c03d
--- /dev/null
+++ b/sysutils/rush/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= rush
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.2-9
+DISTVERSIONSUFFIX= -ga800565
+CATEGORIES= sysutils
+PKGNAMESUFFIX= -parallelization-tool
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Command-line tool for executing jobs in parallel
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= shenwei356
+GH_TUPLE= \
+ cznic:sortutil:f5f958428db8:cznic_sortutil/vendor/github.com/cznic/sortutil \
+ golang:sys:d5e6a3e2c0ae:golang_sys/vendor/golang.org/x/sys \
+ klauspost:compress:v1.12.3:klauspost_compress/vendor/github.com/klauspost/compress \
+ klauspost:pgzip:v1.2.5:klauspost_pgzip/vendor/github.com/klauspost/pgzip \
+ mattn:go-colorable:v0.1.8:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-isatty:v0.0.13:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ pkg:errors:v0.9.1:pkg_errors/vendor/github.com/pkg/errors \
+ shenwei356:bpool:f9e0ee4:shenwei356_bpool/vendor/github.com/shenwei356/bpool \
+ shenwei356:go-logging:c6b9702:shenwei356_go_logging/vendor/github.com/shenwei356/go-logging \
+ shenwei356:natsort:600d539:shenwei356_natsort/vendor/github.com/shenwei356/natsort \
+ shenwei356:util:v0.3.0:shenwei356_util/vendor/github.com/shenwei356/util \
+ shenwei356:xopen:f4f16dd:shenwei356_xopen/vendor/github.com/shenwei356/xopen \
+ shirou:gopsutil:v3.21.4:shirou_gopsutil/vendor/github.com/shirou/gopsutil \
+ spf13:cobra:v1.1.3:spf13_cobra/vendor/github.com/spf13/cobra \
+ spf13:pflag:v1.0.5:spf13_pflag/vendor/github.com/spf13/pflag \
+ tklauser:go-sysconf:v0.3.6:tklauser_go_sysconf/vendor/github.com/tklauser/go-sysconf
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/rush/distinfo b/sysutils/rush/distinfo
new file mode 100644
index 000000000000..521164ce2045
--- /dev/null
+++ b/sysutils/rush/distinfo
@@ -0,0 +1,35 @@
+TIMESTAMP = 1622080676
+SHA256 (shenwei356-rush-v0.4.2-9-ga800565_GH0.tar.gz) = c9dab98110f31599b939222231cd46d4cf219ea48deb1f6abf6ffd332ac9f5de
+SIZE (shenwei356-rush-v0.4.2-9-ga800565_GH0.tar.gz) = 42322
+SHA256 (cznic-sortutil-f5f958428db8_GH0.tar.gz) = a7f882d0c00359f7466b63c1effbef6d6cf999a96a41272408cd112936f67796
+SIZE (cznic-sortutil-f5f958428db8_GH0.tar.gz) = 4459
+SHA256 (golang-sys-d5e6a3e2c0ae_GH0.tar.gz) = 6cd44aa33cb0fc4caedadde44b3a943bece0aa67d803c00bfb09b03222845f19
+SIZE (golang-sys-d5e6a3e2c0ae_GH0.tar.gz) = 1539001
+SHA256 (klauspost-compress-v1.12.3_GH0.tar.gz) = d519f00315007cc0a187ac012fdeec7b0dca8701d46bb385fd8b00879c32c4e4
+SIZE (klauspost-compress-v1.12.3_GH0.tar.gz) = 15349860
+SHA256 (klauspost-pgzip-v1.2.5_GH0.tar.gz) = a64bad5981a232f6b5a40e488708b19a0551e83465f6792b7925f90829d7a830
+SIZE (klauspost-pgzip-v1.2.5_GH0.tar.gz) = 125923
+SHA256 (mattn-go-colorable-v0.1.8_GH0.tar.gz) = 1027954f9abbe06b6e117e3047af70204dd0eb4f8c27fcd459fb2574b279755f
+SIZE (mattn-go-colorable-v0.1.8_GH0.tar.gz) = 9571
+SHA256 (mattn-go-isatty-v0.0.13_GH0.tar.gz) = d25318d3c4e174e1ffb5d90c9d3e6887cc050f76e403b7b3d6163f4338fac952
+SIZE (mattn-go-isatty-v0.0.13_GH0.tar.gz) = 4440
+SHA256 (pkg-errors-v0.9.1_GH0.tar.gz) = 56bfd893023daa498508bfe161de1be83299fcf15376035e7df79cbd7d6fa608
+SIZE (pkg-errors-v0.9.1_GH0.tar.gz) = 13415
+SHA256 (shenwei356-bpool-f9e0ee4_GH0.tar.gz) = a27886f1b55634ca83ff4053dfe9f1914080e6b5d257cd5c1103db13c44fb354
+SIZE (shenwei356-bpool-f9e0ee4_GH0.tar.gz) = 7005
+SHA256 (shenwei356-go-logging-c6b9702_GH0.tar.gz) = 68ca51c09ab8d8605cfb4fb5cfe45032b2e466470d51db6e55b9a7a6ed132a53
+SIZE (shenwei356-go-logging-c6b9702_GH0.tar.gz) = 36393
+SHA256 (shenwei356-natsort-600d539_GH0.tar.gz) = d925add5f7a7fabcf6e11c9c7a99fe6883bb7859341fea6f3a1b08804552f9af
+SIZE (shenwei356-natsort-600d539_GH0.tar.gz) = 2868
+SHA256 (shenwei356-util-v0.3.0_GH0.tar.gz) = b62116fab0cc5d69f41fec9831a56bb4e64161ca60b10203f6a1bdcd7b3c006f
+SIZE (shenwei356-util-v0.3.0_GH0.tar.gz) = 14468
+SHA256 (shenwei356-xopen-f4f16dd_GH0.tar.gz) = 23b0667c28e74db1ef78ecf1ac6a71ed69f892ab5d661983065b71230215913c
+SIZE (shenwei356-xopen-f4f16dd_GH0.tar.gz) = 5385
+SHA256 (shirou-gopsutil-v3.21.4_GH0.tar.gz) = cc8e5e90d765d721c1b5fff4e5ccc9e181025c5ade442cccbe26a312174b8abb
+SIZE (shirou-gopsutil-v3.21.4_GH0.tar.gz) = 283974
+SHA256 (spf13-cobra-v1.1.3_GH0.tar.gz) = e5f93c61e1236e61c7fc45882d2a03b81f46ebebdf70628ebb64b0b5fe34f6fa
+SIZE (spf13-cobra-v1.1.3_GH0.tar.gz) = 146580
+SHA256 (spf13-pflag-v1.0.5_GH0.tar.gz) = 9a2cae1f8e8ab0d2cc8ebe468e871af28d9ac0962cf0520999e3ba85f0c7b808
+SIZE (spf13-pflag-v1.0.5_GH0.tar.gz) = 50796
+SHA256 (tklauser-go-sysconf-v0.3.6_GH0.tar.gz) = c3925a5ed176bc62dc1c1abcb3905eea8a0e6bbf001b4aba1a9fc830d40cc0ce
+SIZE (tklauser-go-sysconf-v0.3.6_GH0.tar.gz) = 27559
diff --git a/sysutils/rush/pkg-descr b/sysutils/rush/pkg-descr
new file mode 100644
index 000000000000..072cc0dbcbfb
--- /dev/null
+++ b/sysutils/rush/pkg-descr
@@ -0,0 +1,8 @@
+rush is a tool similar to GNU parallel and gargs. rush borrows some ideas from
+them and has some unique features, e.g., supporting custom defined variables,
+resuming multi-line commands, more advanced embedded replacement strings.
+
+These features make rush suitable for easy and flexibe parallelization of
+complex workflows in fields like Bioinformatics.
+
+WWW: https://github.com/shenwei356/rush