aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Rehbein <tobias.rehbein@web.de>2021-08-08 21:42:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 21:46:40 +0000
commite52c0266c99e9b5de18af55c2bb9bd4a208df7b6 (patch)
treea0329f8870eb5b8ee246cabb1a937f540b1d2ed3
parenta3abb6ed787917d0b8ef9da6837c25e414763efa (diff)
downloadports-e52c0266c99e9b5de18af55c2bb9bd4a208df7b6.tar.gz
ports-e52c0266c99e9b5de18af55c2bb9bd4a208df7b6.zip
net/tintin++: Add GNUTLS option
PR: 257592
-rw-r--r--net/tintin++/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index 252621df09cb..a3b72baf4169 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -15,19 +15,12 @@ LICENSE_FILE= ${WRKSRC}/../COPYING
LIB_DEPENDS= libpcre.so:devel/pcre
-CONFLICTS_INSTALL?= zh-tintin++
-
-OPTIONS_DEFINE= BIG5 DOCS
-BIG5_DESC= Big5 support
-
USES= gmake localbase
CONFIGURE_ARGS= --includedir=${LOCALBASE}/include \
--libdir=${LOCALBASE}/lib \
--prefix=${PREFIX}
-CONFIGURE_ENV= ac_cv_file__dev_ptmx=no \
- ac_cv_header_gnutls_gnutls_h=no \
- ac_cv_lib_gnutls_gnutls_init=no
+CONFIGURE_ENV= ac_cv_file__dev_ptmx=no
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/tt/src
@@ -36,9 +29,17 @@ DOCS= CREDITS FAQ README SCRIPTS TODO \
PLIST_FILES= bin/tt++
PORTDOCS= ${DOCS:T}
+CONFLICTS_INSTALL?= zh-tintin++
+
SLAVEDIRS= chinese/tintin++
+OPTIONS_DEFINE= BIG5 DOCS GNUTLS
+BIG5_DESC= Big5 support
+
BIG5_CONFIGURE_ENABLE= big5
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+GNUTLS_CONFIGURE_ENV_OFF= ac_cv_header_gnutls_gnutls_h=no \
+ ac_cv_lib_gnutls_gnutls_init=no
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${STAGEDIR}${PREFIX}/bin/