aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-19 18:33:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-19 18:42:28 +0000
commite65d3eeb6a497f9af9aff37eda0ee050e70dd5c6 (patch)
tree714ca4f1a0b05d0ada5df79417bc0f48551cddeb
parent930dd6f8ac0118b7e760258a163b084e0c94a284 (diff)
downloadports-e65d3eeb6a497f9af9aff37eda0ee050e70dd5c6.tar.gz
ports-e65d3eeb6a497f9af9aff37eda0ee050e70dd5c6.zip
audio/yoshimi: Fix bug when yoshimi asserted because it defaulted to ALSA
... which it isn't linked with. PR: 269673 Reported by: Luc <lucmove@gmail.com>
-rw-r--r--audio/yoshimi/Makefile3
-rw-r--r--audio/yoshimi/files/patch-src_globals.h15
2 files changed, 18 insertions, 0 deletions
diff --git a/audio/yoshimi/Makefile b/audio/yoshimi/Makefile
index e7042f0d9b58..50de08285173 100644
--- a/audio/yoshimi/Makefile
+++ b/audio/yoshimi/Makefile
@@ -1,5 +1,6 @@
PORTNAME= yoshimi
DISTVERSION= 2.2.2.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${DISTVERSION:R:R}
@@ -30,4 +31,6 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
+# ALSA can also be enabled, but its build fails, see https://github.com/Yoshimi/yoshimi/issues/175
+
.include <bsd.port.mk>
diff --git a/audio/yoshimi/files/patch-src_globals.h b/audio/yoshimi/files/patch-src_globals.h
new file mode 100644
index 000000000000..272ba8a39937
--- /dev/null
+++ b/audio/yoshimi/files/patch-src_globals.h
@@ -0,0 +1,15 @@
+- workaround for https://github.com/Yoshimi/yoshimi/issues/174
+
+--- src/globals.h.orig 2023-02-19 18:22:47 UTC
++++ src/globals.h
+@@ -126,8 +126,8 @@ typedef unsigned int uint;
+ #define DEFAULT_NAME "Simple Sound"
+ #define UNTITLED "No Title"
+
+-#define DEFAULT_AUDIO alsa_audio
+-#define DEFAULT_MIDI alsa_midi
++#define DEFAULT_AUDIO jack_audio
++#define DEFAULT_MIDI jack_midi
+
+ #define FORCED_EXIT 16
+