aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-06-05 19:54:00 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-06-06 19:05:47 +0000
commite670e294551e70e244f06997d37957680e955fb5 (patch)
tree703df23e7502032d3ea28aa62aff2e57d23a4ffd
parent0bed524c23d91ef3d22daeb75d406ceba89bd457 (diff)
downloadports-e670e294551e70e244f06997d37957680e955fb5.tar.gz
ports-e670e294551e70e244f06997d37957680e955fb5.zip
www/libnghttp3: Improve port
* Switch to CMake for faster builds * Remove C++ requirements, we don't build anything that's written in C++ * Rearrange Makefile to follow Porters Handbook more closely and for readability * Enable "make test" PR: 274761 Approved by: portmgr (maintainer timeout, 3+ weeks)
-rw-r--r--www/libnghttp3/Makefile16
-rw-r--r--www/libnghttp3/distinfo2
-rw-r--r--www/libnghttp3/files/patch-Makefile.in14
3 files changed, 9 insertions, 23 deletions
diff --git a/www/libnghttp3/Makefile b/www/libnghttp3/Makefile
index ec31e881245a..01f1413e7b23 100644
--- a/www/libnghttp3/Makefile
+++ b/www/libnghttp3/Makefile
@@ -1,7 +1,8 @@
PORTNAME= nghttp3
-PORTVERSION= 1.3.0
+DISTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= www net
-MASTER_SITES= https://github.com/ngtcp2/nghttp3/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/ngtcp2/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,12 +13,11 @@ WWW= https://nghttp2.org/nghttp3/ \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++17-lang libtool pathfix pkgconfig tar:xz
-
-CONFIGURE_ARGS= --enable-lib-only
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++17
+USES= cmake pathfix tar:xz
USE_LDCONFIG= yes
+TEST_TARGET= check
+
+CMAKE_ON= ENABLE_LIB_ONLY
+
.include <bsd.port.mk>
diff --git a/www/libnghttp3/distinfo b/www/libnghttp3/distinfo
index 04b98100afcc..406d4110dd19 100644
--- a/www/libnghttp3/distinfo
+++ b/www/libnghttp3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1715842554
+TIMESTAMP = 1715403946
SHA256 (nghttp3-1.3.0.tar.xz) = 450525981d302f23832b18edd1a62cf58019392ca6402408d0eb1a7f3fd92ecf
SIZE (nghttp3-1.3.0.tar.xz) = 390176
diff --git a/www/libnghttp3/files/patch-Makefile.in b/www/libnghttp3/files/patch-Makefile.in
deleted file mode 100644
index 130c25e3faba..000000000000
--- a/www/libnghttp3/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.in.orig 2022-01-22 09:12:33 UTC
-+++ Makefile.in
-@@ -404,9 +404,9 @@ top_srcdir = @top_srcdir@
- # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
- # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
--SUBDIRS = lib tests doc examples
-+SUBDIRS = lib
- ACLOCAL_AMFLAGS = -I m4
--dist_doc_DATA = README.rst
-+dist_doc_DATA =
- EXTRA_DIST = \
- cmakeconfig.h.in \
- CMakeLists.txt \