aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-06-11 13:44:28 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-07-01 19:35:09 +0000
commite67fd2055284ecb769e1ea1b892c11ade54be1b0 (patch)
tree062869f89a5b4c4fcc61af5763fde52913a0084c
parentdb91799d153b570a9309e34200f31863ef4ed9a8 (diff)
downloadports-e67fd2055284ecb769e1ea1b892c11ade54be1b0.tar.gz
ports-e67fd2055284ecb769e1ea1b892c11ade54be1b0.zip
multimedia/gstreamer1-editing-services: update to 1.16.3 and use meson
* Switch to meson for the build, re-enabling Python 3.10+ compat. * Add gstreamer1-validate support and LIB_DEPENDS. * Drop __pycache__ from install and Perl5 and autotools from requisites. Reported by: VVD@unislabs.com (IRC) Discussed with: vishwin@, diizzy@ PR: 264611 Approved by: maintainer timeout (multimedia@, 19 d)
-rw-r--r--multimedia/gstreamer1-editing-services/Makefile23
-rw-r--r--multimedia/gstreamer1-editing-services/distinfo6
-rw-r--r--multimedia/gstreamer1-editing-services/pkg-plist4
3 files changed, 18 insertions, 15 deletions
diff --git a/multimedia/gstreamer1-editing-services/Makefile b/multimedia/gstreamer1-editing-services/Makefile
index 70e33204d24b..389e6cec6baa 100644
--- a/multimedia/gstreamer1-editing-services/Makefile
+++ b/multimedia/gstreamer1-editing-services/Makefile
@@ -1,8 +1,7 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
PORTNAME= gstreamer1-editing-services
-PORTVERSION= 1.16.2
-PORTREVISION= 2
+PORTVERSION= 1.16.3
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer-editing-services/
DISTNAME= gstreamer-editing-services-${PORTVERSION}
@@ -12,17 +11,21 @@ COMMENT= GStreamer editing services
LICENSE= LGPL20
-USES= compiler:c11 gmake gnome gstreamer libtool pathfix perl5 python:3.6-3.9 pkgconfig tar:xz
+USES= compiler:c11 gnome gstreamer meson python pkgconfig tar:xz
USE_LDCONFIG= yes
-USE_PERL5= build
-GNU_CONFIGURE= yes
USE_GNOME= glib20 introspection:build libxml2 pygobject3:build
-USE_GSTREAMER= good
-INSTALL_TARGET= install-strip
+USE_GSTREAMER= good bad
+LIB_DEPENDS+= libgstvalidate-1.0.so:multimedia/gstreamer1-validate
PORTSCOUT= limitw:1,even
-CONFIGURE_ARGS= --enable-introspection=yes \
- --with-bash-completion-dir=${PREFIX}/share/bash-completion/completions
-PLIST_SUB= VERSION=1.0 SOVERSION=0.1602.0
+CONFIGURE_ARGS= -D gtk_doc=disabled \
+ -D introspection=enabled \
+ -D pygi-overrides-dir=${PYTHON_SITELIBDIR}/gstreamer-editing-services
+PLIST_SUB= VERSION=1.0 SOVERSION=0.1603.0
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/bash-completion/completions
+ ${INSTALL_SCRIPT} ${WRKSRC}/data/completions/ges-launch-1.0 \
+ ${STAGEDIR}${PREFIX}/share/bash-completion/completions/
.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-editing-services/distinfo b/multimedia/gstreamer1-editing-services/distinfo
index 1c5761c4cc48..51d19f59607d 100644
--- a/multimedia/gstreamer1-editing-services/distinfo
+++ b/multimedia/gstreamer1-editing-services/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575825901
-SHA256 (gstreamer-editing-services-1.16.2.tar.xz) = 0e06a6191a0c6c16e16272bf2573cecaeb245f10629486ad940a299bef700c16
-SIZE (gstreamer-editing-services-1.16.2.tar.xz) = 1086324
+TIMESTAMP = 1654955116
+SHA256 (gstreamer-editing-services-1.16.3.tar.xz) = 9b05cbb8a6f1db53999e7ad11f00f4f1ccc154d6805b7e49cb7755eb37a99ba6
+SIZE (gstreamer-editing-services-1.16.3.tar.xz) = 1091208
diff --git a/multimedia/gstreamer1-editing-services/pkg-plist b/multimedia/gstreamer1-editing-services/pkg-plist
index a3ac2aad5be9..918a07698746 100644
--- a/multimedia/gstreamer1-editing-services/pkg-plist
+++ b/multimedia/gstreamer1-editing-services/pkg-plist
@@ -60,15 +60,15 @@ include/gstreamer-%%VERSION%%/ges/ges-video-uri-source.h
include/gstreamer-%%VERSION%%/ges/ges-xml-formatter.h
include/gstreamer-%%VERSION%%/ges/ges.h
lib/girepository-1.0/GES-%%VERSION%%.typelib
+lib/gst-validate-launcher/python/launcher/apps/geslaunch.py
lib/gstreamer-%%VERSION%%/libgstges.so
lib/gstreamer-%%VERSION%%/libgstnle.so
lib/libges-%%VERSION%%.so
lib/libges-%%VERSION%%.so.0
lib/libges-%%VERSION%%.so.%%SOVERSION%%
%%PYTHON_SITELIBDIR%%/gstreamer-editing-services/GES.py
-%%PYTHON_SITELIBDIR%%/gstreamer-editing-services/__pycache__/GES.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
-%%PYTHON_SITELIBDIR%%/gstreamer-editing-services/__pycache__/GES.cpython-%%PYTHON_SUFFIX%%.pyc
libdata/pkgconfig/gst-editing-services-%%VERSION%%.pc
man/man1/ges-launch-%%VERSION%%.1.gz
share/bash-completion/completions/ges-launch-%%VERSION%%
share/gir-1.0/GES-%%VERSION%%.gir
+share/gstreamer-%%VERSION%%/validate/scenarios/ges-edit-clip-while-paused.scenario