aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-26 05:38:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-26 05:39:40 +0000
commite6a3abc3c8260427f41eb4e50d57cc1bceb891f7 (patch)
tree963ff07a8ac2e11097dd1f1028987c0d81cb8031
parent3fc52e74dc06490cef518260cf3dbc8aa7d2eaae (diff)
downloadports-e6a3abc3c8260427f41eb4e50d57cc1bceb891f7.tar.gz
ports-e6a3abc3c8260427f41eb4e50d57cc1bceb891f7.zip
emulators/qemu-devel: Update to 20230731 snapshot
- Pet portclippy
-rw-r--r--emulators/qemu-devel/Makefile89
-rw-r--r--emulators/qemu-devel/distinfo30
-rw-r--r--emulators/qemu-devel/pkg-message29
3 files changed, 70 insertions, 78 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 626e11cc7a78..55c464e1e1af 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -1,5 +1,5 @@
PORTNAME= qemu
-DISTVERSION= 8.2.0.20230630
+DISTVERSION= 8.2.0.20230731
CATEGORIES= emulators
PKGNAMESUFFIX= -devel
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -21,37 +21,50 @@ LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
USES= bison compiler:c11 cpe gmake gnome iconv:wchar_t ninja perl5 \
pkgconfig python:build shebangfix tar:xz xorg
USE_GITLAB= yes
-USE_GNOME= cairo glib20 libxml2
-USE_PERL5= build
-USE_PYTHON= distutils noflavors
-USE_XORG= pixman
-
-SHEBANG_FILES= scripts/xml-preprocess.py
-
GL_ACCOUNT= qemu-project
-GL_TAGNAME= d39a84b7348faa5cd6b09921b57969482ca4c543
+GL_TAGNAME= 2fc36530dec61eb83c73f5684a0e8f55a0b9a4d1
GL_TUPLE= qemu-project:keycodemapdb:f5772a62ec52591ff6870b7e8ef32482371f22c6:keycodemapdb/subprojects/keycodemapdb \
qemu-project:dtc:b6910bec11614980a21e46fbccc35934b671bd81:dtc/subprojects/dtc \
qemu-project:libvfio-user:0b28d205572c80b568a1003db2c8f37ca333e4d7:libvfio/subprojects/libvfio-user \
- qemu-project:meson:9067139acb5f133e08ed15eba8a6d41246200b5b:meson/meson \
+ qemu-project:meson:cf5adf0c646474f0259d123fad60ca5ed38ec891:meson/meson \
qemu-project:berkeley-softfloat-3:b64af41c3276f97f0e181920400ee056b9c88037:berkeleysoftfloat3/subprojects/berkeley-softfloat-3 \
qemu-project:berkeley-testfloat-3:40619cbb3bf32872df8c53cc457039229428a263:berkeleytestfloat3/subprojects/berkeley-testfloat-3
+USE_GNOME= cairo glib20#libxml2
+USE_PERL5= build
+USE_PYTHON= distutils noflavors
+USE_XORG= pixman
+
+SHEBANG_FILES= scripts/xml-preprocess.py
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var --mandir=man --extra-ldflags=-L\"/usr/lib\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" --enable-debug \
+ --prefix=${PREFIX} --cc=${CC} --enable-netmap --disable-kvm \
+ --disable-linux-user --disable-linux-aio --disable-xen \
+ --enable-debug-info --python=${PYTHON_CMD} --disable-guest-agent \
+ --extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
+
+CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
+WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
+
+PORTDOCS= .buildinfo _static/* about/* dbus-dbusindex.html devel/* \
+ docs genindex.html index.html interop/* objects.inv \
+ search.html searchindex.js specs/* system/* tools/* user/*
-OPTIONS_SINGLE= NCURSES
-OPTIONS_SINGLE_NCURSES= NCURSES_DEFAULT NCURSES_BASE NCURSES_PORT
OPTIONS_DEFINE= SAMBA X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CURL VDE \
CDROM_DMA USBREDIR X86_TARGETS STATIC_LINK DOCS CAPSTONE
OPTIONS_DEFAULT=X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL NCURSES_DEFAULT VDE \
CAPSTONE
+OPTIONS_SINGLE= NCURSES
+OPTIONS_SINGLE_NCURSES= NCURSES_DEFAULT NCURSES_BASE NCURSES_PORT
OPTIONS_SUB= yes
+
CAPSTONE_DESC= Disassembly framework support
CDROM_DMA_DESC= IDE CDROM DMA
GNUTLS_DESC= gnutls dependency (vnc encryption)
JPEG_DESC= jpeg dependency (vnc lossy compression)
-NCURSES_DEFAULT_DESC= Depend on ncurses (ports if installed, otherwise base)
NCURSES_BASE_DESC= Depend on ncurses in base
+NCURSES_DEFAULT_DESC= Depend on ncurses (ports if installed, otherwise base)
NCURSES_PORT_DESC= Depend on devel/ncurses in ports
PNG_DESC= png dependency (vnc compression)
SAMBA_DESC= samba dependency (for -smb)
@@ -60,57 +73,45 @@ STATIC_LINK_DESC= Statically link the executables
USBREDIR_DESC= usb device network redirection (experimental!)
VDE_DESC= vde dependency (for vde networking)
X86_TARGETS_DESC= Build only x86 system targets
+
+CAPSTONE_LIB_DEPENDS= libcapstone.so:devel/capstone
CAPSTONE_CONFIGURE_ON= --enable-capstone --extra-cflags=-I${LOCALBASE}/include/capstone
CAPSTONE_CONFIGURE_OFF= --disable-capstone
-CAPSTONE_LIB_DEPENDS= libcapstone.so:devel/capstone
-CURL_CONFIGURE_OFF= --disable-curl
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-DOCS_CONFIGURE_ENABLE= docs
+CURL_CONFIGURE_OFF= --disable-curl
DOCS_USES= makeinfo
-GNUTLS_CONFIGURE_OFF= --disable-gnutls
+DOCS_CONFIGURE_ENABLE= docs
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-GTK3_CONFIGURE_OFF= --disable-gtk --disable-vte
+GNUTLS_CONFIGURE_OFF= --disable-gnutls
GTK3_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
-GTK3_USE= GNOME=gdkpixbuf2,gtk30,vte3 XORG=x11,xext
GTK3_USES= gettext gl
-JPEG_CONFIGURE_OFF= --disable-vnc-jpeg
+GTK3_USE= GNOME=gdkpixbuf2,gtk30,vte3 XORG=x11,xext
+GTK3_CONFIGURE_OFF= --disable-gtk --disable-vte
JPEG_USES= jpeg
-NCURSES_DEFAULT_USES= ncurses
+JPEG_CONFIGURE_OFF= --disable-vnc-jpeg
NCURSES_BASE_USES= ncurses:base
+NCURSES_DEFAULT_USES= ncurses
NCURSES_PORT_USES= ncurses:port
-OPENGL_CONFIGURE_OFF= --disable-opengl
-OPENGL_USE= GL=gbm,gl
OPENGL_USES= gl
+OPENGL_USE= GL=gbm,gl
+OPENGL_CONFIGURE_OFF= --disable-opengl
+PNG_LIB_DEPENDS= libpng16.so:graphics/png
PNG_CONFIGURE_OFF= --disable-vnc-png
-PNG_LIB_DEPENDS= libpng.so:graphics/png
+SAMBA_USES= samba:run # smbd
SAMBA_CONFIGURE_ON= --smbd=${LOCALBASE}/sbin/smbd
+#SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_CONFIGURE_OFF= --disable-vnc-sasl
-SAMBA_USES= samba:run # smbd
-SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
-STATIC_LINK_CONFIGURE_ON= --static
STATIC_LINK_PREVENTS= GTK3 X11
STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
+STATIC_LINK_CONFIGURE_ON= --static
USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
-USBREDIR_CONFIGURE_OFF= --disable-usb-redir
USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
+USBREDIR_CONFIGURE_OFF= --disable-usb-redir
+#VDE_LIB_DEPENDS= libvdeplug.so:net/vde2
VDE_CONFIGURE_OFF= --disable-vde
-VDE_LIB_DEPENDS= libvdeplug.so:net/vde2
-X11_CONFIGURE_ENABLE= sdl
-X11_USE= SDL=sdl2 XORG=x11,xext GNOME=gdkpixbuf2
X11_USES= sdl
-
-PORTDOCS= .buildinfo _static/* about/* dbus-dbusindex.html devel/* \
- docs genindex.html index.html interop/* objects.inv \
- search.html searchindex.js specs/* system/* tools/* user/*
-
-WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
-CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
-CONFIGURE_ARGS= --localstatedir=/var --mandir=man --extra-ldflags=-L\"/usr/lib\" \
- --extra-ldflags=-L\"${LOCALBASE}/lib\" --enable-debug \
- --prefix=${PREFIX} --cc=${CC} --enable-netmap --disable-kvm \
- --disable-linux-user --disable-linux-aio --disable-xen \
- --enable-debug-info --python=${PYTHON_CMD} --disable-guest-agent \
- --extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
+X11_USE= SDL=sdl2 XORG=x11,xext GNOME=gdkpixbuf2
+X11_CONFIGURE_ENABLE= sdl
.include <bsd.port.options.mk>
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index b98e45fd1e7d..3f1ad6ab5835 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,15 +1,15 @@
-TIMESTAMP = 1695554498
-SHA256 (qemu/8.2.0.20230630/qemu-project-qemu-d39a84b7348faa5cd6b09921b57969482ca4c543_GL0.tar.gz) = bbc7f03c310462b91523bf1a4313a296cee60cbfa7ccdb7d3d5c6d85e17be5ad
-SIZE (qemu/8.2.0.20230630/qemu-project-qemu-d39a84b7348faa5cd6b09921b57969482ca4c543_GL0.tar.gz) = 36907702
-SHA256 (qemu/8.2.0.20230630/qemu-project-keycodemapdb-f5772a62ec52591ff6870b7e8ef32482371f22c6_GL0.tar.gz) = d014b53382dbb17b8196ad12f50de7f20d0ef1b9f7d54b0be51a6cbb14209195
-SIZE (qemu/8.2.0.20230630/qemu-project-keycodemapdb-f5772a62ec52591ff6870b7e8ef32482371f22c6_GL0.tar.gz) = 29580
-SHA256 (qemu/8.2.0.20230630/qemu-project-dtc-b6910bec11614980a21e46fbccc35934b671bd81_GL0.tar.gz) = e115f987eec23a1ba25150a46ced1675de3716072d3b4905afb3a9cda0f007c7
-SIZE (qemu/8.2.0.20230630/qemu-project-dtc-b6910bec11614980a21e46fbccc35934b671bd81_GL0.tar.gz) = 205556
-SHA256 (qemu/8.2.0.20230630/qemu-project-libvfio-user-0b28d205572c80b568a1003db2c8f37ca333e4d7_GL0.tar.gz) = d2f60cd4f86f345aab1332953eb736cce3518159e6e99bcc2d10467c06f717fe
-SIZE (qemu/8.2.0.20230630/qemu-project-libvfio-user-0b28d205572c80b568a1003db2c8f37ca333e4d7_GL0.tar.gz) = 189943
-SHA256 (qemu/8.2.0.20230630/qemu-project-meson-9067139acb5f133e08ed15eba8a6d41246200b5b_GL0.tar.gz) = 0ba61decdf3c5678e3f79896b0c5b3c8f8341b326836ef5592842dd048201a33
-SIZE (qemu/8.2.0.20230630/qemu-project-meson-9067139acb5f133e08ed15eba8a6d41246200b5b_GL0.tar.gz) = 4694698
-SHA256 (qemu/8.2.0.20230630/qemu-project-berkeley-softfloat-3-b64af41c3276f97f0e181920400ee056b9c88037_GL0.tar.gz) = faae889814ea6a292f7ca03d9b36e6c7e95bab2a64777804883cc822b8d48757
-SIZE (qemu/8.2.0.20230630/qemu-project-berkeley-softfloat-3-b64af41c3276f97f0e181920400ee056b9c88037_GL0.tar.gz) = 148741
-SHA256 (qemu/8.2.0.20230630/qemu-project-berkeley-testfloat-3-40619cbb3bf32872df8c53cc457039229428a263_GL0.tar.gz) = e1374054bc43d75436f1454f92a2e4208046858ee03086d1f2dc5de6d09a3d66
-SIZE (qemu/8.2.0.20230630/qemu-project-berkeley-testfloat-3-40619cbb3bf32872df8c53cc457039229428a263_GL0.tar.gz) = 139281
+TIMESTAMP = 1695662613
+SHA256 (qemu/8.2.0.20230731/qemu-project-qemu-2fc36530dec61eb83c73f5684a0e8f55a0b9a4d1_GL0.tar.gz) = be64d80c6219b782a67d967ec1d378bc033dd6c2793e9c4a3d123ae57aeaef2d
+SIZE (qemu/8.2.0.20230731/qemu-project-qemu-2fc36530dec61eb83c73f5684a0e8f55a0b9a4d1_GL0.tar.gz) = 37023513
+SHA256 (qemu/8.2.0.20230731/qemu-project-keycodemapdb-f5772a62ec52591ff6870b7e8ef32482371f22c6_GL0.tar.gz) = d014b53382dbb17b8196ad12f50de7f20d0ef1b9f7d54b0be51a6cbb14209195
+SIZE (qemu/8.2.0.20230731/qemu-project-keycodemapdb-f5772a62ec52591ff6870b7e8ef32482371f22c6_GL0.tar.gz) = 29580
+SHA256 (qemu/8.2.0.20230731/qemu-project-dtc-b6910bec11614980a21e46fbccc35934b671bd81_GL0.tar.gz) = e115f987eec23a1ba25150a46ced1675de3716072d3b4905afb3a9cda0f007c7
+SIZE (qemu/8.2.0.20230731/qemu-project-dtc-b6910bec11614980a21e46fbccc35934b671bd81_GL0.tar.gz) = 205556
+SHA256 (qemu/8.2.0.20230731/qemu-project-libvfio-user-0b28d205572c80b568a1003db2c8f37ca333e4d7_GL0.tar.gz) = d2f60cd4f86f345aab1332953eb736cce3518159e6e99bcc2d10467c06f717fe
+SIZE (qemu/8.2.0.20230731/qemu-project-libvfio-user-0b28d205572c80b568a1003db2c8f37ca333e4d7_GL0.tar.gz) = 189943
+SHA256 (qemu/8.2.0.20230731/qemu-project-meson-cf5adf0c646474f0259d123fad60ca5ed38ec891_GL0.tar.gz) = 10adb916bf6b18d7c2976e2276708aa23f9a78016cf3baba9e66975d027321cf
+SIZE (qemu/8.2.0.20230731/qemu-project-meson-cf5adf0c646474f0259d123fad60ca5ed38ec891_GL0.tar.gz) = 4717481
+SHA256 (qemu/8.2.0.20230731/qemu-project-berkeley-softfloat-3-b64af41c3276f97f0e181920400ee056b9c88037_GL0.tar.gz) = faae889814ea6a292f7ca03d9b36e6c7e95bab2a64777804883cc822b8d48757
+SIZE (qemu/8.2.0.20230731/qemu-project-berkeley-softfloat-3-b64af41c3276f97f0e181920400ee056b9c88037_GL0.tar.gz) = 148741
+SHA256 (qemu/8.2.0.20230731/qemu-project-berkeley-testfloat-3-40619cbb3bf32872df8c53cc457039229428a263_GL0.tar.gz) = e1374054bc43d75436f1454f92a2e4208046858ee03086d1f2dc5de6d09a3d66
+SIZE (qemu/8.2.0.20230731/qemu-project-berkeley-testfloat-3-40619cbb3bf32872df8c53cc457039229428a263_GL0.tar.gz) = 139281
diff --git a/emulators/qemu-devel/pkg-message b/emulators/qemu-devel/pkg-message
index 42b5a63da5e4..75988f78be41 100644
--- a/emulators/qemu-devel/pkg-message
+++ b/emulators/qemu-devel/pkg-message
@@ -18,12 +18,10 @@ FreeBSD host notes
qemu. (SAMBA knob.)
- If you want to use usb devices connected to the host in the guest
- yot need either recent 10-current (not tested yet much) or you can
- use usbredir over the network (see below); also unless you are
+ you can use usbredir over the network (see below); also unless you are
running qemu as root you then need to fix permissions for /dev/ugen*
- device nodes: if you are on 5.x or later (devfs) put a rule in
- /etc/devfs.rules, activate it in /etc/rc.conf and run /etc/rc.d/devfs
- restart. Example devfs.rules:
+ device nodes: put a rule in /etc/devfs.rules, activate it in
+ /etc/rc.conf and run /etc/rc.d/devfs restart. Example devfs.rules:
[ugen_ruleset=20]
add path 'ugen*' mode 660 group operator
@@ -77,7 +75,7 @@ processing error - resetting ehci HC
FreeBSD guest versions.]
- If you build qemu wihout SDL and then get crashes running it try passing it
- -nographic. This should probably be default in that case...
+ -nographic.
- qemu's network boot roms (-boot n) have a bug when bootfiles sizes are a
multiple of blksize, if this affects you (like with FreeBSD's /boot/pxeboot)
@@ -85,20 +83,13 @@ processing error - resetting ehci HC
cp /boot/pxeboot pxeboot-qemu && chmod +w pxeboot-qemu && echo >>pxeboot-qemu
- and then use pxeboot-qemu. Actually you need recent btx code
- (from after 7.0 was released) because of the real mode boot
- problem, so use at least pxeboot from there. And I just did that
- for the pxeboot extracted out of
+ and then use pxeboot-qemu. Actually you need recent btx code because
+ of the real mode boot problem, so use at least pxeboot from there.
- ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/200805/7.0-STABLE-200805-i386-bootonly.iso
-
- and placed it here:
-
- http://people.freebsd.org/~nox/qemu/pxeboot-qemu
-
-- If you use slirp (usernet, the default) and want to mount nfs into the guest
- and you are not running qemu as root, then mountd(8) on the exporting box
- needs to be run with -n in order to accept requests from ports >= 1024.
+- If you use slirp (usernet, the default) and want to mount nfs into the
+ guest and you are not running qemu as root, then mountd(8) on the
+ exporting box needs to be run with -n in order to accept requests from
+ ports >= 1024.
- (not FreeBSD-specific:) There have been reports of qcow2 corruption with (at
least) win2k guests on recent kvm (which uses similar qcow2 code than qemu