aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2023-04-21 20:21:16 +0000
committerEd Maste <emaste@FreeBSD.org>2023-04-24 19:05:08 +0000
commite6b5fb28a560cda9f101a2c2fc55ef70f00a2179 (patch)
tree35acfb8dbfbdfec74840476c1661929a412cf1ca
parentc1d46995f7f87c659067f4239b6e3123e560c05e (diff)
downloadports-e6b5fb28a560cda9f101a2c2fc55ef70f00a2179.tar.gz
ports-e6b5fb28a560cda9f101a2c2fc55ef70f00a2179.zip
math/trlan: fix build for base system WITH_LLVM_BINUTILS
Use strip --strip-unneeded instead of strip -x. strip -x strips all non-global symbols, but there are some non-global symbols referenced by relocations. ELF Tool Chain strip and GNU strip silently retain those symbols, but LLVM strip is more strict and reports an error. PR: 270958 Reviewed by: jrm Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D39754
-rw-r--r--math/trlan/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/trlan/Makefile b/math/trlan/Makefile
index 95896d36e1dc..50f208c37445 100644
--- a/math/trlan/Makefile
+++ b/math/trlan/Makefile
@@ -48,7 +48,7 @@ do-build:
@${ECHO_CMD} "Building static archive ..."
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} \
${ALL_TARGET}
- @${STRIP_CMD} -x -o ${WRKDIR}/libtrlan.a ${WRKSRC}/libtrlan.a
+ @${STRIP_CMD} --strip-unneeded -o ${WRKDIR}/libtrlan.a ${WRKSRC}/libtrlan.a
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} \
clean
@${ECHO_CMD} "Building shared library ..."