aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-07-17 00:54:21 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-07-17 01:12:32 +0000
commite6c9092be9fcb2de5d98bee1140e961275439512 (patch)
tree96489ae564ed4d452a0ca03410d27021ca893a70
parent9bab55b193f49a7ee83b2e6aeca81f66da7bed3a (diff)
downloadports-e6c9092be9fcb2de5d98bee1140e961275439512.tar.gz
ports-e6c9092be9fcb2de5d98bee1140e961275439512.zip
graphics/darktable: USES+=perl5
This is to make sure that PERL_LEVEL gets defined, which in turn is needed to make sure that perl's Pod::Parser gets defined if it is not part of the respective Perl version's install. Approved by: (blanket, trivial tested build fix) Error log in poudriere before patch: [00:17:46] [ 97% 727/747] cd /wrkdirs/usr/ports/graphics/darktable/work/darktable-3.4.1/doc/man && sh -c /usr/local/bin/po4a-translate\ -f\ pod\ -m\ darktable-generate-cache.pod\ -p\ po/es.po\ -l\ /wrkdirs/usr/ports/graphics/darktable/work/.build/doc/man/es/darktable-generate-cache.pod\ -k\ 0 [00:17:46] FAILED: doc/man/es/darktable-generate-cache.pod [00:17:46] cd /wrkdirs/usr/ports/graphics/darktable/work/darktable-3.4.1/doc/man && sh -c /usr/local/bin/po4a-translate\ -f\ pod\ -m\ darktable-generate-cache.pod\ -p\ po/es.po\ -l\ /wrkdirs/usr/ports/graphics/darktable/work/.build/doc/man/es/darktable-generate-cache.pod\ -k\ 0 [00:17:46] Unknown format type: pod. [00:17:46] po4a::chooser: Module loading error: Can't locate Pod/Parser.pm in @INC (you may need to install the Pod::Parser module) (@INC contains: /usr/local/lib/perl5/site_perl/mach/5.32 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.32/mach /usr/local/lib/perl5/5.32) at /usr/local/lib/perl5/site_perl/Locale/Po4a/Pod.pm line 14. [00:17:46] BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/Locale/Po4a/Pod.pm line 14. [00:17:46] Compilation failed in require at (eval 33) line 1. [00:17:46] BEGIN failed--compilation aborted at (eval 33) line 1.
-rw-r--r--graphics/darktable/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index e77d959f40ce..92e48e4e645d 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libcolord-gtk.so:graphics/colord-gtk \
libtiff.so:graphics/tiff
USES= cmake compiler:c++14-lang desktop-file-utils gl gnome jpeg \
- pkgconfig shebangfix sqlite tar:xz xorg
+ perl5 pkgconfig shebangfix sqlite tar:xz xorg
USE_GL= glu
USE_GNOME= cairo gtk30 intltool librsvg2 libxml2
INSTALLS_ICONS= yes