aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-08-20 16:06:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-08-25 21:35:37 +0000
commite6e0bd06a2eec3f9f5e2780869ce3682d6c81391 (patch)
tree52d45062667894b27523710054ce723749aefdbd
parent4b500674d50988b7ce3585914be27ef74fea3c1d (diff)
downloadports-e6e0bd06a2eec3f9f5e2780869ce3682d6c81391.tar.gz
ports-e6e0bd06a2eec3f9f5e2780869ce3682d6c81391.zip
lang/gcc11-devel: Expose non-default -stdlib=libc++ support
Fix -stdlib=libc++ option which produced "error: unrecognized command-line option '-stdlib=libc++'". PR: 265962 Approved by: salvadore (maintainer) Exp-run by: antoine (via bug 265964)
-rw-r--r--lang/gcc11-devel/Makefile2
-rw-r--r--lang/gcc11-devel/files/patch-libcxxrt18
2 files changed, 20 insertions, 0 deletions
diff --git a/lang/gcc11-devel/Makefile b/lang/gcc11-devel/Makefile
index 2cd4251925a3..cc779acc4c12 100644
--- a/lang/gcc11-devel/Makefile
+++ b/lang/gcc11-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 11.3.1.s20220819
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
@@ -103,6 +104,7 @@ CONFIGURE_ARGS+=--disable-nls \
--with-as=${LOCALBASE}/bin/as \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-gxx-libcxx-include-dir=/usr/include/c++/v1 \
--with-ld=${LOCALBASE}/bin/ld \
${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
diff --git a/lang/gcc11-devel/files/patch-libcxxrt b/lang/gcc11-devel/files/patch-libcxxrt
new file mode 100644
index 000000000000..a02a890266ae
--- /dev/null
+++ b/lang/gcc11-devel/files/patch-libcxxrt
@@ -0,0 +1,18 @@
+libc++ on FreeBSD always uses PathScale libcxxrt and cannot change to
+LLVM libc++abi without breaking backward compatibility. Besides, mixing
+different C++ ABIs is not supported unless subset via DT_FILTER.
+
+https://github.com/llvm/llvm-project/commit/35479ffb1251
+https://github.com/freebsd/freebsd-src/commit/cf56074e5271
+
+--- gcc/cp/g++spec.c.orig 2022-08-19 22:32:09 UTC
++++ gcc/cp/g++spec.c
+@@ -60,7 +60,7 @@ along with GCC; see the file COPYING3. If not see
+ #endif
+
+ #ifndef LIBCXXABI
+-#define LIBCXXABI "c++abi"
++#define LIBCXXABI "cxxrt"
+ #endif
+ #ifndef LIBCXXABI_PROFILE
+ #define LIBCXXABI_PROFILE LIBCXXABI